Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Sign in using an external account
Register Forgot Password?


E-Class (W211) 2003-2009

Sponsored by : Autohaus AZ
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 02-13-2012, 07:17 PM   #1
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
Arrow key fob issues

so i have had this problem where my key fob will not lock or unlock my doors. it will work sometimes but i have to point the remote directly at the door handle and be like 6 inches away, and then it seems to really only work at night... strange

i did a little research but i didnt really come up with a solution, from what i did gather though i heard that the long range of the remote works off the AM antenna, i was told that tint could possibly hinder this, but this weekend i re-tinted the back window and tried to it without tint but still no luck so i know its not the tint.

both remotes do this, i bought fresh batteries as well and still nothing.

any ideas?

thanks
To remove this ad, register today or login if you already are registered!

Craftysince86 is offline   Reply With Quote
Old 02-14-2012, 03:00 PM   #2
Newbie
 
Join Date: Jan 2010
Location: Marin County, CA
Posts: 12
Drives: 2011 E550 Coupe
jerryb2339
key fob

well, if both have that problem then it is a warranty issue - it's obviously the car not the keys, and it's probably the sensor in the car
jerryb2339 is offline   Reply With Quote
Old 02-14-2012, 03:10 PM   #3
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
car is no longer under warranty, so i was hoping maybe someone knew what was going on with it
Craftysince86 is offline   Reply With Quote
Old 02-14-2012, 03:27 PM   #4
Newbie
 
Join Date: Jan 2010
Location: Marin County, CA
Posts: 12
Drives: 2011 E550 Coupe
jerryb2339
it doesn't sound like it would be a non-dealer fix. I had trouble with a key in my last M-B and I tried new batteries and tried "cleaning" the ignition insert.....turned out to be a more "extensive" (read: expensive) sensor-type issue - some form of sensor was not always reading the key, so occasionally the car would not start the first time I turned the key. I had also assumed it might be the starter, but it was some electronic sensor device....made no difference....it was the same cost as a new starter.
jerryb2339 is offline   Reply With Quote
Old 02-14-2012, 04:14 PM   #5
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
my key turns the car on fine every time... just the remote part to it doesn't unlock and lock the car

was the sensor you had changed in the key or in the actual car, i assume it's in the ignition
Craftysince86 is offline   Reply With Quote
Old 02-14-2012, 04:41 PM   #6
MBWorld Fanatic!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 5,853
Drives: '71 Pinto
Quote:
Originally Posted by Craftysince86 View Post
my key turns the car on fine every time... just the remote part to it doesn't unlock and lock the car was the sensor you had changed in the key or in the actual car, i assume it's in the ignition
Have dealer or independent check for fault codes system "may" simply need reset. In the mean time see if key operates properly from passenger side if so, driver side door handle may be your problem and if fault cannot be cleared it may need replacement.
__________________

konigstiger is offline   Reply With Quote
Old 02-14-2012, 05:11 PM   #7
Newbie
 
Join Date: Jan 2010
Location: Marin County, CA
Posts: 12
Drives: 2011 E550 Coupe
jerryb2339
key fob

Konigstiger's ideas are good ones. Try that first. My problem was in the car - not the keys.
jerryb2339 is offline   Reply With Quote
Old 02-14-2012, 07:08 PM   #8
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
i took it to the dealer he said he didnt know what it was but because it goes through the AM antenna he can swap the AM module... not sure what that is honestly but wanted to charge me $1300-$1500

i heard there is a way to reset the remotes yourself... i think it was something like hold down the lock and unlcok simotaneously?
Craftysince86 is offline   Reply With Quote
Old 02-14-2012, 07:12 PM   #9
MBWorld Fanatic!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 5,853
Drives: '71 Pinto
Quote:
Originally Posted by Craftysince86 View Post
i took it to the dealer he said he didnt know what it was but because it goes through the AM antenna he can swap the AM module... not sure what that is honestly but wanted to charge me $1300-$1500
Interesting, check your email.
__________________

konigstiger is offline   Reply With Quote
Old 02-14-2012, 07:18 PM   #10
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
i got it! thank you! i'll have to read through it and see what i can find out...

i didnt think to check on the passenger side door if the remote worked, but i'll look into the zones and sensors a little more.. thanks again!
Craftysince86 is offline   Reply With Quote
Old 06-21-2012, 07:01 PM   #11
Newbie
 
Join Date: Jun 2012
Location: Virginia
Posts: 4
Drives: 2003 Mercedes Benz CLK 500
liveheartbeat
Hello, was just curious if you've found a fix to this issue, as i'm having the same problem in my CLK 500. any tips would be greatly appreciated
Blackaricanboy is offline   Reply With Quote
Old 06-21-2012, 08:28 PM   #12
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
I never got the situation resolved...

I did rule the tint out, it could either be the AM module or the rear window antenna.
Craftysince86 is offline   Reply With Quote
Old 06-21-2012, 10:34 PM   #13
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
I just decided to go with an aftermarket alarm

Im putting in a Clifford 50.7x and with all the bells n whistles, back up battery, tilt sensor, and auto start module I'll have it all done for around $500. It'll have much better security than OE and the auto start is great for summer and winter

Was also thinking about the viper smart start, which would give me the ability to control the car from my phone instead of having to carry an extra fob, it does require an annual/bi-annual/tri-annual subscriptions... 3yr subscription runs $100 and still gives me all the same options at only a hundred more on the actual alarm plus the subscription of course
Craftysince86 is offline   Reply With Quote
Old 06-21-2012, 10:58 PM   #14
Newbie
 
Join Date: Jun 2012
Location: Virginia
Posts: 4
Drives: 2003 Mercedes Benz CLK 500
liveheartbeat
Thumbs up on the viper system, a buddy of mine picked one up and loves it. And just an update, I replaced the batteries in my key fob this evening with CR2025 duracells i found at CVS and I've managed to get the lock and unlock to work! However they only work if i hold the keyfob *right* up against the driver side door handle, a little to the right of the key hole. I was doing some reading and supposedly the IF/RF both work for locking and unlocking.. but strangely enough i can unlock the trunk with the keyfob without being right up on the antenna.. So I guess the next step is to look into the amplifier in the driver side door? any thoughts?

EDIT *
BTW I spoke to Mercedes Benz customer service earlier and the guy informed me that when you change the batteries in the key fob you have to drive the car for 30 minutes before the key will fully resynch to the car..

Last edited by Blackaricanboy; 06-21-2012 at 11:00 PM. Reason: update
Blackaricanboy is offline   Reply With Quote
Old 06-21-2012, 11:27 PM   #15
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
Yea that's the same exact problem I have, to the T

Hmmm maybe I will try and change the battery and drive it and see if they changes anything.

Yea the only that worries me about the smart start is what happens when you are in an area that gets no cell phone service? Lol
Craftysince86 is offline   Reply With Quote
Old 06-22-2012, 12:45 AM   #16
MBWorld Fanatic!
 
jagata's Avatar
 
Join Date: Jun 2005
Location: So. Cal
Posts: 1,041
Drives: S6 LP640 E500
I currently have this problem after the old tint in rear window was removed. I believe the removal of the tint damaged the antenna that is part of the defroster grid. I also have no resoluntion, but the aftermarket alarm sounds like a good idea over dealer repair costs.
__________________
jagata is offline   Reply With Quote
Old 06-22-2012, 02:17 AM   #17
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
If you have full coverage maybe you can talk them into changing the rear window?

But yea the am module is about a thousand dollars alone
Craftysince86 is offline   Reply With Quote
Old 06-22-2012, 09:50 AM   #18
Junior Member
 
Join Date: Feb 2006
Location: Kansas
Posts: 39
Drives: 2004 E500, 2010 R350, 2000 Audi S4, 1994 Miata
I don't have the owners manual, is there a writeup on replacing the keyfob batteries?
blrx7r1 is offline   Reply With Quote
Old 06-22-2012, 10:30 AM   #19
Member
 
XLR82XS's Avatar
 
Join Date: Dec 2007
Location: SE Michigan
Posts: 181
Drives: 06 E500 4matic wagon, 02 Porsche 911 turbo, 67 Mercury
www.facebook.com/speedindustry
I was just about to start a new post as I have the same issue as of a couple weeks ago. Vehicle will only lock unlock when fob pointed directly at the sensor in door handle. No more beeps when lock/unlock and AM radio inoperative. (static)
__________________
~LXA~
2006 MB E500 4matic estate
XLR82XS is offline   Reply With Quote
Old 06-22-2012, 10:37 AM   #20
Newbie
 
Join Date: Jun 2012
Location: Virginia
Posts: 4
Drives: 2003 Mercedes Benz CLK 500
liveheartbeat
Blrx7r1 - un latch the mechanical key from the key fob and remove it, you'll notice that the metal key is shaped kind of like a hook, use the hook end to suppress a trigger inside of the key fob hole you just took the metal key from. While suppressing the trigger, the battery compartment will slide out of the keyfob with a little effort.

here are two videos that show you how to replace the batteries for both key styles

* I didn't make these *

(2010 +)
(2009 -)
Blackaricanboy is offline   Reply With Quote
Old 06-23-2012, 08:30 PM   #21
MBWorld Fanatic!
 
jagata's Avatar
 
Join Date: Jun 2005
Location: So. Cal
Posts: 1,041
Drives: S6 LP640 E500
Can anyone recommend a good stereo shop in OC? Im going the aftermarket alarm/keyless lock route.


WARNING all you w211 owners thinking of retinting your windows, do not remove the rear window tint or be super careful not to damage the antenna grid on the glass.
__________________
jagata is offline   Reply With Quote
Old 07-09-2012, 01:19 PM   #22
Member
 
XLR82XS's Avatar
 
Join Date: Dec 2007
Location: SE Michigan
Posts: 181
Drives: 06 E500 4matic wagon, 02 Porsche 911 turbo, 67 Mercury
www.facebook.com/speedindustry
Quote:
Originally Posted by Craftysince86 View Post
I never got the situation resolved...

I did rule the tint out, it could either be the AM module or the rear window antenna.
Does anyone know the module part #?
__________________
~LXA~
2006 MB E500 4matic estate
XLR82XS is offline   Reply With Quote
Old 07-09-2012, 01:53 PM   #23
Super Member
 
Craftysince86's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 860
Drives: W211
I was told that it is usually the AM amplifier that causes this ^

Not sure on the part number but there is two different ones for doeneding on the year of your E

Quote:
Originally Posted by XLR82XS View Post
I was just about to start a new post as I have the same issue as of a couple weeks ago. Vehicle will only lock unlock when fob pointed directly at the sensor in door handle. No more beeps when lock/unlock and AM radio inoperative. (static)
That's means your AM amplifier is out, they $300-500 depending on what year 211 you have.
Craftysince86 is offline   Reply With Quote
Old 10-25-2012, 09:49 AM   #24
Member
 
XLR82XS's Avatar
 
Join Date: Dec 2007
Location: SE Michigan
Posts: 181
Drives: 06 E500 4matic wagon, 02 Porsche 911 turbo, 67 Mercury
www.facebook.com/speedindustry
I replaced the AM amplifier and the problem still exists. Any other thoughts/ideas?
__________________
~LXA~
2006 MB E500 4matic estate
XLR82XS is offline   Reply With Quote
Old 10-26-2012, 04:20 PM   #25
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,545
Drives: 2004 E320
Quote:
Originally Posted by XLR82XS View Post
I replaced the AM amplifier and the problem still exists. Any other thoughts/ideas?
Well, that was an expensive roll of the dice.

You're probably at the point where a trip to the dealer is necessary.
__________________
2004 E320 4Matic, Tectite, Pano roof, keyless go, Navi, appearance package
starbrite is offline   Reply With Quote
Old 10-26-2012, 04:20 PM
 
 
 
Reply

Tags
12c, 2011, benz, charge, cost, e350, e550, failures, fob, key, keyless, mclaren, mercedes, problem, problems, w211



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 06:11 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details