Notices
190E (W201) 1982-1993: 190E 2.3, 190E 2.6, 190E 2.3-16, 190E 2.5-16, 190 D 2.2, 190 D 2.5, 190 D 2.5 TURBO, 190E 2.5-16 Evolution I, 190E 2.5-16 Evolution II

Urgent help needed

 
Old 11-04-2005, 12:58 PM
  #1  
Newbie
Thread Starter
 
Join Date: Dec 2004
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Urgent help needed

My Merc, a 1889 190 2lts petrol (gas) has developped a problem. Start firs touch when cold, but when reaching working temperature, it wont restart or more accurate, id reluctant, unless the engine is cranked for long minutes. Seems that is starving of fuel, any suggestions, please. Local mechanics (London, UK) including Official Merc mechanics, can't find or even diagnose the fault.

help, please....!!!
yosi is offline  
Old 11-04-2005, 01:29 PM
  #2  
Super Member
 
Justinius7's Avatar
 
Join Date: Feb 2005
Location: Edmonds... good bye SD
Posts: 806
Likes: 0
Received 0 Likes on 0 Posts
check your fuel pressure, first place i'd look... clogged fuel filter or bad pump perhaps...
Justinius7 is offline  
Old 11-04-2005, 09:52 PM
  #3  
Newbie
 
Join Date: Oct 2005
Location: Menlo Park, California
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
I drive a 1991 190e 2.3 and I also own a 2001 ML320
Check all the cylinder to make sure your pressure is good in all of them. You might have a problems in one of the cylinders. Your head gasket might be leaking. If the leak is just starting when you warm up your car your cylinder head expands and you might be getting liquids in one of the cylinders and that might be causing the hard to start condition while the car is withing operation temperture.
PERUNICA is offline  
Old 11-05-2005, 05:05 AM
  #4  
Newbie
Thread Starter
 
Join Date: Dec 2004
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Merc 190

Many thanks, people. I'll check this weekend. It been suggested to me to replace the Fuel Acumulator, whatever that is. Opinions?
yosi is offline  
Old 11-07-2005, 09:34 AM
  #5  
MBWorld Fanatic!
 
Join Date: Aug 2002
Location: York, PA
Posts: 2,753
Likes: 0
Received 0 Likes on 0 Posts
2003 C230K Sport Coupe, 1986 190E 2.3
Go to 190revolution.net/forum and search for Water Temp Sensor. Check it and go from there.
mctwin2kman is offline  
Old 11-07-2005, 12:54 PM
  #6  
MTI
MBWorld Fanatic!
 
Join Date: Dec 2002
Location: Scottsdale, Arizonai
Posts: 2,719
Likes: 0
Received 0 Likes on 0 Posts
'85 190E 2.3-16 '99 C280 '11 GLK350
Originally Posted by mctwin2kman
Go to 190revolution.net/forum and search for Water Temp Sensor. Check it and go from there.
He's been there.
MTI is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Urgent help needed


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: