Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W202)
C220-94 Stalling and not starting properly >

C220-94 Stalling and not starting properly

Notices
C-Class (W202) 1995-2000: C 200 CDI, C 220 CDI, C 270 CDI, C 180, C 200 K,C 230 K, C 220, C230, C 280

C220-94 Stalling and not starting properly

 
Old 05-07-2012, 04:28 PM
  #1  
Newbie
Thread Starter
 
Join Date: May 2012
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
c220
C220-94 Stalling and not starting properly

Well, been reading this forum for a long time trying to get info for my problems, and have now reached the point to not know what to do It's time to ask for help......
This is my story:
Bought a C220 -94 with 220.000 km on the meter. Car functions well for a while, then I get a misfire, cured with a restart. After some days the car suddenly stalls, as in engine shuts off, restarts after several attempts. Cannot trust the car any more as it randomly stalls/shuts down. Beginning to scout the internet finding this excellent forum.
What I have done so far:
1. Changed spark plugs (seemed to fix it, the car worked for a day and then NOT).
2. Fuel filter & Fuel relay (same as above)
3. Crank & Cam shaft sensors (car is working for some days and start to behave as earlier)
4. OVP relay (same)
5. MAF (same)
Car is now not even function any more, when cranking the engine it's starting for a split second and then dies. I can keep it going by flipping the ignition key repeatedly.
After several attempts to start it suddenly cranks and idles for a minute or two and then stops, trying to start again, with success. Engine runs for 10 min and suddenly starts to misfire, shutting down and restart. Run for 8 min and start to misfire again, and we are back to "starts for a split second and then dies".
I got the car scanned with the result of over 15 errors all from ground issues, Lambda to MAF sensor. Start to clean and reconnect all ground points. Didn't make any difference.
Start to suspect wiring harness... And yes it crumpling to pieces, sad
But YEAH fund it!
6. Begin to rewire the harness and try to start the car..... same as earlier, cranks for a split second and dies.
Cut the throttle actuator cable open and yes, cables is degraded, rewire all the way in. Test... didn't make any difference.

Does anybody have the ohm readings for healthy ignition coils so that I can check them??

Regards T. Garth

Last edited by trexgarth; 05-09-2012 at 04:55 PM.
trexgarth is offline  
Old 06-17-2012, 05:54 AM
  #2  
Newbie
Thread Starter
 
Join Date: May 2012
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
c220
bump some one??
trexgarth is offline  
Old 06-25-2012, 12:37 PM
  #3  
Junior Member
 
Join Date: Nov 2011
Posts: 66
Likes: 0
Received 0 Likes on 0 Posts
chevrolet z-71
Man I do wish i could offer some assitance in your situation. Do not give up for sure and check into club 202!! They are geared for the w202 cars!! I left this room long ago just to find that the club 202 is awsome for our cars. Hope you can find some answers their!!
taz069 is offline  
Old 07-31-2012, 12:59 AM
  #4  
Newbie
 
Join Date: Aug 2010
Location: Ontario, CA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
1995 C220
judging by experience there are wires somewhere that could still be causing a problem or position sensor/ CKP sensor..
C220_Lizz is offline  
Old 08-03-2012, 06:19 AM
  #5  
Newbie
Thread Starter
 
Join Date: May 2012
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
c220
update

Have got indications on a immobilizer problem from a friend mechanic. Didn't know that there was such a thing on this car. There was a after market anti theft system with a type of chip that should be inserted in a slot before it would start, this system caused a lot of aggravation when after repeatedly "insertions" finally let me start the car, so I bypassed it with success. This was before I got problem stated earlier in post!

So..... how to fix MB immobilizer?
trexgarth is offline  
Old 03-18-2019, 11:22 AM
  #6  
Newbie
 
Join Date: Mar 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
mercedes c280 1996
Angry Mercedes C280 1996

I have the same problem and they say the CKP module is killing the fuel injectors as a part of its security job. If it does not publish a signal the car runs 3 seconds as a result of the PCM Powertrain control module and then dies because the CKP kills it. The manufacturer will sell the new module for $2500 but the car is beautiful but not worth fixing for that price. ANY suggestions? What did you do to fix the C220? Helppppp?
PaulIMBenson is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: C220-94 Stalling and not starting properly


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: