Radio no sound? Any suggestions - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Radio no sound? Any suggestions > Radio no sound? Any suggestions
Notices
C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Radio no sound? Any suggestions

Reply

 
 
Old 03-13-2007, 07:30 PM
  #1
Almost a Member!
Thread Starter
 
Join Date: Jan 2007
Location: Maryland
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
C320
Radio no sound? Any suggestions

Maybe my fault, removed a fuse #64 that controls the Command system, which includes NAV, RADIO, CD, after reinstalling the fuse, the NAV works-no sound, the CD player is Not found, the radio functions, but no sound.....................I checked fuse #26 which says its "sound" but that fuse was fine, by the way this is on a 01 C320.
jhartmac is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
justinmorrison
S-Class (W221)
1
09-11-2015 07:45 PM
Wayne Starnes
W210 AMG
7
09-08-2015 09:55 AM
thunderMB
AMG GT/GTS
4
09-05-2015 12:10 PM
bewbzout
E-Class (W211)
1
09-04-2015 12:06 PM
OrginalBigDaddy
New Members Check In!
2
09-02-2015 11:57 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:09 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: