fuel gauge - MBWorld.org Forums

Notices
C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

fuel gauge

 
Old 02-06-2019, 05:01 PM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2002 c-240
fuel gauge

have alreay replaced drivers side sending unit and still same problems returns, when i fill tank fuel gauge will work ok but hangs up at half way line until fuel is exhausted,in other words half to empty gauge has no reading at all until out of gas,
so is this a common problem with this car
jeff ingrum is offline  
Old 02-06-2019, 09:06 PM
  #2  
Super Member
 
Join Date: May 2017
Posts: 640
Thanked 54 Times in 53 Posts
C320
Your passenger side fuel level sender is boned.
tjts1 is offline  
Old 02-11-2019, 02:17 PM
  #3  
Junior Member
 
Join Date: Aug 2018
Location: Lawrence, KS
Posts: 34
Thanked 1 Time in 1 Post
2002 BMW 325 XIT, 2003 MB C240
From reading here, the passenger side is the fuel pump The drivers side is the fuel level sender. Is this not correct?
slagdemon is offline  
Old 02-11-2019, 02:53 PM
  #4  
Super Member
 
Join Date: May 2017
Posts: 640
Thanked 54 Times in 53 Posts
C320
Originally Posted by slagdemon View Post
From reading here, the passenger side is the fuel pump The drivers side is the fuel level sender. Is this not correct?
This this is not correct. There are fuel level senders on both sides of the tank
tjts1 is offline  
Old 02-11-2019, 03:00 PM
  #5  
Junior Member
 
Join Date: Aug 2018
Location: Lawrence, KS
Posts: 34
Thanked 1 Time in 1 Post
2002 BMW 325 XIT, 2003 MB C240
How can you tell which is bad if your gauge is reading incorrectly?
slagdemon is offline  
Old 02-11-2019, 03:09 PM
  #6  
Super Member
 
Join Date: May 2017
Posts: 640
Thanked 54 Times in 53 Posts
C320
Originally Posted by slagdemon View Post
How can you tell which is bad if your gauge is reading incorrectly?
You need an MB scan tool that can read live data from the rear signal aqusition module. That'll show you fuel level signals on both the left and right side.
tjts1 is offline  
Old 02-11-2019, 03:12 PM
  #7  
Junior Member
 
Join Date: Aug 2018
Location: Lawrence, KS
Posts: 34
Thanked 1 Time in 1 Post
2002 BMW 325 XIT, 2003 MB C240
Guess I should have asked how the home mechanic can tell which is bad. I don't have a MB scan gauge. Should be a resistance value or something I can go by though, right?
slagdemon is offline  
Old 02-11-2019, 03:17 PM
  #8  
Super Member
 
Join Date: May 2017
Posts: 640
Thanked 54 Times in 53 Posts
C320
This is for the 211/219 but the saddle tank setup on the 203 is the same as this.
https://www.ms-motorservice.com/en/t...-tank-modules/
Each side of the tank has its own float and sensor. The fuel return is used to siphon fuel from the driver's side to the passenger side so the pump is never starved of fuel.
sorry I don't know the pin outs or resistance values to look for.

Last edited by tjts1; 02-11-2019 at 03:20 PM.
tjts1 is offline  
Old 02-15-2019, 12:33 PM
  #9  
Junior Member
 
Join Date: Aug 2018
Location: Lawrence, KS
Posts: 34
Thanked 1 Time in 1 Post
2002 BMW 325 XIT, 2003 MB C240
Good info, thanks tjts1. I'm probably going to pull both sides and look for anything "weird". I'm hoping maybe there are some contacts that can be cleaned or something otherwise. Either way, I'll video it and throw it up on youtube.
slagdemon is offline  
Old 02-15-2019, 07:35 PM
  #10  
MBWorld Fanatic!
 
C230 Sport Coup's Avatar
 
Join Date: Jun 2002
Location: Bay Area
Posts: 6,333
Thanked 54 Times in 52 Posts
C230 Sport Coup & 2006 W164 ML350
There is the possibility that someone replaced the pump, and failed to connect everything correctly, perhaps?
Autozone has a pump tool to loan as well as pressure tester.
C230 Sport Coup is offline  
Old 02-15-2019, 07:49 PM
  #11  
Junior Member
 
Join Date: Aug 2018
Location: Lawrence, KS
Posts: 34
Thanked 1 Time in 1 Post
2002 BMW 325 XIT, 2003 MB C240
I pressure tested my pump and it was right at 55-57 psi. The only issue is the level. I don't think its correct. My tank showed 1/4 left when the guy sold it to me. I put a couple gallons in and it fired up after I primed the pump. Seems its reporting incorrectly or a pickup tube on the pump became disconnected or something.
slagdemon is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: fuel gauge


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: