Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Dash Headlight Selector Bulb Not Illuminated - Bulb Access Help? >

Dash Headlight Selector Bulb Not Illuminated - Bulb Access Help?

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Dash Headlight Selector Bulb Not Illuminated - Bulb Access Help?

 
Old 03-24-2015, 05:51 PM
  #1  
Junior Member
Thread Starter
 
boardrider's Avatar
 
Join Date: Feb 2014
Location: SoCal
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
2011 C300
Dash Headlight Selector Bulb Not Illuminated - Bulb Access Help?

I've noticed when I'm driving at night, the options on the headlight selector switch panel are not illuminated. See area in red in attached photo. Has anyone else experienced this? More importantly, does anyone know the easiest way to access the bulb behind there (for replacement)? I did some searching on here but couldn't find anything.
Thanks in advance for any help!
boardrider is offline  
Old 03-24-2015, 06:04 PM
  #2  
Newbie
 
Join Date: Mar 2015
Location: Levittown PA
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 Sport 4matic
Mine doesn't either. I just got the car 3 weeks ago. I figured it wasn't supposed to and was actually just about to make a post about it. Hopefully someone can help with our problem
eminembdg is offline  
Old 03-26-2015, 05:50 PM
  #3  
Junior Member
Thread Starter
 
boardrider's Avatar
 
Join Date: Feb 2014
Location: SoCal
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
2011 C300
Anyone?
boardrider is offline  
Old 03-26-2015, 07:01 PM
  #4  
Member
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
They don't light up!
NewtwoMB is offline  
Old 03-26-2015, 07:13 PM
  #5  
Junior Member
Thread Starter
 
boardrider's Avatar
 
Join Date: Feb 2014
Location: SoCal
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
2011 C300
Originally Posted by NewtwoMB View Post
They don't light up!
REALLY??? That's odd. They're for selecting headlight functions, usually when it's dark... Engineers...
boardrider is offline  
Old 03-26-2015, 07:33 PM
  #6  
Newbie
 
Join Date: Mar 2015
Location: Levittown PA
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 Sport 4matic
Originally Posted by boardrider View Post
REALLY??? That's odd. They're for selecting headlight functions, usually when it's dark... Engineers...
I know right? Odd thinking on that one. Lol.

Oh well then. Thanks for the answer
eminembdg is offline  
Old 03-26-2015, 09:38 PM
  #7  
Member
 
Join Date: Apr 2014
Location: KY
Posts: 76
Likes: 0
Received 0 Likes on 0 Posts
2008 c300 4matic Sport
For what its worth I was thinking the same thing and mine aren't lit up either. Said part is... I'm an engineer lol. Smartest dumb people you'll ever meet.
will042082 is offline  
Old 03-26-2015, 11:23 PM
  #8  
Member
 
C0d3Sp4c3's Avatar
 
Join Date: Oct 2013
Location: SoCal
Posts: 95
Likes: 0
Received 1 Like on 1 Post
2013 C250
That's just how it is on mine since new.

C0d3Sp4c3 is offline  
Old 03-26-2015, 11:31 PM
  #9  
Member
 
Join Date: Nov 2014
Location: Everett, WA
Posts: 222
Likes: 0
Received 1 Like on 1 Post
2013 C250
I guess it's just too easy to be located in the dark. Lighting itself doesn't make it more functional either since it's kind of behind the steering wheel
rookiezxc is offline  
Old 03-27-2015, 05:46 PM
  #10  
Super Member
 
dudeitsmattx's Avatar
 
Join Date: Dec 2010
Location: Fort Myers, Florida
Posts: 846
Likes: 0
Received 1 Like on 1 Post
2013 C250 Sport
Also idk about on all w204's but where my gauges are in the left one with the temp and gas at the bottom it lights up what I have it selected on for my lights that's probably why the device it's self does not light up on the selection since you can see it on the gauge cluster better
dudeitsmattx is offline  
Old 03-27-2015, 06:08 PM
  #11  
Newbie
 
Join Date: Mar 2015
Location: Levittown PA
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 Sport 4matic
Originally Posted by dudeitsmattx View Post
Also idk about on all w204's but where my gauges are in the left one with the temp and gas at the bottom it lights up what I have it selected on for my lights that's probably why the device it's self does not light up on the selection since you can see it on the gauge cluster better
Hmm that's cool but mine doesn't do that. It's not really bothersome for me. They are easy enough to find and I have little lighted icons under the switch showing what's on.
eminembdg is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Dash Headlight Selector Bulb Not Illuminated - Bulb Access Help?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: