Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Key fob stopped working >

Key fob stopped working

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Key fob stopped working

 
Old 01-08-2019, 01:02 PM
  #1  
Sbm
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
C300 2009
Key fob stopped working

Hello all, I have 2009 C300.
couple days ago when I was trying to unlock my door, the remote didn't work and when I pushed the unlcok button, the red light stayed on, I removed the battery for a second and then tried and it worked. Yesterday, the remote didn't unlcok again, but the red light didn't stayed on, I removed the battery, didn't fix the problem, manually opened the door, when I inserted the fob, the monitor showed: key not belongs to the vehicle.
i found my spare key and it works fine.
Things that I've done so far:
1- changed the fob batteries,
2- put the battery slots of the bad fob to the good one, the bad one is still bad and good one is still good.
3- the red light and infrared( seen with a camera) both light up when I press a button.

Any suggestions!?
Thanks
Sbm is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Key fob stopped working


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: