Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C Class (W205)
Wiper blades for W205 >

Wiper blades for W205

Notices
C Class (W205) C 180 BlueTec,C 200 BlueTec,C 220 BlueTec,C 220 BlueTec BlueEfficiency,C 250 BlueTec,C 300 BlueTec Hybridplus,C 180,C 180 BlueEfficiency,C 200,C 250,C 300,C 400 Plug-in Hybrid,C 400

Wiper blades for W205

 
Old 07-29-2015, 05:56 AM
  #26  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
The dealer just told me they need to aquire a special tool first to check and adjust the angle of the arm/blade as per an MB service information bulletin.
Pit-Pony is offline  
Old 07-30-2015, 10:48 AM
  #27  
Junior Member
 
Join Date: Jul 2015
Posts: 17
Likes: 0
Liked 0 Times in 0 Posts
C300 Sport
If anyone has chatter or stuttering with their wiper blades put some rubbing alcohol on a cloth and wipe the blades. BAM! I was surprised about how well this worked.
hungasaurus is offline  
Old 07-30-2015, 11:58 AM
  #28  
Senior Member
 
CO2010's Avatar
 
Join Date: Feb 2013
Location: USA
Posts: 327
Likes: 0
Liked 16 Times in 7 Posts
2015 C300 RWD Sport Premium
Originally Posted by hungasaurus View Post
If anyone has chatter or stuttering with their wiper blades put some rubbing alcohol on a cloth and wipe the blades. BAM! I was surprised about how well this worked.
Thanks for the tip!
CO2010 is offline  
Old 08-01-2015, 01:49 PM
  #29  
Super Member
 
Join Date: Dec 2010
Location: N.C. USA
Posts: 793
Liked 1 Time in 1 Post
2015, ML250 BlueTEC
Originally Posted by hungasaurus View Post
If anyone has chatter or stuttering with their wiper blades put some rubbing alcohol on a cloth and wipe the blades. BAM! I was surprised about how well this worked.
How often do you have to do this? Is this just a quick fix?
greasykid is offline  
Old 08-02-2015, 07:47 PM
  #30  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
Didn't work for me, Chatter back after just a few wipes
Pit-Pony is offline  
Old 08-03-2015, 09:52 AM
  #31  
Junior Member
 
Join Date: Jul 2015
Posts: 17
Likes: 0
Liked 0 Times in 0 Posts
C300 Sport
Originally Posted by greasykid View Post
How often do you have to do this? Is this just a quick fix?

I've only had my car for a week. So far so good!
hungasaurus is offline  
Old 08-10-2015, 03:24 PM
  #32  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
Well they used the so called windshield wiper special tool on my friends C300 W205 and it did not fix the issue.

They insist using the same tool on my W205 C63S to verify, as they HAVE TO follow procedure on every car complaining about the chatter and I doubt it will yield better results.

MB Canada customer service have heard from me and don't have an answer. They now have a TIPS report in the system.

It's very concerning that MB does not have a solution.

I think it's the quality of the blade rubber or the blade geometry and there is no after market blade that will fit these new arm couplings.

MB has been building cars for 100 years but they screw up the wipers.
Pit-Pony is offline  
Old 08-10-2015, 04:58 PM
  #33  
Member
 
Join Date: Apr 2015
Location: Ottawa, Canada
Posts: 129
Liked 0 Times in 0 Posts
MY16 C300
I read on another thread that someone tried using a Magic Eraser (Mister Clean product) on his window to stop the chatter. He reported that it worked.
Steve71 is offline  
Old 08-11-2015, 01:53 AM
  #34  
Junior Member
 
ept55's Avatar
 
Join Date: Jul 2015
Location: whitworth
Posts: 31
Likes: 0
Liked 0 Times in 0 Posts
C200 Sport
Looks like it will be down to when and if Bosch offer after market wiper blades they are usually the way to go in cases like this.
ept55 is offline  
Old 08-11-2015, 01:28 PM
  #35  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
I contacted Bosch and they are looking into it.
Pit-Pony is offline  
Old 08-11-2015, 02:25 PM
  #36  
Super Member
 
Join Date: Dec 2010
Location: N.C. USA
Posts: 793
Liked 1 Time in 1 Post
2015, ML250 BlueTEC
Pls POST if you get a reply from Bosch.
greasykid is offline  
Old 08-15-2015, 02:45 AM
  #37  
Member
 
Join Date: Nov 2010
Location: Chi-town
Posts: 137
Likes: 0
Liked 5 Times in 2 Posts
Diamond W205 C63s Ed1
The noise the blades make are so annoying, its quite sad mb made a great car but f**ked up on a lot of small things. I really hope they order a tab or have some type of fix
matt11212 is offline  
Old 08-16-2015, 01:50 PM
  #38  
Member
 
Join Date: Dec 2014
Posts: 171
Likes: 0
Liked 0 Times in 0 Posts
Ferrari, Lexus, Toyota
Hmmm, how can I tell if my car would take the ICON OEM blades as photo shows? Looks nice. Is there a visual cue to if it'd fit w/o buying them and trying?

vin specific makes it hard to tell the blade, especially if it's the blade is different for different cars for same model and year out of the same factory.
HelenR is offline  
Old 08-17-2015, 07:29 PM
  #39  
Junior Member
 
Join Date: Apr 2015
Location: Madison, Alabama
Posts: 37
Likes: 0
Liked 0 Times in 0 Posts
2015 C300 RWD AMG SPORT ~ Iridium Silver
Just purchased a NEW MB WIPER SET

C300 build date is 2/2015 and does have different length wiper blades. It was raining here in Bama today and the skipping and shuddering was driving me crazy. I have used the Griot's Garage glass sealant with a little success. The windshield does bead off quite nicely but the skip and shudder is really annoying.


So, today I went to MB and purchased an new $69 set. I did learn how to make the blades stop vertically on the windshield and replace the blades ~ easily. Did you know that the blades have a wear indicator that turns yellow when worn out? Regardless, mine were factory black.


It is suppose to rain again tomorrow -- if the skipping continues -- a dealership trip will be in my future.
123Britt is offline  
Old 08-20-2015, 10:56 AM
  #40  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
This issue doesn't show up after a few strokes when the windshield is dry or when using the windshield solution either, only with water.

Sometimes the wipers need to work for a minute or two in the rain before the trouble begins. It starts off with the bottom of the wiper vibrating and builds into the top as well after a few minutes. Very annoying.

It may be the geometry but it may also be poor rubber on the OEM blades. Bosch told me they don't yet have a set to fit this arm so we are stuck to test the blade rubber for now.

Once we get rain and I can test it again, I'll drive to the dealer that same day and show them the problem yet again. MB just doesn't have another plan of action. The MB rep was at the dealer and said to me they never heard of this problem before (likely story eh :-) ), he did see the problem first hand though. They took videos and sent them on.

I did buy a set of Bosch blades (that don't fit)and returned them. One might try buying a set of Bosch and a set of OEM and try to disassemble both to retrofit the OEM blade connector to the Bosch blade. It doesn't look easy and the connector may break but someone more talented than me may want to try it.
Pit-Pony is offline  
Old 08-20-2015, 01:08 PM
  #41  
Senior Member
 
arnold0523's Avatar
 
Join Date: Apr 2015
Posts: 377
Liked 20 Times in 18 Posts
2017 C43 Sedan
i went to the dealership, they adjusted wiper angle, changed wiper blade, replaced wiper arm. They fixed the jumping/chattering issue. But squeaking noise came up and they said they've done everything, and nothing else can be done at this point.

Different problem, but still annoying.

I dont know where to go from here. Besides every other problems I have, including excessive wind noise, I can live with those, but not the wiper noise!
arnold0523 is offline  
Old 10-03-2015, 02:30 PM
  #42  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
Dealer can't fix it. Wipers are chattering like crazy.
Pit-Pony is offline  
Old 10-03-2015, 09:37 PM
  #43  
Member
 
Join Date: Sep 2015
Location: Magnolia Texas
Posts: 77
Likes: 0
Liked 2 Times in 2 Posts
2015 C300/ 2014 Ford Expedition 2012Ford F205 4x4
Not sure if it was mentioned earlier but Bosch makes a replacement blade that fixed my issue with blades chattering.
RixC300 is offline  
Old 10-04-2015, 03:54 AM
  #44  
Junior Member
 
ept55's Avatar
 
Join Date: Jul 2015
Location: whitworth
Posts: 31
Likes: 0
Liked 0 Times in 0 Posts
C200 Sport
Part number and pictures please....
ept55 is offline  
Old 10-04-2015, 09:58 AM
  #45  
Junior Member
Thread Starter
 
Join Date: May 2015
Posts: 38
Likes: 0
Liked 1 Time in 1 Post
MB C300
Originally Posted by RixC300 View Post
Not sure if it was mentioned earlier but Bosch makes a replacement blade that fixed my issue with blades chattering.
Wiper blades on w205 use vin dependent style blades. Call MB parts to get your part number.
cliffords
ClifordS is offline  
Old 10-04-2015, 10:04 AM
  #46  
MBWorld Fanatic!
 
ManiacGT's Avatar
 
Join Date: Jan 2015
Location: Manchester, UK
Posts: 2,072
Likes: 0
Liked 49 Times in 45 Posts
BMW e89 Z4 sDrive 35i & MB S205 C200 AMG Premium Plus
MB replacement blades sorted mine 90% . The mechanism/arms and wipers are pretty flimsy affairs IMHO
ManiacGT is offline  
Old 10-04-2015, 11:42 AM
  #47  
Super Member
 
Join Date: May 2002
Location: Canada
Posts: 565
Likes: 0
Liked 1 Time in 1 Post
2015 C63S E1 (sold 2012 C63 AMG Sedan (Premium & APX)) & 09 C300 Sport 4Matic
No Bosch blade yet available to fit the new arm for the W205 set up
Pit-Pony is offline  
Old 10-04-2015, 01:15 PM
  #48  
Junior Member
Thread Starter
 
Join Date: May 2015
Posts: 38
Likes: 0
Liked 1 Time in 1 Post
MB C300
Originally Posted by Pit-Pony View Post
No Bosch blade yet available to fit the new arm for the W205 set up
Some early W205 CAN use the Bosch blades. The only way to know is to check the MB parts dept. and giving them your vin number.
cliffords
ClifordS is offline  
Old 10-04-2015, 09:20 PM
  #49  
Member
 
Join Date: Sep 2015
Location: Magnolia Texas
Posts: 77
Likes: 0
Liked 2 Times in 2 Posts
2015 C300/ 2014 Ford Expedition 2012Ford F205 4x4
I will post pics tomorrow along with a part#. I picked mine up at AutoZone last week, was in there for caliper paint and thought I would give it a try and lucked out. The OEM wipers were okay with heavy rain, light rain drove me nutz.
RixC300 is offline  
Old 11-16-2015, 06:05 PM
  #50  
Newbie
 
Join Date: Mar 2009
Posts: 13
Likes: 0
Liked 0 Times in 0 Posts
07 CLS63
Bought the Bosch Icon 22OE, definitely doesn't fit my 2015 C300 (drivers side).. none of the adapters work.
malken00 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Wiper blades for W205


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: