C55 just died while driving. - MBWorld.org Forums

Notices
C32 AMG, C55 AMG (W203) Discuss the C32 and C55 AMG.
Sponsored by:
Sponsored by:

C55 just died while driving.

Old 01-11-2019, 09:50 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2016
Posts: 40
Thanked 6 Times in 2 Posts
C55 AMG
C55 just died while driving.

Hello MB people.
I have just had my C55 Estate die on me while driving, luckily it was near home and i have a ute and helpful friend nearby to get it home.
Its only done 67000Km, has K and N filters and a Eurocharged ECU tune with secondary cats deleted, a nice cruiser.
Anyway, was just driving like a normal human at about 40Km/h and it just died, all the dash lights came on that would if your key is in the on position. Car will crank over on the starter but wont fire into life, multiple tries all same result, im waiting for it to cool down to try once more as it feels hot but its a very hot day here.
The dash shows "no malfunction".
Im thinking fuel pump, CAS, MAF or ignition (signal to coilpacks).

Im fairly handy on the tools but not a pro.
What is the best way to go about fault finding this?
Which to start on?
I have the rest of the weekend to DIY it but if it gets over my head i have a mechanic i will get it towed to anyway, its due a service.

Thanks
daynger is offline  
Old 01-11-2019, 09:55 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Oct 2016
Posts: 40
Thanked 6 Times in 2 Posts
C55 AMG
daynger is offline  
Old 01-12-2019, 08:11 AM
  #3  
MBWorld Fanatic!
 
noogman's Avatar
 
Join Date: Feb 2006
Location: Црна Гора
Posts: 4,594
Thanked 33 Times in 32 Posts
A vicious C43
reading codes is the only way to properly find your issue?
sounds like CrankPositionSensor if your car won't start?
after 30min/one hour cool down, did your car start or not?
if it starts , could probably be a worn CPS?
if not, then something else is the culprit?
good luck fixing your car.
noogman is offline  
Old 01-12-2019, 07:24 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Oct 2016
Posts: 40
Thanked 6 Times in 2 Posts
C55 AMG
So i left it to cool overnight and this morning it started right up.
I would suspect its the CPS from what i have read at this stage.
Its all booked in for a service and to get the codes read to confirm and repair.
Thanks
Dayne.
daynger is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: C55 just died while driving.


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: