Go Back  MBWorld.org Forums > Mercedes-Benz AMG Vehicles > C63 AMG (W204)
Anyone notice low grinding noise when driving or turning slowly?y >

Anyone notice low grinding noise when driving or turning slowly?y

Notices
C63 AMG (W204)
Sponsored by:
Sponsored by:

Anyone notice low grinding noise when driving or turning slowly?y

 
Old 09-05-2011, 01:12 AM
  #1  
MBWorld Fanatic!
Thread Starter
 
Join Date: Dec 2008
Location: San Diego
Posts: 2,155
Received 68 Likes on 45 Posts
Hyperion's Candy-Coated 4 x 4
Anyone notice low grinding noise when driving or turning slowly?y

Noticed it on really slow turns but not always consistent. Kind of like a low grinding noise emanating from center area of car to the back. Doesn't feel it's coming from the front. Anyone experience anything similar? Other than that, no issues when driving and steering, just at very low speeds like 10mph or less.

Last edited by Pertplus; 09-05-2011 at 01:20 AM.
Pertplus is offline  
Old 09-05-2011, 09:21 AM
  #2  
Senior Member
 
Join Date: Feb 2011
Location: Australia
Posts: 357
Received 7 Likes on 6 Posts
E63S
Cant say I have either heard it, or heard of it, in the C63.
I am however thinking of diff, especially if you have the LSD. If the LSD was the fluid changed at ~3000km??

A grinding sound from the rear on low speed turns, similar to what you are describing, was common place in the BMW E46 M3, all of which had LSD as standard. It was fixed by replacing the standard diff fluid with one that had a friction modifier additive and then doing a few full lock figure of 8 turns to spread the new fluid through the sytem. This fixed mine straight away and I never had any further problems with it.
JimmyR is offline  
Old 09-05-2011, 09:31 AM
  #3  
Senior Member
 
Djovovic63's Avatar
 
Join Date: May 2010
Location: Barcelona, Ljubljana
Posts: 330
Likes: 0
Received 0 Likes on 0 Posts
Mercedes C63 amg, Bmw X5,
Originally Posted by Pertplus View Post
Noticed it on really slow turns but not always consistent. Kind of like a low grinding noise emanating from center area of car to the back. Doesn't feel it's coming from the front. Anyone experience anything similar? Other than that, no issues when driving and steering, just at very low speeds like 10mph or less.
I had exactly the same issue. I remember that when I took it to service I told them to check the steering wheel and change all the fluids. Diff trans and engine fluid. After that everything seemed fine and the grinding noise is gone for good. But otherwise it used to happen on the parking lot or when i would turn the car at very low speeds. Like 10mph max, usually slower.

I think the problem lies with differential because I was never told that anything was wrong with my steering wheel or anything.
Djovovic63 is offline  
Old 09-05-2011, 09:58 AM
  #4  
MBWorld Fanatic!
Thread Starter
 
Join Date: Dec 2008
Location: San Diego
Posts: 2,155
Received 68 Likes on 45 Posts
Hyperion's Candy-Coated 4 x 4
Thanks guys. I only have 8k miles on my car, and probably only 4k with the Quaife LSD, but I will have it double checked to see if that's the issue.
Pertplus is offline  
Old 09-05-2011, 10:51 AM
  #5  
MBWorld Fanatic!
 
-=Hot|Ice=-'s Avatar
 
Join Date: May 2008
Location: MD
Posts: 1,383
Received 9 Likes on 8 Posts
Cars.
Common complaint among M3 owners. It's the rear diff and it usually is fixed with a fluid change.
-=Hot|Ice=- is offline  
Old 09-05-2011, 12:45 PM
  #6  
MBWorld Fanatic!
Thread Starter
 
Join Date: Dec 2008
Location: San Diego
Posts: 2,155
Received 68 Likes on 45 Posts
Hyperion's Candy-Coated 4 x 4
Originally Posted by -=Hot|Ice=- View Post
Common complaint among M3 owners. It's the rear diff and it usually is fixed with a fluid change.
You think even after having a new LSD and differential fluid installed in February and less than 5k miles of use?
Pertplus is offline  
Old 09-05-2011, 01:02 PM
  #7  
MBWorld Fanatic!
 
obsidian05e55's Avatar
 
Join Date: Dec 2006
Location: Livingston NJ
Posts: 3,278
Likes: 0
Received 1 Like on 1 Post
C63, Grigio Medio E46 M3
I have this very same issue. Mine doesn't sound anything like my E46 M diff, and I don't have an LSD in the 63.
obsidian05e55 is offline  
Old 09-05-2011, 02:35 PM
  #8  
MBWorld Fanatic!
 
bhamg's Avatar
 
Join Date: Aug 2009
Posts: 2,861
Received 71 Likes on 65 Posts
C63 AMG
Originally Posted by Pertplus View Post
You think even after having a new LSD and differential fluid installed in February and less than 5k miles of use?
If it is the diff from my experience you'll experience those symptoms almost immediately...I did at under 1k miles.
bhamg is offline  
Old 09-05-2011, 04:08 PM
  #9  
MBWorld Fanatic!
Thread Starter
 
Join Date: Dec 2008
Location: San Diego
Posts: 2,155
Received 68 Likes on 45 Posts
Hyperion's Candy-Coated 4 x 4
Originally Posted by bhamg View Post
If it is the diff from my experience you'll experience those symptoms almost immediately...I did at under 1k miles.
I think it may just be the normal process of the parts of the chassis moving because this isnt a consistent noise and not something I noticed (although I almost always have the music on) when I first got the LSD installed. I only noticed it because I was in a parking lot with friends, the stereo down low, and was making a slow sharp turn.
Pertplus is offline  
Old 09-05-2011, 05:17 PM
  #10  
MBWorld Fanatic!
 
-=Hot|Ice=-'s Avatar
 
Join Date: May 2008
Location: MD
Posts: 1,383
Received 9 Likes on 8 Posts
Cars.
Originally Posted by Pertplus View Post
You think even after having a new LSD and differential fluid installed in February and less than 5k miles of use?
I've seen people complain about the noise with before they break-in. Other times, the dealers were being idiots and putting in the wrong fluid into the diff. Take it in and you should be covered under warranty.
-=Hot|Ice=- is offline  
Old 09-06-2011, 02:19 PM
  #11  
MBWorld Fanatic!
 
BK63amg's Avatar
 
Join Date: Feb 2011
Location: Oakland, CA
Posts: 1,341
Received 2 Likes on 2 Posts
'16 GTS Solar
Check your sway bar bushings/links - mine are already worn and making a ridiculously loud clunking noise. This initally started as a low grinding kind of sound but is a full clunk now. I'll be replacing them this week...mind you, I'm only at 15K miles right now...seems way too early for this kind of wear and tear.
BK63amg is offline  
Old 09-06-2011, 04:23 PM
  #12  
MBWorld Fanatic!
 
Join Date: Jul 2009
Location: Los Angeles
Posts: 6,674
Likes: 0
Received 0 Likes on 0 Posts
C63
Is this sound specifically linked to coilovers or lowered cars in general?
Had my H&R springs for some time now and haven't heard any grinding noise.
_AMG_ is offline  
Old 03-28-2017, 04:49 AM
  #13  
Junior Member
 
Join Date: Aug 2016
Posts: 41
Received 3 Likes on 3 Posts
Bmw m5 , c63
Sorry to resurrect an old thread but anyone manage to fix this ?

I have low grinding noise from rear half of the car when going very very slowly almost to a complete stop

Weirdly it only happens after the car is warmed up doesn't happen right off the bat when it's cold

Lsd oil was changed just 2000 Miles before

Currently about 35k Miles 2010 p30 car with lsd
Terryamg04 is offline  
Old 03-28-2017, 08:33 AM
  #14  
MBWorld Fanatic!
 
Jasonoff's Avatar
 
Join Date: Aug 2011
Location: Kitchener, ON
Posts: 3,638
Received 658 Likes on 433 Posts
2010 C63 AMG
Likely the brakes...
Jasonoff is offline  
Old 03-28-2017, 09:33 AM
  #15  
MBWorld Fanatic!
 
Adi-Benz's Avatar
 
Join Date: Apr 2016
Location: Milwaukee, WI
Posts: 3,554
Received 298 Likes on 269 Posts
2010 C300 4MATIC
Transmission, problem with 722.9
Adi-Benz is offline  
Old 03-28-2017, 09:39 PM
  #16  
Junior Member
 
Join Date: Aug 2016
Posts: 41
Received 3 Likes on 3 Posts
Bmw m5 , c63
Which part of the transmission is giving the problem
?

Anyone knows the exact parts to be replaced ?
Terryamg04 is offline  
Old 04-13-2018, 11:55 PM
  #17  
Member
 
Join Date: Mar 2017
Posts: 118
Likes: 0
Received 2 Likes on 2 Posts
c63 amg PP (w204)
Originally Posted by Adi-Benz View Post
Transmission, problem with 722.9
why do you believe it is the transmission?
valjay is offline  
Old 04-14-2018, 08:39 AM
  #18  
MBWorld Fanatic!
 
roadkillrob's Avatar
 
Join Date: Aug 2016
Posts: 1,215
Received 163 Likes on 139 Posts
2014 C63 507 with LSD Polar White
Originally Posted by valjay View Post


why do you believe it is the transmission?
Why do you believe a thread from 13 months ago needs a new response?
roadkillrob is online now  
Old 04-14-2018, 10:01 AM
  #19  
Member
 
Join Date: Mar 2017
Posts: 118
Likes: 0
Received 2 Likes on 2 Posts
c63 amg PP (w204)
Originally Posted by roadkillrob View Post
Why do you believe a thread from 13 months ago needs a new response?
Do threads have expiry dates?

If I spent my time posting a reply here, that most definitely means that I require a response.
valjay is offline  
Old 04-14-2018, 10:46 AM
  #20  
MBWorld Fanatic!
 
roadkillrob's Avatar
 
Join Date: Aug 2016
Posts: 1,215
Received 163 Likes on 139 Posts
2014 C63 507 with LSD Polar White

roadkillrob is online now  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Anyone notice low grinding noise when driving or turning slowly?y


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: