Notices
CL-Class (W215) 2000-2006: CL 500, CL 600

Need help with my new cl500

 
Old 03-26-2017, 12:57 PM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Received 0 Likes on 0 Posts
cl500 w215 w126 350sdl
Need help with my new cl500

Hello, I recently picked up a 2000 cl500 with a front end collision. Headlight, hood, gender, bumper, and rad support were affected. Drivers air bag also popped out. I was able to turn the car on with all the lights in the dash but it won't crank at all. When I turn the key to start it I don't hear anything. I've read around but couldn't find anything specific to the w215 that when the car crashes there's a safety switch that gets activated??? If anyone has any info on this please help me out I need to get the car started. Thanks !!!!!
zakxe30 is offline  
Old 03-26-2017, 11:55 PM
  #2  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
Yes there's a safety in the rear left side trunk I believe

but you likely have other issues
start with the fuse below the pasenger front carpet and apply battery power directly here as in this video
https://youtu.be/Jb_7E-Z5D7g

Need help with my new cl500-dab7bf89-07c0-4102-b6da-fda2597e26cf.jpg
tusabes is offline  
The following users liked this post:
zakxe30 (03-28-2017)
Old 03-27-2017, 11:57 PM
  #3  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Received 0 Likes on 0 Posts
cl500 w215 w126 350sdl







Originally Posted by tusabes View Post
Yes there's a safety in the rear left side trunk I believe

but you likely have other issues
start with the fuse below the pasenger front carpet and apply battery power directly here as in this video
https://youtu.be/Jb_7E-Z5D7g


Where should I start
zakxe30 is offline  
Old 03-28-2017, 02:16 AM
  #4  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
Start with the part I showed you , the junction block where the main battery cable attaches under the pasenger floor

your bolt to the main battery cable is rusty which suggest there had been water damage . You need to look at the underside of that junction block where the fuses I pictured are located
tusabes is offline  
Old 03-28-2017, 02:35 AM
  #5  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Received 0 Likes on 0 Posts
cl500 w215 w126 350sdl
Originally Posted by tusabes View Post
Start with the part I showed you , the junction block where the main battery cable attaches under the pasenger floor

your bolt to the main battery cable is rusty which suggest there had been water damage . You need to look at the underside of that junction block where the fuses I pictured are located
I fixed the rust, I didnt know that the junction block can open up or else i would've tried, I'll try it tomorrow when I'm with the car again. Also, when I turn the car on, it says 0 faults or malfunctions on the dash. Could that have anything to do ? and I found another junction box in the trunk but no visible switch. Anything you can tell me about that?
zakxe30 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Need help with my new cl500


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: