COMAND SSD Upgrade /Hard Drive Replacement - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CL-Class (W216)
COMAND SSD Upgrade /Hard Drive Replacement >

COMAND SSD Upgrade /Hard Drive Replacement

Notices
CL-Class (W216) 2007-Present: CL 500, CL 600

COMAND SSD Upgrade /Hard Drive Replacement

 
Old 02-14-2018, 02:03 PM
  #1  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Thumbs up COMAND SSD Upgrade /Hard Drive Replacement

Posting this in case other people have issues or need the info. I've been playing with the COMAND on my 08CL63 for a couple of days. After doing the telematics update and the map update I decided to upgrade the mechanical HDD to an SSD. I've read a couple threads that mentioned a HDD replacement with conflicting info. Here's my take on this:

- The original HDD is PATA/IDE, 44 pin. The COMAND connector automatically puts it in master mode.
- There are 4 partitions on the disk, all QNX4. If you're interested in extracting/mounting them, it's possible. You can also expand/resize them but there are no benefits in doing so and it's a pain.
- For NTG3, there is no copy protection. The HDD can be imaged to a file and easily restored to any other media.
- Not all mechanical HDDs will work and none of the IDE SSDs (all brand names) I tried worked. If you don't want to upgrade the HDD, just get the same original HDD model to avoid issues.
- If the COMAND cannot read the HDD it will say "Activating Navigation" (everything else will work like radio, etc.) for a while and then say that the software was updated and to insert the map DVD to update maps. It will then spit out the DVD and say that the map update is not possible. If you're having these symptoms then your HDD is most likely toast.
- Theoretically, you can replace the HDD with a blank one and then insert the map DVD, which should recreate all the necessary partitions/software. No need to image the HDD first.
- I've tried several IDE SSDs and none of them worked. It's most likely because they do not fully support all ATA protocols or don't provide all SMART data.
- I have tried several CF cards with different IDE adapters, NONE worked.
- In order to get it to work you're gonna need an IDE adapter based on the Marvell 88SA8052 chip. There are several around, based on what you're trying to convert to.
- If you image the HDD from the original, any size drive seems to work. The remaining space will remain unallocated.
- If you're replacing the hard drive try to get a drive with industrial/extended operation temperature ranges. The original is good for something like -40C to 85C. SSDs are generally 0C-70C so you may have issues in cold weather. The one I am using is -10C to 85C.

Remove unit from the car and take out the HD


Adapter with SSD



Reinstall in the vibration absorbing contraption...because why not.



Enjoy your new SSD and much faster map loading times.
megacrazy is offline  
The Following User Says Thank You to megacrazy For This Useful Post:
Parkl (01-20-2019)
Old 03-10-2018, 11:36 AM
  #2  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
Is that the Ableconn IIDE-MSAT mSATA SSD to 2.5-Inch IDE Adapter Converter?
EasyPhil is offline  
Old 03-11-2018, 03:22 PM
  #3  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Yup it is.
megacrazy is offline  
Old 03-28-2018, 10:50 AM
  #4  
Member
 
Join Date: Nov 2008
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
CL63, ML63, R500, GLK
I'm doing this monday when the mSata drive comes in but i pulled it all out and put it back together, now the disks wont load or eject nor do the red lights come on

Maybe i loosened a wire? or needs a reset?

Originally Posted by megacrazy View Post
Yup it is.
princemarko is offline  
Old 03-28-2018, 11:19 AM
  #5  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Originally Posted by princemarko View Post
I'm doing this monday when the mSata drive comes in but i pulled it all out and put it back together, now the disks wont load or eject nor do the red lights come on

Maybe i loosened a wire? or needs a reset?
Check all your connections. Otherwise it could be hardware damage. Does the rest of the unit work?
megacrazy is offline  
Old 03-28-2018, 04:35 PM
  #6  
Super Member
 
Join Date: Mar 2010
Location: London UK
Posts: 637
Thanked 58 Times in 46 Posts
2013 W204 C63 AMG, 2008 W221 S65 AMG
Apart from Map loading times, does this speed up the rest of the comand system?
alexanderfoti is offline  
Old 01-22-2019, 12:47 PM
  #7  
Newbie
 
Join Date: Jan 2019
Location: Detroit, MI
Posts: 12
Thanked 0 Times in 0 Posts
S550 w140, 07 S550
Originally Posted by megacrazy View Post
Check all your connections. Otherwise it could be hardware damage. Does the rest of the unit work?
Hey Mega, I sent you a direct message. Do you think you could help me with downloading the backup of your COMAND image?

My 07 S550 does not read discs and the 2nd used unit I purchased does not read them either after 10 seconds.

I am at the point where using someone else's updated data will be the smart thing to do then replacing the whole COMAND unit.
I already have STAR so I can re-program my car features once the HDD is installed with the new content.
Arlind86 is offline  
Old 01-22-2019, 02:06 PM
  #8  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
The Ableconn IIDE-MSAT mSATA SSD to 2.5-Inch IDE Adapter pictured has an operating temperature of 40f and doesn't work well in temperatures lower than 32 degrees F. I have an industrial msata SSD along with this adapter and currently in NYC we're experiencing temperatures below 32 degrees F and the navigation does not work until the car has warmed up. Just a heads up for those of you attempting to do this mod.
EasyPhil is offline  
Old 01-22-2019, 02:07 PM
  #9  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
Originally Posted by Arlind86 View Post
Hey Mega, I sent you a direct message. Do you think you could help me with downloading the backup of your COMAND image?

My 07 S550 does not read discs and the 2nd used unit I purchased does not read them either after 10 seconds.

I am at the point where using someone else's updated data will be the smart thing to do then replacing the whole COMAND unit.
I already have STAR so I can re-program my car features once the HDD is installed with the new content.
Does the command work otherwise? If it doesn't read disks, the problem can be the DVD drive in the unit and not the hard drive.
EasyPhil is offline  
Old 01-22-2019, 02:15 PM
  #10  
Newbie
 
Join Date: Jan 2019
Location: Detroit, MI
Posts: 12
Thanked 0 Times in 0 Posts
S550 w140, 07 S550
Originally Posted by EasyPhil View Post
Does the command work otherwise? If it doesn't read disks, the problem can be the DVD drive in the unit and not the hard drive.
Yes, the DVD reader is not working. COMAND is working completely fine. I have 2 commands, and both dvd readers have issues.
That's what happens when you buy used stuff I guess and can't return them because they were sold as-is.

To make matters worst, the firmware and maps are from 06 and 07 ..very out of date.
Arlind86 is offline  
Old 01-22-2019, 02:19 PM
  #11  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
If you can access the reader lens you can try cleaning it with alcohol which may make a difference provided the mechanism spins.
EasyPhil is offline  
Old 01-22-2019, 02:40 PM
  #12  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Originally Posted by EasyPhil View Post
The Ableconn IIDE-MSAT mSATA SSD to 2.5-Inch IDE Adapter pictured has an operating temperature of 40f and doesn't work well in temperatures lower than 32 degrees F. I have an industrial msata SSD along with this adapter and currently in NYC we're experiencing temperatures below 32 degrees F and the navigation does not work until the car has warmed up. Just a heads up for those of you attempting to do this mod.
Hmmm strange. What ssd do you have? Iím in the NJ area and everything worked fine yesterday in 14 degree weather.
megacrazy is offline  
Old 01-22-2019, 02:45 PM
  #13  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
Originally Posted by megacrazy View Post


Hmmm strange. What ssd do you have? I’m in the NJ area and everything worked fine yesterday in 14 degree weather.
This one: https://www.ebay.com/itm/Innodisk-64gb-Msata-3ME3-Industrial-Msata-MLC-SSD-DEMSR-64GD09BC2DC/382470497785?ssPageName=STRK%3AMEBIDX%3AIT&_trksid =p2060353.m2749.l2649

It works fine once the interior temperature of the car goes up but yesterday and today first getting into the car, nav isn't available. It could be that the seller sent me a non industrial msata. My research on devices with the Marvell 88SA8052 chip shows the operating temperatures lows to be 32 - 40F.

Update: I pretty sure the seller sold me the non-industrial version. The listing shows a non-industrial version as does the model number in the listing.

Last edited by EasyPhil; 01-22-2019 at 03:03 PM.
EasyPhil is offline  
Old 01-22-2019, 03:11 PM
  #14  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Originally Posted by EasyPhil View Post
This one: https://www.ebay.com/itm/Innodisk-64...53.m2749.l2649

It works fine once the interior temperature of the car goes up but yesterday and today first getting into the car, nav isn't available. It could be that the seller sent me a non industrial msata. My research on devices with the Marvell 88SA8052 chip shows the operating temperatures lows to be 32 - 40F.

Update: I pretty sure the seller sold me the non-industrial version. The listing shows a non-industrial version as does the model number in the listing.
Yeah like I mentioned before, I would double check the drive first. I'm using an ADATA drive. I think a lot of people used this adapter without issues in cold weather. Most of the time the issue was traced back to the SSD, as most people that did the mod got Samsung SSDs that are not rated for cold weather.

Personally I've never had cold weather issues with any of the sensors or microcontrollers that I used in my projects even though they were mostly rated for 0C. It could also be a matter of luck - as you get closer to temperature extremes, not all chips are created equal.



megacrazy is offline  
The Following User Says Thank You to megacrazy For This Useful Post:
EasyPhil (01-22-2019)
Old 01-22-2019, 04:02 PM
  #15  
Newbie
 
Join Date: Jan 2019
Location: Detroit, MI
Posts: 12
Thanked 0 Times in 0 Posts
S550 w140, 07 S550
I can't seem to find the Ableconn IIDE-MSAT mSATA SSD on ebay or amazon.

They are all SSD to Msata once I click on the link from google.
Arlind86 is offline  
Old 01-22-2019, 04:09 PM
  #16  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Yeah seems to be out of stock everywhere. See if you can find another adapter based on the same chip ( Marvell 88SA8052 ).
megacrazy is offline  
Old 01-22-2019, 05:13 PM
  #17  
Senior Member
 
Join Date: Feb 2009
Location: Brooklyn, NY
Posts: 289
Thanked 36 Times in 31 Posts
2004 S430 4Matic 2007 S550 4Matic
Originally Posted by Arlind86 View Post
I can't seem to find the Ableconn IIDE-MSAT mSATA SSD on ebay or amazon.

They are all SSD to Msata once I click on the link from google.
I must have bought the last one from Amazon.

EasyPhil is offline  
Old 01-22-2019, 05:47 PM
  #18  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Originally Posted by EasyPhil View Post
I must have bought the last one from Amazon.
Damn I should have bought a spare

I'm sure we can figure something else out if things go south.
megacrazy is offline  
Old 01-23-2019, 01:34 PM
  #19  
Newbie
 
Parkl's Avatar
 
Join Date: Oct 2011
Posts: 4
Thanked 0 Times in 0 Posts
CLS 55, W221 320
Hi Gents here.
So, I have the same issue like Mr. Arlind86. Comand DVD 6-pack reader doesn't read update mine latest navi dvd in NTG3.

Would be possible, if I make a backup of now working HDD w/t another adapter and HDD of course and just try to update maps folder from latest navi dvd?

(:
Parkl is offline  
Old 01-24-2019, 11:11 AM
  #20  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
Originally Posted by Parkl View Post
Hi Gents here.
So, I have the same issue like Mr. Arlind86. Comand DVD 6-pack reader doesn't read update mine latest navi dvd in NTG3.

Would be possible, if I make a backup of now working HDD w/t another adapter and HDD of course and just try to update maps folder from latest navi dvd?

(:
I already have an image with the updated maps. So a swap should be easy. However, there are settings and other things that are probably based on the firmware of the comand. I don't think that's stored on the disk...so an actual update would have to be done with SDS and a Telematics DVD.
megacrazy is offline  
The Following User Says Thank You to megacrazy For This Useful Post:
Parkl (01-24-2019)
Old 02-10-2019, 07:25 AM
  #21  
Newbie
 
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
S 320CDI 2006
Hi, new member here
so i followed instructions on replacing HDD, still getting software update message, insert lime green maps dvd, dvd format cannot be recognized pops on the screen.
Movie dvds, cds, mp3s all work fine so drive is ok, so is dvd-rom as reads fine on PC, where do i go from here ?
nephilim1973 is offline  
Old 02-11-2019, 03:39 PM
  #22  
Newbie
 
Join Date: Jul 2015
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes Benz CL500 C216
Will that disk with new maps work on an ntg3.5?
Orion81 is offline  
Old 02-13-2019, 03:30 PM
  #23  
MBWorld Fanatic!
Thread Starter
 
Join Date: Oct 2012
Posts: 1,048
Thanked 65 Times in 60 Posts
CLK55 W209, CL63 W216
You mean the SSD? You can replace any drive with an SSD.
megacrazy is offline  
Old Yesterday, 02:00 PM
  #24  
Newbie
 
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
S 320CDI 2006
megacrazy, i followed your instructions and no luck so far. Got couple of questions
1, what do you format the SSD to ? i tried fat32 and ext3, none work
2.have you got a clone of a disk that do work you could possibly share with me, that would allow me to see if it works at all or maybe its a hardware problem?
my old disk was fried beyond recovery
Cheers
Andy
nephilim1973 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: COMAND SSD Upgrade /Hard Drive Replacement


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: