Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > A-class (W168, W169,W176) > A-Class (W168, W169)
A168 - Changed power steering pump, but steering still heavy :( >

A168 - Changed power steering pump, but steering still heavy :(

Notices
A-Class (W168, W169) A140, A160, A160 CDI, A170 CDI, A190, A210 Evo, A180

A168 - Changed power steering pump, but steering still heavy :(

 
Old 06-01-2018, 05:17 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jun 2018
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
A170 CDI
A168 - Changed power steering pump, but steering still heavy :(

HI guys,

I have a A170 CDI (2001) which has been virtually faultless except last week, where the steering suddenly went heavy.

I've changed the power steering pump, but it's had no effect. Is there anything else I could try?

Many thanks,

Chris
Stanners is offline  
Old 09-29-2018, 03:08 PM
  #2  
Newbie
 
Join Date: Sep 2018
Posts: 11
Liked 1 Time in 1 Post
'99 w168, '99 w163
Hi:
The pump is ok? , have you proof the pump out? take it out there (it`s easy) and take 12v between terminals, if it goes right then we could looking for another issue
kraizeg is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: A168 - Changed power steering pump, but steering still heavy :(


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: