Notices
CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

Codes - Help

 
Old 05-11-2008, 07:16 PM
  #1  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
Codes - Help

The following codes popped up:

P0156 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 2)
P0161 - O2 Sensor Heater Circuit Malfunction (Bank 2 Sensor 2)
P0455 - EVAP Emission Control System Leak (Large)

Would you guys give me some insight as to how I would go about fixing the problems noted.

Thanks in advance for your help.
wnycec is offline  
Old 05-11-2008, 11:28 PM
  #2  
Senior Member
 
Join Date: Dec 2004
Posts: 390
Likes: 0
Received 1 Like on 1 Post
2000 Silver CLK430
I don't have experience with these but a quick search turned up a bunch of posts that you should check out for quick info. Good luck.
bs00clk is offline  
Old 05-12-2008, 04:07 PM
  #3  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
http://cgi.ebay.com/ebaymotors/Merce...m250246542632&

Anyone ever buy from this lister?
wnycec is offline  
Old 07-16-2008, 09:35 PM
  #4  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
Bump

These are the rear O2 sensors correct? Plan on swapping them out myself if anyone could confirm

Thanks!

wnycec is offline  
Old 07-16-2008, 10:15 PM
  #5  
MBWorld Fanatic!
 
Join Date: Mar 2008
Location: New York City
Posts: 1,753
Likes: 0
Received 0 Likes on 0 Posts
Yo Momma
thats the MAF sensor. O2 sensors are different looking and i dont think they are easy to change?
ZEEK is offline  
Old 07-16-2008, 10:52 PM
  #6  
Member
 
Join Date: Jan 2007
Location: Anaheim Hills, CA
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
CLK430, SC430, RX330
+1 ...that's the MAF sensor (Mass Air Flow sensor/meter). If you need 02 sensors, you are looking for these.

http://cgi.ebay.com/ebaymotors/_Car-...3756.m20.l1116

These are usually cheaper because they don't have the harness (plug)... You would have to use your original harness from the 02 sensor you're replacing.
ratha67 is offline  
Old 07-16-2008, 11:32 PM
  #7  
Super Member
 
sfclk's Avatar
 
Join Date: Mar 2008
Posts: 576
Likes: 0
Received 0 Likes on 0 Posts
1999 CLK320
I got a P0150 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 1) from my reader.

It goes away after a few days/drive cycles.

Which is which?

https://www.autohausaz.com/search/pr...xygen%20Sensor

Last edited by sfclk; 07-16-2008 at 11:35 PM.
sfclk is offline  
Old 07-17-2008, 11:14 AM
  #8  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
Originally Posted by wnycec View Post
The following codes popped up:

P0156 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 2)
P0161 - O2 Sensor Heater Circuit Malfunction (Bank 2 Sensor 2)
P0455 - EVAP Emission Control System Leak (Large)

Would you guys give me some insight as to how I would go about fixing the problems noted.

Thanks in advance for your help.
Confused everyone on my question - i mean P0156 and p0161 are the rear o2 sensors right?
wnycec is offline  
Old 07-17-2008, 05:49 PM
  #9  
Member
 
blisscafe's Avatar
 
Join Date: Apr 2006
Posts: 98
Likes: 0
Received 0 Likes on 0 Posts
i went to the stealship and told them my codes for the o2 sensor. they told me which ones then i went online and baught em. sorry it was a long time ago so i forget which codes i had
blisscafe is offline  
Old 07-17-2008, 06:00 PM
  #10  
Super Member
 
sfclk's Avatar
 
Join Date: Mar 2008
Posts: 576
Likes: 0
Received 0 Likes on 0 Posts
1999 CLK320
http://catalog.worldpac.com/mercedes...=Oxygen+Sensor

there's the 4 sensors for a 99, just don't know which is which still.

bank 1 is probably the front sensors.

someone here must know for sure.
sfclk is offline  
Old 07-17-2008, 06:30 PM
  #11  
Member
 
Join Date: Jan 2007
Posts: 86
Likes: 0
Received 0 Likes on 0 Posts
I'm not sure which is which but I had P0156 and p0161 codes.
Bought a can of MAF cleaner at PepBoys. Car runs stronger than
it did before after using the cleaner, even used it on the ML320
and the idle shakes are now gone.
BilOutkast is offline  
Old 03-09-2009, 11:25 PM
  #12  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
P0156 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 2)
P0161 - O2 Sensor Heater Circuit Malfunction (Bank 2 Sensor 2)

Whats the differences between these two codes... Trying to get this resolved and after further investigation I noticed the detail of the two codes was different.

wnycec is offline  
Old 03-11-2009, 07:18 AM
  #13  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
BUMP

Can anyone confirm that I need 15094 and 15092 to resolve the codes I am getting (P0156 & P0161)...

http://www.autohausaz.com/search/pro...xygen%20Sensor

Thanks in advance
wnycec is offline  
Old 06-19-2009, 05:05 PM
  #14  
Member
 
Join Date: Aug 2008
Posts: 245
Likes: 0
Received 0 Likes on 0 Posts
c32
i'm also getting the same codes I got po150,po156,po130,po136


can anyone tell me what i need to replace or do to fix it? thanks
batman6 is offline  
Old 06-23-2009, 05:54 PM
  #15  
Super Member
Thread Starter
 
wnycec's Avatar
 
Join Date: May 2005
Location: New York City
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
Originally Posted by batman6 View Post
i'm also getting the same codes I got po150,po156,po130,po136


can anyone tell me what i need to replace or do to fix it? thanks
Looks like you need all four oxygen sensors replaced.

autohausaz.com is where I picked mine up from. You need the two 02 sensors before the cat and the 2 after the cat. That should clear up your problems. Easy fix if you could easily get under ur car and you just follow what you take out and reinstall the new ones just like the old ones.
wnycec is offline  
Old 06-23-2009, 11:18 PM
  #16  
Super Member
 
unlukky's Avatar
 
Join Date: Apr 2007
Location: Fort Worth, TX
Posts: 637
Received 10 Likes on 10 Posts
2014 CLS550 4Matic
Cool

Originally Posted by batman6 View Post
i'm also getting the same codes I got po150,po156,po130,po136


can anyone tell me what i need to replace or do to fix it? thanks

I cannot imagine that all 4 O2 sensors went bad at the same time. Or, for that matter, that both primary CATs failed at the same time. For this, I would go with cleaning and or replacing MAF. My 2 cents.
unlukky is offline  
Old 06-24-2009, 07:43 PM
  #17  
Member
 
Join Date: Aug 2008
Posts: 245
Likes: 0
Received 0 Likes on 0 Posts
c32
thanks guys i will try this and report back.
batman6 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Codes - Help


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: