Notices
E-Class Coupe (C207) & Cabrio (A207) 2010-: E250CDI Coupe, E350 Coupe, E350CDI Coupe, E500 Coupe, E550 Coupe [Coupes & Cabriolets]

Lack of power w207 cgi 2010

 
Old 05-12-2019, 05:35 PM
  #1  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 2
Received 0 Likes on 0 Posts
Mercedes
Lack of power w207 cgi 2010

Hi everyone. I see that this forum is quite poor regarding info about E class 250 cgi w207 convertible 2010 204bhp 60k miles. Anyone that can help or give advice? I faced error code P0087 fuel rail/system pressure commanded position not reachable. The car acting strange, 1st start in the morning engine shaking like missing fire, after few mins everything comes to normal when out of gear. Once it's on reverse or drive the engine shacking badly until I'll release the break and car moves. While driving on low speed under 20 miles /h the car has a little shake especially when increase or decrease the gears itself (automatic gearbox). Also when I force it over 40 miles /h, especially on hills the car refuse to catch speed, shacking very bad like aggressive fire missed, then speeding as should. On sport mode this aggressive shake is much less. I've changed the rail fuel pressure sensor, right side fuel pump, both new and genuine Mercedes. The fuel filter of the right fuel pump was very bad, contaminated, almost totally blocked. After right fuel pump charged, the car acting much better, seems to have power but the issue wasn't fixed 100%, the car still shaking when engaged on reverse or drive before the car start moving. When engine runs on idle sometimes still a little shake is present and I can see the rpm gauge a little up & down. Also I monitored by diagnostic machine the fuel pressure delivered by fuel pump and there I have 60-100 hpa - around 0.01 bar. I intend to buy and change the left feed delivery fuel pump too. Any advice or opinion regarding all mentioned above? It worth to buy and try the left fuel pump too? Thanks in advance for any suggestion or opinion.

Last edited by Dan Crăciun; 05-13-2019 at 08:10 PM.
Dan Crăciun is offline  
Old 05-13-2019, 08:43 AM
  #2  
Super Member
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 712
Received 117 Likes on 103 Posts
2018 E400 Coupe, 2012 SLK350
I don't see many posts in the 207 forum for that engine. If it is the M271 EVO turbo 1.8L 4 cylinder, you might try the W204 forum as the C250, which shares that engine and for which the 207 chassis is based, will have many posts. Best of luck.
teksurv is offline  
The following users liked this post:
Dan Crăciun (05-13-2019)
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Lack of power w207 cgi 2010


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: