97 E420 Stalling - MBWorld.org Forums

Notices
E-Class (W210) 1995-2002: E 200, E 220D, E 240, E 290TD, E 300TD, E 200, E 240, E 280, E 320, E 420, E 430 (Wagon, Touring, 4Matic)

97 E420 Stalling

Reply

 
 
Old 05-10-2010, 11:27 AM
  #1
Newbie
Thread Starter
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
97 E420
97 E420 Stalling

Hi.

I have a 97 E420 that is stalling at a stop when the temp gauge gets around 80-100. I have changed the KPS and it's still doing it. It doesn't take a cool down period, it starts back immediately, and I don't have any CEL, but when it stalls the ARS and battery lights come on. I've read also that it could be the MAF, but again, there's no codes. Any help would be appreciated. Thanks in advance.
crownluv is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Vic_VA
E-Class (W212)
12
10-07-2015 08:56 PM
ECSTuning
Vendor Announcements
6
10-01-2015 04:57 PM
ECSTuning
AMG Vendor Classifieds
2
10-01-2015 04:56 PM
jaguar445e
E-Class (W124)
0
10-01-2015 02:17 PM
ECSTuning
MB Sedan Vendor Classifieds
4
09-30-2015 05:23 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:02 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: