Notices
E-Class (W210) 1995-2002: E 200, E 220D, E 240, E 290TD, E 300TD, E 200, E 240, E 280, E 320, E 420, E 430 (Wagon, Touring, 4Matic)

W210 CAn bus hub

 
Old 03-15-2019, 02:18 AM
  #1  
Newbie
Thread Starter
 
Join Date: Dec 2018
Location: Sydney Australia
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
e430
W210 CAn bus hub

Hi to the forum

I am having problems with my right hand drive e430 being stuck in limp mode, I think I have traced the problem to the can bus ( long story )
Can some one please tell me were the can bus hub us on a right hand drive w210.

Thanks in advance.
59bluebear is offline  
Old 03-15-2019, 07:07 PM
  #2  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,714
Thanked 575 Times in 558 Posts
1999 E300TD
Check the wiring located within the rocker panels.
Plutoe is offline  
Old 03-15-2019, 07:44 PM
  #3  
MBWorld Fanatic!
 
Join Date: Nov 2012
Posts: 4,584
Thanks: 0
Thanked 439 Times in 361 Posts
A gaggle of MB's
"Limp Mode" - since we don't have the full story - please search forum and stickies above this forum.

The transmission conductor plate (TCP) connects/communicates to the Transmission Control Module (TCM) in the engine compartment thru a "adapter plug" at the tranny up thru a cable.

Often - that adapter plug at the tranny has a internal leak which allows tranny fluid to "wick" up that cable that over time can fill/contaminate the TCM.

To properly diagnose any Limp Home mode - you need to assure proper/clean communication - by replacing that adapter plug (genuine MB or genuine MOPAR only) and pull-clean-dry the TCM board and connector.

Check the "stickies" in this forum - just trying to be of help mate !
fabbrisd1 is offline  
Old 03-18-2019, 03:57 AM
  #4  
Newbie
Thread Starter
 
Join Date: Dec 2018
Location: Sydney Australia
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
e430
Limp Mode

Hi thanks for the assistance
I have replaced the conductor plate and the plug on the end of the conductor plate.
I purchased the car with the fault and am sorting the problem slowly.
At this pint in time I did not have a MB scan tool.
Now have a scan tool I am receiving various can bus errors hense enquiring about the can bus.

Following up on the can bus I have a question I have identified three green white twisted pairs originating at the various control modules in the left hand side of the engine compartment.
Photo attached,

Checking the green white twisted pair with a dual channel oscilloscope I get what appears to be a can bus signal.

Is this correct ?

What has confused me is I found the x30 connector in the right hand sill panel near the base of the a pillar ( photo attached ) and I have been lead to believe this is the termination point for the can bus.
But the wires are brown red so I guess there is another point were the can bus terminates and changes colour?

Thanks for you assistance

Nigel




I
59bluebear is offline  
Old 03-18-2019, 10:17 PM
  #5  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,714
Thanked 575 Times in 558 Posts
1999 E300TD
yes
Plutoe is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: W210 CAn bus hub


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: