Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
SBC INSTALLATION QUESTTION >

SBC INSTALLATION QUESTTION

Notices
E-Class (W211) 2003-2009

SBC INSTALLATION QUESTTION

 
Old 01-30-2019, 05:54 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 6
Likes: 0
Recieved 0 Likes on 0 Posts
e200
SBC INSTALLATION QUESTTION

Hi, i recently bought a new sbc pump, my mechanic tried to install it, and start bleeding procedure,

he stopped and said that the (new) sbc pump is not working.
pump has no sound, just clicking sound.
my question is:

1. Should a new sbc pump needs programming and be married to the car in order to run?
2. should i hear the pump sound right away after installing and starting the car?

I am getting no fault codes under sbc pump whatsoever htats why we are puzzled.
*I THINK HE DIDNT DEACTIVaTE the old pump because when he arrives, he just went on unboltting the break lines and pull the wiring attached to the sbc pump.
car: w211 E200 K0mpressor 2006

thanks guys.

boygood is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: SBC INSTALLATION QUESTTION


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: