Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
2007 E550 no start/stalling after pulling fuse >

2007 E550 no start/stalling after pulling fuse

Notices
E-Class (W211) 2003-2009

2007 E550 no start/stalling after pulling fuse

 
Old 02-03-2019, 11:37 AM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Likes: 0
Recieved 0 Likes on 0 Posts
2007 E550
2007 E550 no start/stalling after pulling fuse

Hey all,

New E550 owner here. I picked up the car a few days ago - low mileage 07 and drove it 800 miles without issue. This morning I noticed the windshield sprayer didnt work so I checked two fuses - a 40 amp under the hood and a 5 amp in the door panel. After replacing fuses (both were fine) and buttoning everything back up the car wouldn’t start- no cranking. Everything in the car works fine so it doesn’t appear to be a battery issue. On the advice of a few posts I saw I disconnected the neg battery terminal and reconnected after 15 minutes. Car started without issue but stalled out about 30 seconds later. It started back up, I drove it around the block and it seemed fine. Started it up again to take a short trip to the store and it stalled out going 40 mph. I coasted it to a parking lot and disconnected the cable again, hoping the trick would work again. Any ideas? Thanks for your help.
Danmoultrie is offline  
Old 02-03-2019, 04:47 PM
  #2  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,763
Recieved 578 Likes on 561 Posts
1999 E300TD
There is something else very wrong as sprayer fuses don't stall MB's.However its either fuel pressure or a lack of voltage-----how do I test,you don't a person with the diagnostics and experience with the MB starting, fuel and electrical system does
Plutoe is offline  
Old 02-03-2019, 10:45 PM
  #3  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Likes: 0
Recieved 0 Likes on 0 Posts
2007 E550
Thanks Plutoe. As an update, I was able to get it restarted after leaving battery disconnected for a while. Drove it home, left it running for a while, drove it a few more places then it shut down again on the way back from a SB party... Wonderful. I wasnt able to get it restarted this time so it's going to the local euro specialist tomorrow.
Danmoultrie is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: 2007 E550 no start/stalling after pulling fuse


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: