Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Keyless entry module? >

Keyless entry module?

Notices
E-Class (W211) 2003-2009

Keyless entry module?

 
Old 02-07-2019, 10:55 AM
  #1  
Newbie
Thread Starter
 
HassanB's Avatar
 
Join Date: Feb 2019
Location: Czech Republic
Posts: 5
Likes: 0
Liked 0 Times in 0 Posts
CLS550
Question Keyless entry module?

Hello

yea, im another one, my keyless aint working. I tryed to search lot of threads on W219 and here in W211 section, but i didnt found any good answer for my kind of problem with this crap. I have 2009 CLS550. Both my front doors doesnt lock and unlock. Drivers side, and passenger side front doors. Locking buttons and unlocking buttons dont work. Both rear doors works perfectly. Car is at 80 000miles atm. Door handles are in perfect condition, no cracks, no signs of corosion or leaks. I dont think this is problem with door handles. I think it might be module. Or maybe wires? Does any one had this kind of problem with keyless?
Also one thing, previous owner split some suggary lemonade onto driver door panel. That caused very sticky window opening buttons which im about to change (just got new button panel). So im curious if i find something on that keyless module. But even if i do, and that module will be damaged, i think every door have its own module or not? I did find in some service manual that each of rear doors have its own module, same as trunk and start button. I didnt find anything about front doors tho. But im pretty sure there will be separate module for each front door too.

If anyone had similar problem with more then one door and both lock/unlock not working, pls let me know. I would love to have some shortcut with this... thanks!
HassanB is offline  
Old 02-07-2019, 02:12 PM
  #2  
MBWorld Fanatic!
 
bbirdwell's Avatar
 
Join Date: Jan 2014
Location: Republic of Texas
Posts: 1,853
Liked 395 Times in 324 Posts
'99 and '05 E55 AMG
A very brief description of how the system works on a 4-door W211...
https://mbworld.org/forums/mercedes-...ml#post7647270
bbirdwell is online now  
Old 02-07-2019, 02:33 PM
  #3  
Newbie
Thread Starter
 
HassanB's Avatar
 
Join Date: Feb 2019
Location: Czech Republic
Posts: 5
Likes: 0
Liked 0 Times in 0 Posts
CLS550
Originally Posted by bbirdwell View Post
A very brief description of how the system works on a 4-door W211...
https://mbworld.org/forums/mercedes-...ml#post7647270
HAH, so thats why i didnt found anything about modules in front doors, there are non. But well, that is messing with me pretty hard bcs both of those modules are clearly working since rear doors are opening and locking without problem :
HassanB is offline  
Old 02-07-2019, 04:53 PM
  #4  
Junior Member
 
Join Date: Aug 2009
Posts: 25
Liked 0 Times in 0 Posts
W211 E350
I believe what usually goes bad are the door handles. A bit 'fiddly' to replace, but reasonably easily done. Not inexpensive, though, perhaps $200 per handle.

See, e.g., https://mbworld.org/forums/clk-class...or-handle.html.
adamgoldberg is offline  
Old 02-07-2019, 05:22 PM
  #5  
Newbie
Thread Starter
 
HassanB's Avatar
 
Join Date: Feb 2019
Location: Czech Republic
Posts: 5
Likes: 0
Liked 0 Times in 0 Posts
CLS550
Well, i read lot of topics about it, and they all say, if its Locking OR unlocking, its the handle. But if its both at once, it very probably isnt. I do have 2 like that. And there is not even smallest scratch on rubber parts of those handles and no sign of corosion. I will try to remove door card on drivers door to check whats wrong there with that splitted lemonade. Clear connectors, change my window button pannel and will see. I will for sure not pay 400 usd just to see its still the same and problem is somewhere else. I can also try to connect my rear door handles to front doors and try if it works. But as i sadi, im almost sure handles are fine.
HassanB is offline  
Old 02-07-2019, 06:58 PM
  #6  
Junior Member
 
Join Date: Aug 2009
Posts: 25
Liked 0 Times in 0 Posts
W211 E350
I had both driver's side handles quit working entirely (neither lock or unlock). Externally, it didn't look like anything was wrong. The rubber button was fine, you couldn't see any corrosion, etc. I've replaced the driver's door, and it works fine now, and I took the old one apart and inside was fouled.

Somewhere on the net I saw someone who buzzed out the connector. It's something like a specific resistance when the unlock is pulled, and a different resistance when the lock button is pushed... you could certainly take the handle off and measure it with a multimeter.

I haven't gotten around to replacing the rear door.
adamgoldberg is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Keyless entry module?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: