Notices
E-Class (W212) 2010 - 2016: E 350, E 550

Rain & Technology

 
Old 05-13-2014, 07:57 AM
  #1  
Member
Thread Starter
 
Join Date: Mar 2014
Location: Sugar Land, TX
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
2011 E550
Rain & Technology

Driving to work today in a terrible rainstorm. After about 10 minutes of driving the display has a notice that Safe Assist is not working. Then the blind spot detection has a message saying it is not available.

Both said consult your owners manual which is a little difficult while driving.

Is this normal and have other people had the systems shut down during bad rain? If so that is a shame, because the worse the weather the more you would want that technology to work.

Hopefully at lunch the weather is clear and when I hop back into the car all is working well.
SLpat is offline  
Old 05-13-2014, 08:24 AM
  #2  
Senior Member
 
drsaab's Avatar
 
Join Date: Mar 2005
Location: Vienna, VA
Posts: 409
Likes: 0
Received 1 Like on 1 Post
Yes in heavy snow or rain these turn off for me too.
drsaab is offline  
Old 05-13-2014, 10:49 AM
  #3  
Super Member
 
dfordham's Avatar
 
Join Date: Apr 2007
Location: New Mexico
Posts: 561
Likes: 0
Received 1 Like on 1 Post
2014 E350, 2012 SL550
Moisture is highly reflective to radar. These systems are smart enough to turn themselves off when real return signals are masked by the "clutter" generated by rain or snow.

Regards,
Don
dfordham is offline  
Old 05-13-2014, 05:11 PM
  #4  
Super Member
 
Join Date: Jun 2011
Location: Placitas, NM
Posts: 576
Likes: 0
Received 5 Likes on 3 Posts
E550
Originally Posted by dfordham View Post
These systems are smart enough to turn themselves off when real return signals are masked by the "clutter" generated by rain or snow.
Or by hordes of grasshoppers smacking on the radar cover at 80mph!
Live Oak is offline  
Old 05-13-2014, 07:33 PM
  #5  
Senior Member
 
Join Date: May 2013
Location: Boston
Posts: 325
Likes: 0
Received 0 Likes on 0 Posts
2010 E550
Originally Posted by Live Oak View Post
Or by hordes of grasshoppers smacking on the radar cover at 80mph!
That's just nasty. It must take quite a bit of elbow grease to remove the insect residue inside and out.
stale-bread is offline  
Old 05-18-2014, 01:49 PM
  #6  
Junior Member
 
Join Date: Mar 2014
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
2014 E350
I get the same message if its really really cold in the morning. i always figured the glass was frozen. worked after 10 min driving and warming up.
ats-1 is offline  
Old 05-18-2014, 06:53 PM
  #7  
Junior Member
 
velocity12's Avatar
 
Join Date: Oct 2013
Posts: 44
Likes: 0
Received 0 Likes on 0 Posts
E350Cab
Got the same messages after going through a car wash. Took a few minutes to reactivate.
velocity12 is offline  
Old 05-21-2014, 01:40 AM
  #8  
Super Member
 
Join Date: Nov 2009
Location: Earth (Mostly)
Posts: 562
Received 2 Likes on 2 Posts
2014 E350
Originally Posted by velocity12 View Post
Got the same messages after going through a car wash. Took a few minutes to reactivate.
+1 most always after a power carwash, but never from a hand washing
samkimg is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Rain & Technology


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: