10.25 inch android headunit installed - Page 27 - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
10.25 inch android headunit installed >

10.25 inch android headunit installed

Notices
E-Class (W212) 2010-present: E 350, E 550

10.25 inch android headunit installed

Old 08-28-2018, 03:02 PM
  #651  
Newbie
 
Join Date: Aug 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
E-350 w212 2015
wire check

Originally Posted by Avilly View Post





I couldn’t figure out how to get the head unit back in with all the cabling either. I had to drive to work to day with my head unit sticking out about 2 inches and the vent trim just loosely placed. See pic. It looks embarrassing. all the DIY videos show the head unit just slipping right in. Anyone have suggestions?

I did run the USB cable up and into the glovebox space adjacent to the vents. I still have to removed the glovebox upper lining to pull it thru. There are a few small openings in the upper lining of the glovebox and I can feel it with my finger. I probably won’t get to this for another few weeks due to time.


Hi there, check please if you have all same wire which you have?! i have same car and i thought something missing, my screen not showing anything after installing


waleed-911 is offline  
Old 08-28-2018, 06:44 PM
  #652  
Newbie
 
Join Date: Jun 2018
Posts: 13
Thanked 1 Time in 1 Post
2013 C207
Hi all. I have a couple questions if someone is able to assist? Regarding the 3.5mm aux input used by the Android unit. Is there a 3.5mm on the Android unit itself? I ask because the 3.5mm input for the COMAND unit will be used by the Android screen itself, leaving no input for any other devices. I bought a 3.5mm splitter just in case, but thought I would ask in case I am missing something?

I also have a similar question regarding the GPS fakra connection. Can I split the factory GPS to both the COMAND unit and the Android unit? I bought a splitter for that as well, but I am curious is anyone has had any success with it?

And finally, do I need the two pin speaker that's included in the box? I know someone had asked a similar question, but I can't find it now.

Last edited by Splise; 08-28-2018 at 07:02 PM.
Splise is offline  
Old 08-28-2018, 07:42 PM
  #653  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
The Android unit occupies the AUX 3.5 MMI input. I would not bother messing with GPS as you might mess of the gain of the COMAND system. The included GPS antenna works fine if properly positioned under the dash. You do not need the speaker thing. mic is built into the V2 and audio is through car audio (via AUX). You can connect other items to the V2 using BT audio or USB (2 USB ports are included, plus there is onboard MicroSD slot. There are some RCA connectors built into the hardness but I am not sure if they are general inputs or meant for cameras. There appears to be RCA audio (but I never bothered trying it and did not see any setting regarding AUX in with the V2).

Last edited by Skeechan; 08-28-2018 at 07:45 PM.
Skeechan is offline  
The Following User Says Thank You to Skeechan For This Useful Post:
Splise (08-28-2018)
Old 08-28-2018, 07:51 PM
  #654  
Newbie
 
Join Date: Jun 2018
Posts: 13
Thanked 1 Time in 1 Post
2013 C207
Originally Posted by Skeechan View Post
The Android unit occupies the AUX 3.5 MMI input. I would not bother messing with GPS as you might mess of the gain of the COMAND system. The included GPS antenna works fine if properly positioned under the dash. You do not need the speaker thing. mic is built into the V2 and audio is through car audio (via AUX). You can connect other items to the V2 using BT audio or USB (2 USB ports are included, plus there is onboard MicroSD slot. There are some RCA connectors built into the hardness but I am not sure if they are general inputs or meant for cameras. There appears to be RCA audio (but I never bothered trying it and did not see any setting regarding AUX in with the V2).
Thanks for the info, much appreciated. Good point regarding the gain on the GPS antenna, I may end up trying to get it routed up to my rear view mirror if the signal isn't sufficient. I use a portable DAC to convert the FLAC I have on my phone (or other device) to an analog signal, so it would be nice to have a 3.5mm input to use. I am not a huge fan of the 3.5mm aux splitter, but it appears that may be the only option?

Last edited by Splise; 08-29-2018 at 10:56 AM.
Splise is offline  
Old 08-28-2018, 09:50 PM
  #655  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
The built in media player has native FLAC support plus you can download whatever you want using the google play store. I have FLAC plus ts Blu-ray tips and all play fine.
Skeechan is offline  
Old 08-29-2018, 09:32 AM
  #656  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,255
Thanked 136 Times in 105 Posts
W212 E63 wagon, ML350, GLK 350
FINALLY BACK!!!!!!!!!!!!!!!! So frustrating sitting here reading all and not be able to answer. I have NO CLUE what so ever why they banned me??? I advertise no where and I am very carefull with that. Never a link posted to my webstore. And I can not contact them and ask why or explain if a mistake is done They just freeze you out with no options at all!!!
Chris The Swede is offline  
The Following User Says Thank You to Chris The Swede For This Useful Post:
etian (08-30-2018)
Old 08-29-2018, 10:04 AM
  #657  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
Welcome back!
Skeechan is offline  
The Following User Says Thank You to Skeechan For This Useful Post:
Chris The Swede (08-29-2018)
Old 08-29-2018, 05:02 PM
  #658  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
Originally Posted by Skeechan View Post

6. When using the phone app, is it still only outputting on the left speaker?

Worked from all speakers in my V2
Hello Skeechan. I have the problem with waze who's still outputting on the front left speaker. Any advice ?

Last edited by etian; 08-29-2018 at 05:12 PM.
etian is offline  
Old 08-29-2018, 05:05 PM
  #659  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
I have no problem with waking now and phone is all speakers. Not sure why you would have only one side.
Skeechan is offline  
Old 08-29-2018, 05:14 PM
  #660  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
Originally Posted by Skeechan View Post
I have no problem with waking now and phone is all speakers. Not sure why you would have only one side.
sorry. its with waze the problem not with wake
etian is offline  
Old 08-29-2018, 05:17 PM
  #661  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
My waze works fine. Unthethered you only get map and routing, but not dynamic routing and traffic. It works fine on mine including automatic muting of entertainment while speaking alerts/directions. I have never had the one speaker problem with Waze or phone.

If you have not checked already, check auto playback of other V2 functions to make sure everything is not left side like the AUX input is not plugged in all the or something. It should be either everything audio on the V2 works or none of it does.
Skeechan is offline  
Old 08-29-2018, 05:18 PM
  #662  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
Like load a music file on the V2 and make sure it plays out all speakers.
Skeechan is offline  
Old 08-29-2018, 05:23 PM
  #663  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
Originally Posted by Skeechan View Post
Like load a music file on the V2 and make sure it plays out all speakers.
when I'm using video or music with sample in the V2, everything is ok.
its only with waze
etian is offline  
Old 08-29-2018, 05:34 PM
  #664  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
If memory serves, in Waze apps there is a setting for audio output, like *phone audio*, Bluetooth, etc. See if you can find that setting in Waze and try the different options.
Skeechan is offline  
Old 08-30-2018, 01:08 AM
  #665  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
Many thanks. I will tell you
etian is offline  
Old 08-30-2018, 02:49 AM
  #666  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
Originally Posted by Skeechan View Post
If memory serves, in Waze apps there is a setting for audio output, like *phone audio*, Bluetooth, etc. See if you can find that setting in Waze and try the different options.
it works. It was in Waze settings ! Many thanks.
etian is offline  
Old 08-31-2018, 06:25 AM
  #667  
Member
 
Join Date: May 2007
Location: S JERSEY/PHILLY
Posts: 217
Thanks: 0
Thanked 8 Times in 8 Posts
2007 mercedes e63, 2006 bmw 530 Xi with Mtech kit , 2005 ford expedition
I'm def digging the newer unit but still on the fence on the size of the screen... Anyone in the Philly , south Jersey area have this installed on there 212 ?
bigjule is offline  
Old 08-31-2018, 06:35 AM
  #668  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,255
Thanked 136 Times in 105 Posts
W212 E63 wagon, ML350, GLK 350
The size is the best thing here..
Chris The Swede is offline  
Old 08-31-2018, 08:20 AM
  #669  
Newbie
 
Join Date: Aug 2018
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
W212
Is there a new version of aliexp 4 ram android 8! Has anyone bought it?

Autostereo Android 8 Car GPS Navigation Head Unit For MERCEDES-BENZ E220 W212 2009-2016 multimedia radio tape recorder No DVD 9 " Octa core CPU 32GB ROM 4GB RAM
Charlii is offline  
Old 08-31-2018, 08:35 AM
  #670  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,255
Thanked 136 Times in 105 Posts
W212 E63 wagon, ML350, GLK 350
Originally Posted by Charlii View Post
Is there a new version of aliexp 4 ram android 8! Has anyone bought it?

Autostereo Android 8 Car GPS Navigation Head Unit For MERCEDES-BENZ E220 W212 2009-2016 multimedia radio tape recorder No DVD 9 " Octa core CPU 32GB ROM 4GB RAM
I would NOT trust that one...First they write 8 then 7.1 They just dont know wht they sell..
Chris The Swede is offline  
Old 08-31-2018, 09:23 AM
  #671  
Member
 
Join Date: May 2007
Location: S JERSEY/PHILLY
Posts: 217
Thanks: 0
Thanked 8 Times in 8 Posts
2007 mercedes e63, 2006 bmw 530 Xi with Mtech kit , 2005 ford expedition
Originally Posted by Chris The Swede View Post
The size is the best thing here..
I def see were u coming from BUT it just seems a tad bit like it can be a lil distracting? .. especially at night ... But I mite b totally wrong .. I've looked a bunch of videos of the unit but kind of hard to gauge as most of them are videos showing the unit at close up range ... Just wish the unit was recessed a bit but like I said I mite b wrong... Hence the reason y I would like to see one before I pull the trigger
bigjule is offline  
Old 08-31-2018, 10:21 AM
  #672  
Newbie
 
Join Date: Jul 2018
Posts: 8
Thanked 0 Times in 0 Posts
W204 320 CDI
I'm looking for : how to reboot the V2 screen, please.
etian is offline  
Old 08-31-2018, 10:23 AM
  #673  
Junior Member
 
Join Date: Jul 2018
Posts: 44
Thanks: 0
Thanked 6 Times in 5 Posts
GLC X253
Originally Posted by etian View Post
I'm looking for : how to reboot the V2 screen, please.
Switch off the car, open the driver door, restart the car.
Or: paper clip in the top hole on the left.
Sly_North is offline  
The Following User Says Thank You to Sly_North For This Useful Post:
etian (08-31-2018)
Old 08-31-2018, 02:21 PM
  #674  
Newbie
 
Join Date: Jun 2018
Posts: 13
Thanked 1 Time in 1 Post
2013 C207
Does anyone know which Bluetooth version is supported by the Android unit?
Splise is offline  
Old 08-31-2018, 02:38 PM
  #675  
Member
 
Join Date: Jul 2018
Location: Laguna Hills, CA and Himeji, Japan
Posts: 91
Thanked 13 Times in 11 Posts
2011 W212
I cannot find the HW version using built in settings tools. Under BT it is only configuration and BT version is not listed under SW or About Device either. The only BT anything reference I saw is in About Device which shows HMI, MCU, Media and BTV with BTV as BT.18.07.03.0930 which just appears to be a build number. There might be an app in the play store that could dig in and actually fetch HW info from an Android device, but I have not seen one that will report the actual version, best is just BT vs BT LE which for the V2 doesn't matter since it is not running on batteries. It will certainly be at least 2.1 and newer versions are not relevant as they are power saving features or LTE friendly coexistance features or range extending features. It doesn't support BT tethering or anything so the benefits of BT 3 and 4 speed don't help.

What were you looking for?

Last edited by Skeechan; 08-31-2018 at 02:44 PM.
Skeechan is offline  
The Following User Says Thank You to Skeechan For This Useful Post:
Splise (08-31-2018)

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 6 votes, 3.67 average.

Quick Reply: 10.25 inch android headunit installed


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:
You Rated this Thread: 5