Notices
E-Class (W212) 2010 - 2016: E 350, E 550

e350 running to cold

 
Old 02-18-2019, 06:18 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2010 E350 sports
e350 running to cold

I recently had to change my upper radiator hose do to the overflow hose hanging and getting cut by fan. I put the new hose on and topped off with fluid that I purchased from MB and was fine for a day. Yesterday I get an engine light and the code from my reader says the thermostat is stuck open. I ordered a new thermostat but my question is. Do I need to bleed the system, could not bleeding it after the change of the hose cause this code? Also, anyone know of how to bleed the system in a 2010 E350 4dr base?
Bossie is offline  
Old 02-18-2019, 02:25 PM
  #2  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,912
Received 589 Likes on 572 Posts
1999 E300TD
If done correctly----YES.....wait for Konigstar to post the WIS docs
Plutoe is offline  
Old 02-18-2019, 03:08 PM
  #3  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
I ordered my thermostat on Friday
as i have this problem too.
You dont have to bleed the coolant , some of it you will lose when disconnecting the hose from thermostat , but at the end of replacement you can just top off whatever amount you need. At least that what im gonna do once i receive mine.
belarus27 is offline  
Old 02-18-2019, 04:13 PM
  #4  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2010 E350 sports
Thanks for the info. Will it be ok to drive while I wait for the new one?
Bossie is offline  
Old 02-18-2019, 04:15 PM
  #5  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,453
Received 392 Likes on 362 Posts
2014 E550 4Matic Designo Diamond White and loaded up
Originally Posted by Bossie View Post
Thanks for the info. Will it be ok to drive while I wait for the new one?
Yes. The default failure condition is full open as you are experiencing.

KEY08 is online now  
Old 02-19-2019, 05:52 PM
  #6  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
I been driving like this for almost a week now.
waiting for my new part to come..but these holidays dont make it any faster.
it stays around 80... 75-80 sometimes it does go to 85ish.
belarus27 is offline  
Old 02-20-2019, 12:05 AM
  #7  
MBWorld Fanatic!
 
cetialpha5's Avatar
 
Join Date: Feb 2014
Location: MA
Posts: 3,471
Received 365 Likes on 327 Posts
2008 E350 4Matic, 2011 E350 4matic
Wahler is the OEM maker of the thermostat and it's pretty common that they fail open. I think I got mine on Amazon. Didn't need to bleed the system, you lose a little coolant when you swap it out, but I just topped it off and it was fine. While you're doing the thermostat, check the two pulleys and tensioner for play, those are also well known to go too and you have to take off one of the pulleys to replace the thermostat.
cetialpha5 is offline  
Old 02-21-2019, 02:31 AM
  #8  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
Update.
got thermostat today and replaced it.
Right now just need to reset the CEL light.
belarus27 is offline  
Old 02-22-2019, 07:18 AM
  #9  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2010 E350 sports
Originally Posted by Bossie View Post
I recently had to change my upper radiator hose do to the overflow hose hanging and getting cut by fan. I put the new hose on and topped off with fluid that I purchased from MB and was fine for a day. Yesterday I get an engine light and the code from my reader says the thermostat is stuck open. I ordered a new thermostat but my question is. Do I need to bleed the system, could not bleeding it after the change of the hose cause this code? Also, anyone know of how to bleed the system in a 2010 E350 4dr base?
update: I replaced the thermostat and all is well. The temp is back up and running good.
Bossie is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: e350 running to cold


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: