Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W213)
Fuel gauge stopped working for few days >

Fuel gauge stopped working for few days

Notices
E-Class (W213) 2016 -

Fuel gauge stopped working for few days

 
Old 02-19-2019, 08:24 AM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2016 E-Class 220 CDI Wagon (S213)
Fuel gauge stopped working for few days

I have a 2016 220 CDI wagon (S213). Anyone else had problems with fuel gauge? One day when leaving work noticed that fuel gauge was showing empty and range was showing 0 km. No low fuel notice or other warnings. Drove to a gas station and filled her up, tank was quite empty, was able to fit 70 liters (18.5 gal). But fuel gauge was still showing empty and range was 0 km. Made an appointment to a dealer and kept driving for four days when suddenly the gauge started working in the middle of a drive and has been working fine since.
The dealer appointment is next Thursday. Will probably still go there and let them inspect it but I'm skeptic they will find anything.

I noticed that there is a service campaign relating to the wiring, anyone had issues like this?:
Service Campaign 2016100001 OCT16 - 2017 213 under certain loading conditions the rear seat bench seat frame could damage the wiring harness to the fuel system control module depending on the affected wire, it could affect the operation of the fuel pump, the fuel tank pressure sensor, or the fuel gauge. Should the fuel pump fail, the fuel supply to the engine would stop and the engine could subsequently stall. Dealer will repair/reroute harness. Approximately 6,858 vehicles are involved.
_AK_ is offline  
Old 03-08-2019, 01:22 AM
  #2  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2016 E-Class 220 CDI Wagon (S213)
Update to the problem. Fuel gauge started working by itself after four days of driving. When I took it to the dealer they checked the codes and found out that left fuel level sensor had given a fault code. They reset the code and said that if the problem happens again the sensor needs to be replaced. They also told me that the sensor is not available separately! the whole tank needs to be replaced!.

And it indeed did happen again when the tank got empty enough. Taking the car to the dealer next week and if it is the same error, they'll replace the whole tank. I'm happy that I'm still under warranty.
_AK_ is offline  
Old 03-09-2019, 07:14 AM
  #3  
Super Member
 
guhvies's Avatar
 
Join Date: Feb 2006
Location: Bromley, UK
Posts: 758
Thanked 73 Times in 69 Posts
2017 C43 AMG Saloon
Seriously though, stop letting your tank get empty or near empty. That ain't cool...
guhvies is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Fuel gauge stopped working for few days


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: