Notices
G-Class (W460, W461, W463) 1980-Present: 290 GD, 290 GDT, 300 GD, 350 GD, 500 GE, G 250, G 300, G 300 DT, G 320, G 500, G55 AMG

2016 G63 Possible Transmission/Eco Issue

 
Old 09-24-2018, 05:34 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
G63
2016 G63 Possible Transmission/Eco Issue

I have a 2016 G63 and haven't had any huge issues with it until now. It has less than 40,000 miles. I will be stopped in traffic or at a stoplight and the eco will go on (i.e. the engine will turn off). However, when I take my foot off the brake to start driving again, the engine does not switch back on. The car will suddenly be in neutral and will not allow me to put it back in drive unless I turn the entire car off and back on again. This has happened a number of times and I've taken the car to two dealerships without any luck - nobody can figure out what the issue is. So far, all they've tried doing is replacing the battery. I read a thread with a similar issue for a 2015 G63, but the issue was never resolved. Has anyone had this issue? Any ideas as to what this may be? I currently have a loaner car and would love to be able to nudge the dealership in the right direction.
AMR1014 is offline  
Old 09-26-2018, 12:26 PM
  #2  
Senior Member
 
Join Date: Aug 2015
Location: US
Posts: 456
Thanked 77 Times in 59 Posts
2018 E400W4
Originally Posted by AMR1014 View Post
I have a 2016 G63 and haven't had any huge issues with it until now. It has less than 40,000 miles. I will be stopped in traffic or at a stoplight and the eco will go on (i.e. the engine will turn off). However, when I take my foot off the brake to start driving again, the engine does not switch back on. The car will suddenly be in neutral and will not allow me to put it back in drive unless I turn the entire car off and back on again. This has happened a number of times and I've taken the car to two dealerships without any luck - nobody can figure out what the issue is. So far, all they've tried doing is replacing the battery. I read a thread with a similar issue for a 2015 G63, but the issue was never resolved. Has anyone had this issue? Any ideas as to what this may be? I currently have a loaner car and would love to be able to nudge the dealership in the right direction.

You have the car under warranty so talk with MB service. I know about this issue on different MB models and they had a easy fix.
Wassaby is offline  
Old 09-26-2018, 12:43 PM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
G63
Originally Posted by Wassaby View Post
You have the car under warranty so talk with MB service. I know about this issue on different MB models and they had a easy fix.
Thank you, but I have taken my car to multiple dealerships and nobody has ever heard of this happening. Unfortunately, my car was returned yesterday with yet another dealership unable to find any issues to resolve this intermittent problem. Two dealerships have also discussed this issue with MB in New Jersey and a specialist in Germany and nobody has any answers.
AMR1014 is offline  
Old 09-28-2018, 11:57 AM
  #4  
Senior Member
 
NYCBenz's Avatar
 
Join Date: Mar 2014
Location: New York, New York
Posts: 319
Thanked 57 Times in 46 Posts
6x6 | 4x4
Originally Posted by AMR1014 View Post
Thank you, but I have taken my car to multiple dealerships and nobody has ever heard of this happening. Unfortunately, my car was returned yesterday with yet another dealership unable to find any issues to resolve this intermittent problem. Two dealerships have also discussed this issue with MB in New Jersey and a specialist in Germany and nobody has any answers.
Not sure what the issue is, and I am sure you have thought about this: Turn off the eco button every time you get in your car to drive, to temporarily alleviate the situation?

Haven't heard of this problem on any MB with the start/stop feature.
NYCBenz is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 2016 G63 Possible Transmission/Eco Issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: