Notices
G-Class (W460, W461, W463) 1980-Present: 290 GD, 290 GDT, 300 GD, 350 GD, 500 GE, G 250, G 300, G 300 DT, G 320, G 500, G55 AMG

G55, No Start After Repairing EIS

 
Old 02-07-2019, 10:53 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jul 2018
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
SVT Cobra
G55, No Start After Repairing EIS

Ugh...

2008 G55 80k miles. Started having issues with the key a few months ago, not starting on the first twist or two. Then it would just not start.. thought it was the key batteries, replaced those, pulled and checked the car battery. If I let the truck sit for an hour or two it would start up after the failed attempts. Started doing some research, looked like EIS was going out. Then it refused to start, and left me stranded. Towed it home, took it to the dealer hoping my aftermarket warranty would cover it.

Bull**** ensued and the dealer wanted $1,900 to replace the EIS. Pulled it, shipped it to Pressertech, paid $600, got it back. Installed it and it fired up perfectly.

Took out the truck. Got dinner, got gas.. and heading home, it just died and coasted to a stop. Radio shut off.

Cluster lit up with "Restraint System Visit Workshop SRS". I put it park, turned the key, dash would not unlight, put the key back in, key turned and all but it did nothing. Power locks would not work, nor would remote key.

Since I still had my tools, I figured I'd unplug the battery and let it reset. Reset, but still won't start, I noticed the stereo when off was not lit and was flickering.

Towed the trash can home.

Noticed the passenger side running lights remained on... unplugged the battery so not to drain it.

It's freezing cold and raining and I can't get the trash can into the garage. So I'll have to wait to start checking fuses and any loose ground straps.

Suggestions and thoughts are greatly appreciated.
Cobric is offline  
Old 02-09-2019, 12:05 PM
  #2  
Newbie
Thread Starter
 
Join Date: Jul 2018
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
SVT Cobra
So can't get thr OBD2 reader to sync since I can't turn the ignition key. Ordered a MBII which will be here tommorow.

Also can't seem to check the fuses since it doesnt look like they have power?

Dash now shows this.


Cobric is offline  
Old 02-10-2019, 09:53 PM
  #3  
Newbie
Thread Starter
 
Join Date: Jul 2018
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
SVT Cobra
Whelp... iCarsoft MBII arrived -

Plugged in it, menus powered up, selected the appropriate vehicle - ran auto scan - nothing.

Started to run manually scan -

I got this for every system I tried "Fault in communication with vehicle ECU" followed with check that it's plugged in and that the vehicle is a supported platform.
Cobric is offline  
Old 02-11-2019, 09:09 PM
  #4  
Junior Member
 
Join Date: Jan 2007
Location: Dubai, United Arab Emirates
Posts: 16
Liked 3 Times in 3 Posts
W221 2007
Sounds like a bad ground connection somewhere.
worst case situation though, looks like the car lost its BCM/ECU programming somehow, dash on mileage means communication error/mismatch between the systems.
jackaleman is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: G55, No Start After Repairing EIS


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: