C300 ignition problem - MBWorld.org Forums

Notices
General Mercedes Discussion Use this forum to discuss general Mercedes-Benz topics that are not specifically model related.

C300 ignition problem

Reply

 
 
Old 12-24-2012, 01:19 PM
  #1
Newbie
Thread Starter
 
Join Date: Dec 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
C300, 2008
C300 ignition problem

I have a 2008 C300 with 90,000 miles, it is currently in repair shop diagnosed with bad ignition switch and computer problem. has anyone else encountered problems like this. So far my repair cost is $1100 and counting.
drmann83 is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
djokodallas
C Class (W205)
43
10-08-2016 07:59 PM
RothnerD
C-Class (W203)
9
09-14-2015 06:27 PM
jakc
C Class (W205)
9
09-04-2015 11:50 PM
alexfirth91
C-Class (W204)
5
09-03-2015 05:50 PM
System500SEL
S-Class (W140)
0
09-03-2015 12:39 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:08 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: