Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

ML Bogs in the morning

 
Old 05-18-2006, 10:50 PM
  #1  
Out Of Control!!
Thread Starter
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
ML Bogs in the morning

Hey guys, my heap is at it again... Start the car in the morning(or the first time during the day) and when I start it up, it needs to FULLY warm up, not the little warm up to when the needle idles normally. If its not warm, and you put it in gear and put your foot on the gas it stalls... as soon as you try to give it anything more then a little gas its like its starved of gas and stalls out.

I think I have a pretty good handle on what it is but other opinions couldnt hurt.

My diagnosis...
Well talking to my cousin and some other station owners I have been hearing the new Ethanol blend in Mobil/exxon gas is pretty killer on fuel systems. I think that my fuel filter may be dirty and when the car is just getting started for the first time during the day the junk in the line is getting caught in the filter... The filter needs to be replaced anyway as there are 106k miles on the car anyways. So thats my thoughts, what do you all think?
55fanatic is offline  
Old 05-19-2006, 10:08 AM
  #2  
Member
 
Join Date: Feb 2004
Location: Houston, TX
Posts: 205
Likes: 0
Received 2 Likes on 2 Posts
MY2004 E320
It is highly possible that its fuel filter but I have concerns. If the fuel filter is clogged, it would dog all the time - not when heated up.

Have your checked your cats lately? Could be choked up and taking time to heat up. I would think that will trigger CEL but maybe not. I had a nissan 200SX (1980 model) loooong time ago that developed exact same symptoms. Cats were choked up and started flowing better when heated up.

Also check your air filter. Simple to do and you will be amazed sometimes as to what you will find in there. My neighbors Camry refused to stay started one day and we found a plastic bag sucked in and blocking most of the air intake.

Keep us posted and Good Luck!
mobinakhtar is offline  
Old 05-19-2006, 12:07 PM
  #3  
Out Of Control!!
Thread Starter
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
could very well be the Cats... they have been throwing codes for a couple years... After the Dealer screwed me out of getting new ones under warranty(dont really want to repeat the story, I have posted it a few times but should anyone be interested you can PM me) I refused to change them. I finally broke down and got a price to get them replaced at a local exhuast shop, guess Im going to have to now. And I know its not the filter because I have a cone filter on it...
55fanatic is offline  
Old 05-19-2006, 12:10 PM
  #4  
Out Of Control!!
Thread Starter
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
You think the MAS? I have had a feeling that its been going hay wire for a while now... just was never positive.
55fanatic is offline  
Old 05-19-2006, 12:24 PM
  #5  
Member
 
Join Date: Feb 2004
Location: Houston, TX
Posts: 205
Likes: 0
Received 2 Likes on 2 Posts
MY2004 E320
Actually stop by a mufler shop. They should check cats for free. Also here is a non-techy trick. In the morning (cold start) have someone start the ML and put your hand on the exhaust exit. If the exchausing gases are smooth, its something else. If they break coming out (burst, break , burst) it could be cats. then again, this is no true test - just something somneomne mentioned. I strongly suggest to take it to another deaer or a muffler shop. cats should be tested for free.

Verify that it runs smooth after it heats up. MAF, once again should not be interminnent (or hot/cold effect)
mobinakhtar is offline  
Old 05-19-2006, 06:00 PM
  #6  
Out Of Control!!
Thread Starter
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
I know cats are bad, I have an OBD2 scanner and family owns a garage... They split at 49k miles and got welded up by the dealer. Only thought bad cats would effect emmisions not how it runs
55fanatic is offline  
Old 05-21-2006, 10:25 AM
  #7  
Out Of Control!!
Thread Starter
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
Originally Posted by 55fanatic
I know cats are bad, I have an OBD2 scanner and family owns a garage... They split at 49k miles and got welded up by the dealer. Only thought bad cats would effect emmisions not how it runs
Checked my codes... I had a whole lot of them, and the two active ones were fuel trim malfunction, others were cylinder misfires and more fuel trim malfunctions... I think Im going to replace the MAS, and then from there the fuel filter, just cause it needs it, then both the cats down the road...
55fanatic is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ML Bogs in the morning


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: