Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

ML430 wont start CPS or MAF?

 
Old 12-18-2009, 08:43 PM
  #1  
Member
Thread Starter
 
Join Date: Oct 2009
Location: Orange, CA
Posts: 80
Likes: 0
Received 0 Likes on 0 Posts
Mercedes ML430
ML430 wont start CPS or MAF?

will not start when engine is warm. would this be a mass air flow or crankshaft position sensor? thanks
Racerx18691 is offline  
Old 12-19-2009, 09:39 AM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
I would lean towards the CPS however having said that there are about 100 other things that can cause the engine to not start. I suggest running the OBD codes to see what shows up.
Mike
Mike's ML is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ML430 wont start CPS or MAF?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: