Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

location camshaft sensor

 
Old 02-21-2011, 12:08 PM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2011
Location: Staten Island, New York
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
ml55
location camshaft sensor

i have a 01' mll55 amg.....where is the camshaft sensor?
ny55 is offline  
Old 02-21-2011, 12:55 PM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
Originally Posted by ny55 View Post
i have a 01' mll55 amg.....where is the camshaft sensor?
The Camshaft sensor is #17.
The Crankshaft sensor is #5.
Mike
Attached Thumbnails location camshaft sensor-cam-ps.jpg  

Last edited by Mike's ML; 02-21-2011 at 12:57 PM.
Mike's ML is offline  
Old 02-21-2011, 01:07 PM
  #3  
Newbie
Thread Starter
 
Join Date: Feb 2011
Location: Staten Island, New York
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
ml55
Originally Posted by Mike's ML View Post
The Camshaft sensor is #17.
The Crankshaft sensor is #5.
Mike
Thanks!
I though that was it!
It look to good to be true so I figure I would asked..... before the part arrive.
Thanks again man!
ny55 is offline  
Old 02-21-2011, 02:24 PM
  #4  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
What was the problem you were having?
How did you know it was the Camshaft Position Sensor and not the Crankshaft Position Sensor?
The reason I ask is that there have been very few reported problems with the Cam Position Sensor but many problems with the Crank Position Sensor.
Mike
Mike's ML is offline  
Old 02-21-2011, 03:32 PM
  #5  
Newbie
Thread Starter
 
Join Date: Feb 2011
Location: Staten Island, New York
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
ml55
Originally Posted by Mike's ML View Post
What was the problem you were having?
How did you know it was the Camshaft Position Sensor and not the Crankshaft Position Sensor?
The reason I ask is that there have been very few reported problems with the Cam Position Sensor but many problems with the Crank Position Sensor.
Mike
I broke the serpentine belt the other day, the truck ran fine before...
The idler pulley also broke.
Replace the parts,It's cranks an that it!
"I don't know", but i did replaced the crankshaft sensor like 2yrs ago!
ny55 is offline  
Old 02-22-2011, 07:18 PM
  #6  
Newbie
Thread Starter
 
Join Date: Feb 2011
Location: Staten Island, New York
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
ml55
update

I just plug in a OBD scanner
it gave me 2 faults:
1-camshaft sensor
2-EGR valve
Okay where's the EGR valve location?
I hope it's only a gasket, that part is pretty pricely....
ny55 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: location camshaft sensor


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: