Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

ML300 CDI 4matic strange noise

 
Old 04-08-2011, 07:58 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2011
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
ML300 CDI
ML300 CDI 4matic strange noise

Hi all,

As this is my first post here would like just to say coming from Europe /Belgium.

Anyway I have problems with my ML300 4matic which is old 3month's + -

Problem 1:
Bad smell behind left wheel sometimes not always but smell like someone burning plastic or you drive under hand break (which I dont )

Dealer Answer:
This is normal ,thats some kind of filter they say which is letting go bad things from the car and smelling because that filter heat up up to 900 degree Celsius


Problem 2: This week I had strange noise coming from engine front left (I have read some posts here but I am not sure if this is same noise like guys discussed before so I am putting link here for you Benz masters to hear if this is normal.. Here is download link:
http://rapidshare.com/files/456457659/mlnoise.m4a

Problem is I went with dealer both times but by the time I get there that noise stop so today I have recorded on my mobile file is above also gave them to listen that what is going on and anser again the same "Thats Normal"

So if someone is out there and know what this could be I am ready to fight back without knowledge is hard to do anything when they say this is normal

Thanks in advance
Daniel
Daniel74 is offline  
Old 04-08-2011, 09:43 AM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
You are on the wrong forum. This is the W163 ML forum, 1998 - 2005.
You should re-post your question on the W164 ML forum, 2006 - present.
Mike
Mike's ML is offline  
Old 04-08-2011, 10:20 AM
  #3  
Newbie
Thread Starter
 
Join Date: Apr 2011
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
ML300 CDI
Thanks Mike I did that, will be on once moderator approve thats what I got message

Cheers
Daniel74 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ML300 CDI 4matic strange noise


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: