Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Brake wear sensor question

 
Old 11-18-2011, 11:54 AM
  #1  
Member
Thread Starter
 
Join Date: Jan 2011
Location: Glenmoore, Pa
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
2003 ML 500
Question Brake wear sensor question

Recently replaced front pads/wear sensors on '03 ML 500. Since then brake wear indicator light (yellow) comes on intermittently. Unsally on acceleration and when I come to a complete stop, not during deceleration. Also, have a lot of static listening to AM radio. Never had that problem before brake job. I've replaced both wear sensors, with same quailty, no improvement. Driver side sensor in outter pad, right side sensor in inner pad. That's the way they came off. I replaced the same. But aways thought sensors go on inner pad?? Next step is to get sensors from MB. Maybe the sensors I get from Autopart International are junk?? Anybody have any thoughts?

Thanks,
ML 500 mz is offline  
Old 11-18-2011, 04:44 PM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
Intermittent light could be coming from the rear sensors. Just a thought. They work by just shorting to ground when pads get low. Check for any part of sensor that could be touching anything metal. Also any moisture or other contamination in the sensor plugs could cause an electrical leak to ground. When new the sensors are completely covered with insulation which wears off when the pads get low.
Mike
Mike's ML is offline  
Old 11-22-2011, 07:25 PM
  #3  
Member
Thread Starter
 
Join Date: Jan 2011
Location: Glenmoore, Pa
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
2003 ML 500
Thanks for the reply. The rear brakes are ok. I need to get sensors from MB, see what happens. I'm getting used to light coming on, doesn't bother me anymore. I know the brakes and brake systems are fine. It's a wear sensor issue.
ML 500 mz is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Brake wear sensor question


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: