Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Yellow Triangle with !

 
Old 05-07-2013, 10:00 AM
  #1  
Newbie
Thread Starter
 
khporter90's Avatar
 
Join Date: May 2013
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
ML 320
Exclamation Yellow Triangle with !

Recently, the yellow triangle with an exclamation point light will flash while I'm driving and I lose power. I can't accelerate at all. This has happened on the highway and has put me in a dangerous spot. When the flashing stops, it works normally again. I have a 1999 ML 320 with well over 253,000 miles on it. Any ideas on what's going on before I put it in the shop? Thanks!
khporter90 is offline  
Old 05-07-2013, 04:19 PM
  #2  
Senior Member
 
Limited Edition 190E's Avatar
 
Join Date: Dec 2001
Location: Virginia
Posts: 328
Likes: 0
Received 0 Likes on 0 Posts
2005 CL65 AMG
Sounds like traction control or limp home mode. When it happens, try turning off the car and restarting.
Limited Edition 190E is offline  
Old 05-12-2013, 09:54 AM
  #3  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
If it recovers by itself, without having to turn ignition off, then it is most likely Not in limp home mode. Sounds more like one of the wheel speed sensors is failing.
Mike
Mike's ML is offline  
Old 05-13-2013, 12:20 AM
  #4  
Junior Member
 
Join Date: Mar 2013
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
2000 ml320
i have the same problem, like you have a blow-out and a stalling engine all at the same time. used to be able to drive through it. now i have to pull over and turn it off and restart and the BAS ESP light stays on till i let it set overnight and it goes back off. then i get to wonder when it's going to happen again, it's going to get me rearended.
cobracop is offline  
Old 05-17-2013, 10:24 PM
  #5  
Junior Member
 
Join Date: Mar 2004
Posts: 27
Likes: 0
Received 0 Likes on 0 Posts
'99 ML430, '84 380SL, '04 XC90, '12 X5
Triangle Flashing

I completely agree with Mike's ML above. I had exactly the issue you are describing on my 1999 ML430 with 190,000. Replaced front driver's side wheel speed sensor and problem is done .... 10,000 miles ago, no re-occurance. The problem generated lots of codes suggesting lateral sensor and other expensive sensors but once the wheel speed sensor was replaced, no other codes are being generated.

The sensor was new and pretty inexpensive on ebay. I don't recall it being a difficult job to do.
YuCrew is offline  
Old 05-20-2013, 03:01 PM
  #6  
Junior Member
 
Join Date: Mar 2013
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
2000 ml320
i've been turning the esp off and it doesn't do it, so i'm guessing wheel speed sensor over brake light switch. my brake lights seem to be working fine and i get no abs warn light.
cobracop is offline  
Old 05-20-2013, 07:41 PM
  #7  
Junior Member
 
Join Date: Mar 2004
Posts: 27
Likes: 0
Received 0 Likes on 0 Posts
'99 ML430, '84 380SL, '04 XC90, '12 X5
Wheel Speed Sensor

Now you need to figure out which wheel. If you can have the codes pulled, I would ignore all the C codes that deal with steering (C1140) and Yaw/lateral accel or Rotary (C1120), brake switch (C1200), ESP module (C1000), C1140 or C1142 for lateral, etc.

Concentrate for example on a C1100 which will be left (US Driver's side) front, C1101 will be front right. I paid $35 for new genuine MB part on ebay, July 2012 from seller nomocarparts. It was an easy install.

If you're lucky, you might also have a P1605 code thrown ... I believe it confirmed speed sensor in my case.

Share your success with us if you're successful. Good luck.
YuCrew is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Yellow Triangle with !


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: