Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
2004 ml350 defroster doesn't work. Please help! >

2004 ml350 defroster doesn't work. Please help!

Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

2004 ml350 defroster doesn't work. Please help!

 
Old 09-21-2017, 09:42 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2017
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2004 ml350
2004 ml350 defroster doesn't work. Please help!

I've replaced the blend door actuator already but still nothing. The defroster would sometimes work for a few minutes then cut out. Any kind of advice or guidance would be much appreciated!
Matt0901 is offline  
Old 09-21-2017, 11:09 AM
  #2  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,324
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
Is that the reason why you replaced the Blend Door?
Maj. Dundee is offline  
Old 09-21-2017, 11:13 AM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2017
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2004 ml350
That was the only thing that I could find while researching it online. I should have asked on here first...

Last edited by Matt0901; 09-21-2017 at 12:17 PM.
Matt0901 is offline  
Old 09-21-2017, 01:58 PM
  #4  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,324
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
Remove the cover under the left side Instrument Panel.

Look up to the right and locate the Trans. Control Module and pull it out of the bracket. Then remove the bracket and you will see the Def. Actuator.

Request defrost and watch to see if the actuator moves. If not, it must be replaced.
Attached Thumbnails 2004 ml350 defroster doesn't work. Please help!-actuator-motors-2002-leg-rear.jpg  
Maj. Dundee is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 2004 ml350 defroster doesn't work. Please help!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: