Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

2002 ML320 First Start Problems

 
Old 10-25-2017, 08:06 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: San Diego, CA
Posts: 2
Received 0 Likes on 0 Posts
ML320
2002 ML320 First Start Problems

When I try starting the vehicle, first start of the day it rough. It turns over but you need to gun the gas pedal to get it running, if not it stops. After about 3 minutes I can easy off the gas petal then it's ok to run. For some reasons its only the first start, once it's been running is ok. I've already replaced the fuel filter and mass air flow sensor. Any suggestions?
MCJR is offline  
Old 10-25-2017, 11:22 PM
  #2  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,327
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
This is an indication that the fuel filter is partially clogged and or the fuel pump is weak.
Maj. Dundee is offline  
The following users liked this post:
MCJR (10-26-2017)
Old 10-25-2017, 11:22 PM
  #3  
Newbie
 
Join Date: Feb 2016
Posts: 13
Received 0 Likes on 0 Posts
2001 ML 320 2001
Might have some carbon buildup in the system. Id run a fuel system cleaner through the system and see if that will help.I only mention that because you said it runs better after It warms up.
jayty3617 is offline  
Old 10-26-2017, 01:34 PM
  #4  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: San Diego, CA
Posts: 2
Received 0 Likes on 0 Posts
ML320
2002 ML320 First Start Problems

Originally Posted by jayty3617 View Post
Might have some carbon buildup in the system. Id run a fuel system cleaner through the system and see if that will help.I only mention that because you said it runs better after It warms up.
I have given it two treatments of fuel cleaner but the vehicle does have over a 180,000 miles, I'll try more treatments.
Thank you...
MCJR is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 2002 ML320 First Start Problems


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: