Notices
M113 V8 Kompressor Platform Technical discussion relating to models sharing the M113 V8 5.5L Kompressor. Including SL55 AMG, CL55 AMG, S55 AMG, E55 AMG, CLS55 AMG, G55 AMG, SLR (M155).
Sponsored by:
Sponsored by:

no heat

 
Old 09-25-2013, 04:49 PM
  #1  
Newbie
Thread Starter
 
gregwhill's Avatar
 
Join Date: Aug 2013
Location: Toronto canada
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
05 e55
no heat

good afternoon .... the other morning was cool went to use the heat in my car an just blows cold air ... been try for days now an still just cold air when I first turn it on I get warm air for seconds an then just goes to cold any help would b great thx ...
gregwhill is offline  
Old 11-24-2013, 09:55 AM
  #2  
Super Member
 
211.070's Avatar
 
Join Date: Jun 2012
Location: Atlanta, GA
Posts: 703
Thanked 4 Times in 4 Posts
2005- E55 & E500
This is usually the heater core shut off valve. They area common failure on the 211 chassis.
211.070 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: no heat


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: