Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W116)
1973 280se w116 lost all electrics >

1973 280se w116 lost all electrics

Notices
S-Class (W116) 1972-1980: 280S, 280SE, 280SEL, 350SE, 350 SEL, 450 SE, 450 SEL, 450 SEL 6.9, 300 SD

1973 280se w116 lost all electrics

 
Old 08-02-2017, 04:31 AM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2017
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
280ce 280se
1973 280se w116 lost all electrics

The engine was accidentally started while the 27mm socket wrench was still attached to the front of the engine after points gap (manual crank) the starter just coughed and then I lost all electrics. The 73 w116 280se-m110 does not have an ovp voltage protection but I don't where to start to find what is blown?
no clock,radio.. nothing.. any ideas many thnaks
BEYTAN is offline  
Old 08-16-2017, 11:55 AM
  #2  
Newbie
 
Join Date: Nov 2014
Location: Vancouver, BC, Canada
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
1977 450 SEL 6.9
Check out the 5 pin relay in the fuse box inside the engine compartment. There should be 2 big ones in there, one is related to the fuel pump, and one is for the starter. Swap out the one for the starter, might get lucky.
dikdaan is offline  
Old 08-23-2017, 11:45 AM
  #3  
Newbie
Thread Starter
 
Join Date: Aug 2017
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
280ce 280se
Thank you for your suggestion, I will take a look at both and let you know how I get on. cheers

ACTUALLY FIXED.. just reconnected the starter after and everything came back to life! very strange and didn't do anything other than
disconnect and reconnect starter!

So I think it must have been something to do with the solenoid clutch jamming out of position and the internal switch (noted from a wiring diagram)
didn't allow the continuity of the circuit.

I will upload the wiring diagram which is quite different to the post 1975 280se.

Last edited by BEYTAN; 08-24-2017 at 03:00 PM.
BEYTAN is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 1973 280se w116 lost all electrics


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: