Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W220)
S430 airmatic problem please help :((( >

S430 airmatic problem please help :(((

Notices
S-Class (W220) 1999-2006: S 320 CDI, S 320, S430, S 500, S 600

S430 airmatic problem please help :(((

 
Old 10-17-2012, 06:09 AM
  #51  
Newbie
 
Join Date: Oct 2012
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2000 Mercedes s430
Originally Posted by Benziechicago View Post
I can hear the pump working trying to.raise the vehicle. !??
I had the same problem one day i came out to my garage and thee passenger side just dropped after i started the car...I lifted the car with a jack evenly with the driver side to take a look.After i let the car down it was leveled fine and i havent had the problem since.
Slimpr is offline  
Old 10-17-2012, 09:05 AM
  #52  
Junior Member
 
Join Date: Oct 2008
Location: Minneapolis, St. Paul, MN
Posts: 54
Likes: 0
Received 0 Likes on 0 Posts
2008 E350 4Matic
Airmatic too low

Hi Guys,

After read all posted about airmatic problem, now my car had warn me about "Airmatic error on your dash with car logo and a arrow pointing up or car is too low error in RED" than gone away very quickly in last couple weeks and continue almost everyday. I can hear the pump running when I start the car, front wheels seem just a bit low but car drive ok. My concern is warning in red about airmatic come and goes. What is it pointing me to now, problem with pump or both structs (shocks). Thanks all guys for inputs in an advance.

Last edited by klvaleri; 10-17-2012 at 09:54 AM.
klvaleri is offline  
Old 10-18-2012, 06:28 AM
  #53  
Newbie
 
Join Date: Oct 2012
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2000 Mercedes s430
The front always sits just a little lower than the Back due to the weight in the front.As for the red light for the suspension could be one of numerous problems.First thing would be to inspect the air suspension system for leaks in lines or clogged lines.i would have your computer checked before changing any parts that dont need to be changed.I have the same problem it happens when i start the car an just go...i spoke with my mechanic he said to wait for the car to finich lifting before driving off..otherwise the erroe will appear.you can hear when the car has stopped lifting.
Slimpr is offline  
Old 01-05-2013, 12:09 AM
  #54  
Newbie
 
Join Date: Jan 2013
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2-430 2003
temperature issue

I have a W220 and obviously, when the temparature goes bellow -15 degrees she does not lift from the rear. My tought are either, compressor cannot handle low air pressure or I have a leak and/or humidity stocked in the air line.
Anyone figured the same bug?
Pasco is offline  
Old 01-05-2013, 01:19 AM
  #55  
Newbie
 
Join Date: Jan 2013
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2-430 2003
w220 doesn't lift from rear

hi everyone,
i am new here but felt like I should ask, does a very low temperature makes the air suspension gowing kind off dead?
Pasco is offline  
Old 10-20-2014, 01:27 PM
  #56  
Newbie
 
Join Date: Oct 2014
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2006 S 430
Front Airmatic Problems

I have been warned from other Benz owners about the cost of the Airmatic repairs for when ( not if ) it happens being anywhere from $1200 for one to well over $3000 at the dealerships. Two weeks ago I finally had the dreaded car bottomed out on the front tire issue. I ended up on line at BUYAUTOPARTS and ordered both fronts shocks figuring if one went out the other was right behind. I ordered them on Saturday night and late Sunday afternoon I received a call from them checking on my order. They wanted to verify I wanted 2 sets..Seems I entered two orders by mistake which I will blame on too many SAM ADAMS ! Pretty cool to get a call late on a Sunday to verify what I was trying to do. I went with the Arnott Remanufactured and received them in 3 days tightly packaged up. Of course I had to check them out for my just over $700 purchase ( FOR BOTH ). Damn, they looked brand new to me. I am usually a DO IT MY SELF guy but due to my regular job and not really able to drive the car I took it to a mechanic I know that charged me $230 to install both front shocks as well as having the alignment done. There is also a $200 core per shock, but in the shipping box is a return label to ship them back. So for under $1000 I now hope I can go another 110K miles. I hope this will help someone else out there with there issue and wanting to save some money.
Mr. Moto is offline  
Old 10-20-2014, 01:49 PM
  #57  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
That's a good price

You might need to do the rears in the future
tusabes is offline  
Old 10-20-2014, 03:55 PM
  #58  
Newbie
 
Join Date: Oct 2014
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2006 S 430
Oh I am sure I will.. But at least I know it's not as much $$ as first thought. When I was going to buy my first Benz 2001 E 320 I was hesitant because of all the rumors associated with repair cost. I got to know a service writer at the local dealership who told me that most people that buy these cars don't work on them so they will pay to get them fixed. I bought that car used with 34 K miles and sold it with 189 K miles and besides brakes and batteries probably had less then $2000 in other misc repairs. Sold it and bought the S 430..Keeping my fingers crossed.
Mr. Moto is offline  
Old 10-24-2014, 05:33 PM
  #59  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500


this is the hose that cracked on the compressor I would advise every one to check this hose as often as possible I have had to replace it twice in the past 18 months




this is the car right now so sad its still trying to rise up



I have a similar problem with my 2001 s 430
I just did air shocks on my 06 ml 500 last week now my s class dropped ! great


Any ways my main issue is that the hoses on the compressor were cracked
I replaced the hose and the car went up again but that was last night this morning it is almost touching the ground I can hear the hissing coming out of the passenger air shock but I want to see the leak where exactly would it leak from on this model ? its not leaking from the top


I have finally located what I believe is the airmatic filter witch is attached to a much larger hose but it runs in the body of the car any one know if theres any thing else I should inspect for leaks before I order the parts ?

Last edited by S430LUCKDRAGON; 10-24-2014 at 08:27 PM.
S430LUCKDRAGON is offline  
Old 10-24-2014, 07:06 PM
  #60  
Newbie
 
Join Date: Oct 2014
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2006 S 430
When my passenger side dropped I got the red warning light on the dash too. Luckily I could use the Air Ride button on the dash and it would raise the are up pretty far and at least enough to drive. Once parked and the engine off it would bottom out in 5 minutes. That's why I figured it must be the shocks, because the compressor would put enough air in to lift the car. When the shock was removed the only thing I could see was the rubber boot was totally disconnected from the shock.
Mr. Moto is offline  
Old 10-24-2014, 08:26 PM
  #61  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
Im wondering if its possible for the air hose on the other end of the filter could be broken ?
Or if the filter itself might be cracked I can hear the air hissing out on the passenger side
Going to look one more time before I order the new shocks
S430LUCKDRAGON is offline  
Old 10-24-2014, 09:24 PM
  #62  
Member
 
Join Date: Oct 2014
Posts: 127
Likes: 0
Received 0 Likes on 0 Posts
S500L 03, Avalanche 03 and Porsche Cayenne S 04
Mine is down to the ground front and rear. I tried connecting the compressor directly to a battery and it works. I tried lifting the car by pressing the dash button but that doesn't work. None of these buttons work by the way. I also changed relays mine were Tyco for Hella made in China. Compressor does not come on. Car is on jack stands now. I have read about Arnold's but i would like to see if there is a cheaper option to fix this. I saw there are cracks in front shocks. I don't know what to do first now.
rik881 is offline  
Old 10-25-2014, 10:51 AM
  #63  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,419
Received 90 Likes on 85 Posts
2003 S430
The filter has nothing to do with the leak. If the hiss is coming from the strut, the strut has failed (or the line attaching to it, but that is pretty rare). Arnott replacement seems to be the best approach to repair.


rik881 - The Airmatic system on my car doesn't operate until the engine is running...
wallyp is offline  
Old 11-01-2014, 01:02 PM
  #64  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
ohh man tuff day so far I replaced both of the front air struts ad the car still wont raise up
the hissing noise from the front went away now there is hissing coming from under the car near the rear drivers side tire I can see what looks like it could be air lines under there on top of that its been raining all morning are there any air bags in the car or does this just narrow it down to the lines ?
S430LUCKDRAGON is offline  
Old 11-02-2014, 03:29 AM
  #65  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
The air bags are in the struts
tusabes is offline  
Old 11-02-2014, 08:07 AM
  #66  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,419
Received 90 Likes on 85 Posts
2003 S430
The air lines for the rear struts enter thru the top, not under the car. If there is a hiss from under the car, it probably indicates that a strut has failed.


If you look on the rear shelf behind the outer headrests, you will see a triangular snap-on cover that appears to be part of the rear shelf. Pop that cover off, and you will find the air line and connector on the top of the rear strut. The fasteners holding the top of the rear strut are also under the cover.


The more you know about the car, the easier and cheaper it is to keep in repair. The thread at the top of the page labeled "start here" has a huge amount of useful info.
wallyp is offline  
Old 11-03-2014, 01:54 AM
  #67  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
The hissing is coming from the lines on the bottom of the car !
I just put in brand new front struts now the back is way up front still low
Then it drops completly again
Front had gone up a little bit now its slammed down again
S430LUCKDRAGON is offline  
Old 11-03-2014, 10:40 AM
  #68  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,419
Received 90 Likes on 85 Posts
2003 S430
AFAIK, there are no external Airmatic lines under the car on the rear of the vehicle. If the hiss is coming from under the car at the rear, it would seem to be a failed strut.


If the hiss is at the front, there are several Airmatic lines there...


If you have a continuous hiss, get a four-foot piece of rubber or plastic tubing, stick one end in your best ear and use the other end as a locating device to find the leak.
wallyp is offline  
Old 11-03-2014, 12:38 PM
  #69  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
Thanks wally
I had to bring it to the dealer for diagnosis
they said replace the compressor so ordered it should be here tomorrow
S430LUCKDRAGON is offline  
Old 11-04-2014, 08:34 PM
  #70  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
I put the new compressor in today every thing is all good the car is up in the air now but has some squeeking noises from the struts
S430LUCKDRAGON is offline  
Old 11-05-2014, 09:53 PM
  #71  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,419
Received 90 Likes on 85 Posts
2003 S430
This is worth a try...


You will need:
- Grease gun. I suggest a standard size "pistol grip" gun.
- Flex hose to replace the steel tube on the gun.
- Grease needle. Snaps into the nozzle of the grease gun.
- Tube of soft Moly grease.


Install the flex hose on the gun, put the grease tube in the gun, snap the needle in the nozzle.
Carefully insert the needle into each of the rubber boots on the front suspension and pump grease in until the boot begins to firm up.
Drive the car for a few days and see if the squeaks stop.
wallyp is offline  
Old 11-11-2014, 05:24 AM
  #72  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
Thanks wally p seems like it is worth a try but the thing is i replaced all the controll arms last year so the rubber boots there are pretty new and the bushings but i am wodering if the new strut itself has lost some internal lubrication is this possible ?
S430LUCKDRAGON is offline  
Old 11-16-2014, 11:35 AM
  #73  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
All of the ball joints and bushings are fine going to have to call the company tomorrow I got a crazy price on e bay for a reman pair only 550$ after core return Sun Core
S430LUCKDRAGON is offline  
Old 11-16-2014, 06:47 PM
  #74  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
Should have used arnott

It's worth the extra $$$ over suncore
tusabes is offline  
Old 11-17-2014, 08:45 AM
  #75  
Member
 
S430LUCKDRAGON's Avatar
 
Join Date: Aug 2013
Location: Providence RI
Posts: 190
Likes: 0
Received 0 Likes on 0 Posts
2003 S 500 4 MATIC , 2001 S 430 , 2003 ML 500
I was thinking the same thing but lets see if sun core will send me another one I don't mind putting it in again more practice
S430LUCKDRAGON is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: S430 airmatic problem please help :(((


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: