Notices
SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

04 SL500 Alarm Issue

 
Old 08-23-2009, 09:32 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jul 2009
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
04 sl500, 02 e320, 02 landcruiser
04 SL500 Alarm Issue

whatsup everyone im new to this forum...i just got a certified sl500 a few weeks ago and was wondering if anyone knew about an alarm issue ive run into today. after i lock the car like 30 seconds later the alarm will start ringing for no reason. i got this to happen five times in a row so im pretty sure its not just a fluke. if anyone knows why this is happening please let me know. just trying to see if i can figure it out before going to the dealer. thanks
iamlinjo is offline  
Old 08-23-2009, 10:13 PM
  #2  
Member
 
garybc230's Avatar
 
Join Date: Jun 2009
Location: Upper Marlboro, MD
Posts: 164
Likes: 0
Received 1 Like on 1 Post
2006 SL500/2006 Porsche Cayenne S Titanium
Welcome to the forum. This is a great way to make new friends and find answers to your questions. Unfortunately, I haven't had that issue with the alarm. Hopefully one of the other members will have had a similar situation and give you and answer. You might also try the search function as well, just in case it's been convered before. Once again, welcome and enjoy your new baby!
garybc230 is offline  
Old 08-23-2009, 10:32 PM
  #3  
Newbie
 
rizzy's Avatar
 
Join Date: Aug 2009
Location: Earth
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
none
I don't remember if the SL's door contact switch is built into the latch or not. Look under the door striker on the body and see if the is a door contact switch there. If there is, make sure that both the left and the right are there and not broken. Sometimes they break and fall into the door jam, which would set the alarm off. If not, it could be a problem with the latch in the doors or the trunk as well as a faulty alarm siren horn.
rizzy is offline  
Old 08-24-2009, 12:56 AM
  #4  
Super Member
 
VendettaMB's Avatar
 
Join Date: May 2009
Location: In a VAN down by the river
Posts: 644
Likes: 0
Received 0 Likes on 0 Posts
His wifes head hard into the headboard nightly!!
Originally Posted by iamlinjo View Post
whatsup everyone im new to this forum...i just got a certified sl500 a few weeks ago and was wondering if anyone knew about an alarm issue ive run into today. after i lock the car like 30 seconds later the alarm will start ringing for no reason. i got this to happen five times in a row so im pretty sure its not just a fluke. if anyone knows why this is happening please let me know. just trying to see if i can figure it out before going to the dealer. thanks
I HAVE THE SAME ISSUE!!! it SUCKS! mb dealer cnt find the issue. PULL 3rd fuse(7.5amp) under the hood on rivers side, so yr alarm wont SOUND everytime u park. if not you will have to stand there and count like i do and wait...its a joke. you cant silnece it/disable it..stupid system. everytime you lock yr door, its embarassing. g/l let me know if u get it resolved.

also u will drain yr consumer batt..not allowing you to open roof etc for about 15min of driving in yr new car till its charged back up. Even if ou pull fuse it still thinks alarm is going off and it drains. I live in condo..for all i know it may be ok, when i park, but go off 1 hr later..resulting in my drained batt after 30=48hrs.
VendettaMB is offline  
Old 08-24-2009, 01:41 AM
  #5  
MBWorld Fanatic!
 
m4xm1l10n's Avatar
 
Join Date: Oct 2008
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
BMW F02 (750Li) F10 (550i)
Maybe your front SAM , since It's certified what you care , bring it in enjoy you loaner and let the others know what it was after you pick her up .
m4xm1l10n is offline  
Old 08-24-2009, 01:46 AM
  #6  
Super Member
 
VendettaMB's Avatar
 
Join Date: May 2009
Location: In a VAN down by the river
Posts: 644
Likes: 0
Received 0 Likes on 0 Posts
His wifes head hard into the headboard nightly!!
Originally Posted by m4xm1l10n View Post
Maybe your front SAM , since It's certified what you care , bring it in enjoy you loaner and let the others know what it was after you pick her up .
They checked my SAM and they said it was fine
tried to telle I have aftermarket stuff. So I ripped out my sub to help trouble shoot. My radar is not the issue as it van be turned off. Even then won't set off alarm. And sure as hell won't drain a New mB batt overnight. So annoying.
VendettaMB is offline  
Old 08-24-2009, 01:49 AM
  #7  
MBWorld Fanatic!
 
m4xm1l10n's Avatar
 
Join Date: Oct 2008
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
BMW F02 (750Li) F10 (550i)
Originally Posted by VendettaMB View Post
They checked my SAM and they said it was fine
tried to telle I have aftermarket stuff. So I ripped out my sub to help trouble shoot. My radar is not the issue as it van be turned off. Even then won't set off alarm. And sure as hell won't drain a New mB batt overnight. So annoying.
Well use this thread as a solution to your problem , I'm sure Iamlinjo will updated you on that

Last edited by m4xm1l10n; 08-24-2009 at 08:18 PM.
m4xm1l10n is offline  
Old 08-24-2009, 02:06 AM
  #8  
Super Member
 
VendettaMB's Avatar
 
Join Date: May 2009
Location: In a VAN down by the river
Posts: 644
Likes: 0
Received 0 Likes on 0 Posts
His wifes head hard into the headboard nightly!!
Originally Posted by m4xm1l10n View Post
Maybe your front SAM , since It's certified what you care , bring it in enjoy you loaner and let the others know what it was after you pick her up .
Ya foresure. I talked with my warranty company and I'm going to take it back to dealer as Long as they don't charge like crazy trying to solve as opposses to fix. Keep ya updated
VendettaMB is offline  
Old 08-28-2018, 06:02 PM
  #9  
Junior Member
 
Join Date: Apr 2017
Posts: 21
Likes: 0
Received 1 Like on 1 Post
2003 Mercedes sl500 & 2012 C300 4matic
Check the alarm siren behind the left front wheel. It has if I remember 4 small batteries inside it. They go bad, break open and leak all over the circuit board, destroying it. Then your alarm can go off for no reason, and it will get worse. You can pull the fuse for it and it will stop the siren from going off in the middle of the night, but it will also not go off if someone tries to steal your car. Not a big deal to replace it, like 3 bolts to get out after you take out the inner fender liner. About $150 for a new one, less for used ones.
2007mustang is offline  
Old 05-16-2019, 04:44 AM
  #10  
Newbie
 
Join Date: May 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Sl500
Alternative method to locking car without priming alarm

Just bought a 2004 sl500 with only 48,000 miles on the clock. Lovely car but not surprisingly already having to iron out problems with such an old car. My alarm keeps going off. Usually it will go off a day after I have last driven the car, so im slightly suspicious the consumer battery voltage is dropping below a voltage threshold for the alarm maybe...i don't really know i just guessing. If i press the lock button on the key fob it will stop the alarm but only for about 10 minutes when it goes off again. If i go to the car and turn the key on and off in the ignition and lock the car again it will behave itself until i drive and park it again...weird. Having it looked at the end of the month by a mercedes specialist. I think i found a way to lock the car without priming the alarm for now. With the driver door open press the central locking button on the dash to lock the passenger door and boot lid. Shut driver door and lock with emergency key element. Im just assuming this method purely just locks the doors so hope this helps as a temporary solution for other sl owners.
Jamsyxl is offline  
Old 05-16-2019, 01:05 PM
  #11  
Junior Member
 
Join Date: Apr 2017
Posts: 21
Likes: 0
Received 1 Like on 1 Post
2003 Mercedes sl500 & 2012 C300 4matic
Have your mechanic check the alarm behind the front, drivers side wheel. It gets wet and corroded with time and then shorts out. The alarm going off will only increase with frequency. It's not that expensive a part. In the meantime you can pull the alarm fuse so that it isn't going off all the time.
2007mustang is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 04 SL500 Alarm Issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: