Notices
SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

What will this be?

 
Old 05-12-2019, 10:04 PM
  #1  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
What will this be?

As I was driving, I believe I stopped at a traffic light and all of a sudden, all of the lights in the dash came on and the gauges dropped to zero and then back to normal as if nothing happened. This also happened three months ago when I got the car, but I based it on the car being parked for almost a year and half, almost abandoned by my boss😀. I bought it for so cheap that the state is requesting more proof of purchase, which Iím putting together. Iím currently looking for a reputable Indy mechanic around Central NJ if anyone knows of one.
kemzo is offline  
Old 05-12-2019, 10:16 PM
  #2  
Junior Member
 
sean65's Avatar
 
Join Date: Sep 2013
Location: Walpole, MA USA
Posts: 15
Received 0 Likes on 0 Posts
2004 SL500, 2005 SLK350 6-speed
My first thought would be the consumer battery in the trunk. Have it tested.
sean65 is offline  
Old 05-12-2019, 11:02 PM
  #3  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 10,029
Received 753 Likes on 703 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
A bad EIS (ignition switch) can also cause strange "burps" and "reboots". Mine does this about once every other week. If I'm at idle, the engine will often shut off. If driving, it just acts like there was a power failure. Sometimes it only does something like give me a brief SRS warning, or a "replace key" message.
Rudeney is offline  
Old 05-12-2019, 11:42 PM
  #4  
Senior Member
 
Join Date: May 2015
Location: North Cali
Posts: 341
Received 22 Likes on 21 Posts
2005 SL500
Kemzo,

See below a thread of what happened to me. What was my case is what Rudeney pointed at. The problem was fixed with a trip to the dealer and a total of $921 for EIS and labor. If i remember correctly i had a video linked there of what was happening to my dashboard. Hopefully that will solve your problem.
Dealer was pointing to a defective dashboard, which costs at least 2k (new).... Check the thread and see if you can get someone to read the codes while your car will act up.

https://mbworld.org/forums/sl-class-...t-nowhere.html


P.S.

Question: did the engine stop when it happened or continued running?
Ghostty is offline  
Old 05-13-2019, 07:44 AM
  #5  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by sean65 View Post
My first thought would be the consumer battery in the trunk. Have it tested.
I replaced both batteries about three months ago when I got the car, so they are both brand new.
kemzo is offline  
Old 05-13-2019, 07:50 AM
  #6  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Rudeney View Post
A bad EIS (ignition switch) can also cause strange "burps" and "reboots". Mine does this about once every other week. If I'm at idle, the engine will often shut off. If driving, it just acts like there was a power failure. Sometimes it only does something like give me a brief SRS warning, or a "replace key" message.
It usually happens when Iím driving slow or at a full stop. Maybe there is a connection with my push button start not working.
kemzo is offline  
Old 05-13-2019, 08:03 AM
  #7  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Ghostty View Post
Kemzo,

See below a thread of what happened to me. What was my case is what Rudeney pointed at. The problem was fixed with a trip to the dealer and a total of $921 for EIS and labor. If i remember correctly i had a video linked there of what was happening to my dashboard. Hopefully that will solve your problem.
Dealer was pointing to a defective dashboard, which costs at least 2k (new).... Check the thread and see if you can get someone to read the codes while your car will act up.

https://mbworld.org/forums/sl-class-...t-nowhere.html


P.S.

Question: did the engine stop when it happened or continued running?
Thanks for the info... Iíll read that tread, by the way, the engine did not stop, no slow down, it just happened for a second and then back to normal again. Thereís no CEL, my KeylessGO isnít working, including push button start, currently not working. It happens randomly, like once a month or twice a week or none at all.
kemzo is offline  
Old 05-13-2019, 09:39 AM
  #8  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Rudeney View Post
A bad EIS (ignition switch) can also cause strange "burps" and "reboots"..
I just contacted someone from NYC that sells and program ignition switches, he said if itís the Ignition switch, the key fob will not start the car.

Last edited by kemzo; 05-13-2019 at 09:44 AM.
kemzo is offline  
Old 05-13-2019, 07:01 PM
  #9  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Video:
kemzo is offline  
Old 05-13-2019, 10:39 PM
  #10  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 10,029
Received 753 Likes on 703 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
That's almost exactly what mine does, but no batter warning or washer fluid warning. Like I said, it's usually a "Replace Key" message. Sometimes I get a brief SRS fault. The EIS is the "hub" for the vehicles various CAN buses and when it resets, they lose communication, thus the strange errors.
Rudeney is offline  
Old 05-13-2019, 11:35 PM
  #11  
Senior Member
 
Join Date: May 2015
Location: North Cali
Posts: 341
Received 22 Likes on 21 Posts
2005 SL500
Originally Posted by kemzo View Post

Yup, i had similar symptoms. I can add to that radio non operational, no headlights, no windshield washers, no power to 12v outlet. All would disappear for a minute or so, but with time it would happen more and more often. When i was driving to the dealer it came on and did not go away. From what Rudeney previously explained the EIS is programmed with DAS / STAR system. The Indy has to be very knowledgeable of the system to work on it. Plus you will need to reprogram the keys, thus you'll need the blue (or green) key from the dealer.
Ghostty is offline  
Old 05-14-2019, 05:34 AM
  #12  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Ghostty View Post
Yup, i had similar symptoms. thus you'll need the blue (or green) key from the dealer.
Then Dealer it is...
kemzo is offline  
Old 05-14-2019, 09:09 AM
  #13  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
The plot is getting thicker!

I decided to drive the car to work this morning and also decided this time to use my spare key fob, BOOM!💥 KeylessGO is working again, after a month of non functioning, push button start is working again. I drove for 45 miles without it exhibiting those issues.
kemzo is offline  
Old 05-15-2019, 12:17 AM
  #14  
Senior Member
 
Join Date: May 2015
Location: North Cali
Posts: 341
Received 22 Likes on 21 Posts
2005 SL500
Since the symptoms are not showing up constantly, I'd wait until it will get to happen more often. When it just started on my car - it didn't disturb me at all. You will figure out when it's time to pay a visit to the dealer, because, unfortunately, once it started acting up - it will go down from there 😌

P.S.
In case nobody mentioned, there is a MB club of America that I joined. It gives you 10% discount on parts and 15% discount on labor with the dealer. Another gentleman told me about it while I was waiting for my car for service 😁 I think the membership is about $50 a year or so. Considering i paid for the EIS and labor $921, the discount would already exceed at least 1-2 years of membership for sure
Ghostty is offline  
Old 05-15-2019, 01:37 AM
  #15  
Member
 
Join Date: Nov 2016
Location: Kirkland, WA
Posts: 171
Received 14 Likes on 13 Posts
2003 SL500
Originally Posted by kemzo View Post
I decided to drive the car to work this morning and also decided this time to use my spare key fob, BOOM!💥 KeylessGO is working again, after a month of non functioning, push button start is working again. I drove for 45 miles without it exhibiting those issues.
Just after I bought my SL, I was having similar problem from time to time, usually, when car was idling (like when I would pick up mail from he mail box). I can not say for sure if it was happening only with one key or with both, but after a while it stopped. Hope you'll see the same outcome.
alk247 is offline  
Old 05-15-2019, 01:38 AM
  #16  
Junior Member
 
Join Date: Jul 2018
Posts: 18
Received 1 Like on 1 Post
sl600
Yeah before my first key went out, my car will turn off, on its own 2 days before it wouldn't crank the car up anymore.

Replaced the key that gone out, but i do have a srs light always on and not too sure if those are related though.

My dealer recommends me changing out the ignition switch (600$), but for now i keep it.
Sl600kd is offline  
Old 05-15-2019, 05:45 AM
  #17  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Ghostty View Post
P.S.
In case nobody mentioned, there is a MB club of America that I joined. It gives you 10% discount on parts and 15% discount on labor with the dealer. Another gentleman told me about it while I was waiting for my car for service 😁 I think the membership is about $50 a year or so. Considering i paid for the EIS and labor $921, the discount would already exceed at least 1-2 years of membership for sure
Thanks for the info... Do you know the name of the club? Iíll definitely join it and get some discount. I still donít know the cost yet, I called but they wonít tell me, and they are telling me that itíll cost $246 just for diagnosing the issue.
kemzo is offline  
Old 05-15-2019, 06:21 AM
  #18  
Senior Member
 
Join Date: Mar 2018
Location: Netherlands
Posts: 302
Received 38 Likes on 35 Posts
1966 W113 230SL 2005 R 230 SL350 (M112 3.7). Selling the W113.
A German dealer made three wrong diagnoses and charged my seller (he guaranteed) for expensive parts that cured nothing. I took over and ordered a new EIS, told them to forget their diagnosing (that took some pursuasion). Problem solved.
if Iím correct a new EIS is coded to your VIN and it can not be re-coded after a certain number of starts. Hence sourcing a used EIS would be no option. Looks like youíre going to have to bite the bullet, like I had to.
Frederick NL is offline  
Old 05-15-2019, 09:23 AM
  #19  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Frederick NL View Post
A German dealer made three wrong diagnoses and charged my seller (he guaranteed) for expensive parts that cured nothing. I took over and ordered a new EIS, told them to forget their diagnosing (that took some pursuasion). Problem solved.
if Iím correct a new EIS is coded to your VIN and it can not be re-coded after a certain number of starts. Hence sourcing a used EIS would be no option. Looks like youíre going to have to bite the bullet, like I had to.
At this point , Iíve accepted that I have to pay up , but Iíll wait till it gets worse. Does anyone know whatís the going rate, so that Iíll be prepared?
kemzo is offline  
Old 05-15-2019, 10:15 AM
  #20  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Ghostty View Post
MB club of America
is it this one?

kemzo is offline  
Old 05-15-2019, 11:22 AM
  #21  
Senior Member
 
Join Date: Mar 2018
Location: Netherlands
Posts: 302
Received 38 Likes on 35 Posts
1966 W113 230SL 2005 R 230 SL350 (M112 3.7). Selling the W113.
Originally Posted by kemzo View Post
At this point , Iíve accepted that I have to pay up , but Iíll wait till it gets worse. Does anyone know whatís the going rate, so that Iíll be prepared?
With me the faults were consistent. Since I had no wipers and the seatbelts would tension up, among others, I couldnít live with it. From my experience I guess your symptoms may remain as they are, but others reported things culminated into real trouble.
Frederick NL is offline  
Old 05-15-2019, 12:34 PM
  #22  
Member
Thread Starter
 
Join Date: Feb 2019
Location: New Jersey
Posts: 107
Likes: 0
Received 1 Like on 1 Post
2008 SL550
Originally Posted by Frederick NL View Post
real trouble.
😳 hopefully not...
kemzo is offline  
Old 05-15-2019, 10:45 PM
  #23  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 10,029
Received 753 Likes on 703 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
The EIS must be coded to the car, and once done, it can't (easily) be transferred to another car. The good news is that it does not require SCN coding, so the job can be done with a Chinese clone SDS. If you buy a bran new EIS from MBZ, you can also buy that special green (or orange?) key that will download your car's key codes to it. But even that may not be necessary. As long as the current EIS can be read, coding can be transferred without the "green" key. The purpose of the "green" key is when the EIS is totally dead and cannot be read by SDS. In this case, the EIS is just flaky, so it may be able to read it and transfer to a new one. ANd of course there is always a way to get around buying a new EIS. To install a used EIS, you'd just need to have the odometer value stored in it zeroed and then SDS will re-code it. There are various ways to do that, the best being to send it to an electronics specialist who know what they are doing.
Rudeney is offline  
Old 05-16-2019, 12:23 AM
  #24  
Senior Member
 
Join Date: May 2015
Location: North Cali
Posts: 341
Received 22 Likes on 21 Posts
2005 SL500
Originally Posted by kemzo View Post
is it this one?
Yes, that's the one. They will send you in the mail a membership card and a nice sticker that you get to put it on your windshield))


Frederick NL,

I had to do the same thing when I pulled into the dealership. I told them to skip the diagnose and replace the EIS. The rest if the story in the thread linked at the beginning.
Ghostty is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: