Go Back  MBWorld.org Forums > Site & Forum Support > Test
2015 C300 navigation HELP >

2015 C300 navigation HELP

Notices
Test Use this forum to test posting messages and pictures before posting on the actual forum. If you are a new user, this is a great place to learn how to post.

2015 C300 navigation HELP

 
Old 10-25-2018, 11:05 AM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 0
Likes: 0
Received 0 Likes on 0 Posts
C300 MERCEDES 4MATIC
2015 C300 navigation HELP

I have had the car at the dealer for 3 days now. They can not get the navigation to work .The screen says please insert card They gave me a brand new card The SD slot works. We have tried to watch images and video son it no problem. Someone took the original SD navigation card out prior to me purchasing the car We have reset disconnect the battery. Factory reset. Nothing seems to work. Fm does anyone have nay ideas to help with this please
This what the screen says at all times, with card plugged in
Robert Longo is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 2015 C300 navigation HELP


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: