Disabling Check Engine Light in STAR - MBWorld.org Forums

W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Disabling Check Engine Light in STAR

Reply

 
 
 
Old 06-15-2018, 01:01 AM
  #1  
Member
Thread Starter
 
Join Date: Jan 2017
Location: East Coast
Posts: 92
Thanked 3 Times in 3 Posts
2005 E55 AMG
Disabling Check Engine Light in STAR

Hello,

Since I have owned my car, my check engine light has been disabled through STAR. That said, I scan it frequently and it has no issues. The light just isn't turned on. This became evident to me when I had a primary o2 sensor malfunction and no light. STAR showed the CEL as on, yet there was no light on in my dash.

I know there is a way to turn it off and on using dev mode (which I have), I just don't know exactly how.

Could someone please enlighten me on how to get my CEL working again? Feel free to message me if you do not want to publicly broadcast how to deactivate the CEL.

Thanks!
Davednconfused is offline  
Reply With Quote
Old 06-15-2018, 10:07 AM
  #2  
Super Member
 
rapidoxidation's Avatar
 
Join Date: Jan 2016
Location: In the Shadow of the Tetons
Posts: 681
Thanked 61 Times in 60 Posts
2005 E320 CDI
Are you sure you don't just have a burned out (or otherwise disconnected/bad solder/loose connection) bulb?
rapidoxidation is offline  
Reply With Quote
Old 06-15-2018, 11:02 AM
  #3  
Member
Thread Starter
 
Join Date: Jan 2017
Location: East Coast
Posts: 92
Thanked 3 Times in 3 Posts
2005 E55 AMG
Originally Posted by rapidoxidation View Post
Are you sure you don't just have a burned out (or otherwise disconnected/bad solder/loose connection) bulb?
Yes - STAR has a "bulb test" function. CEL bulb works fine.
Davednconfused is offline  
Reply With Quote
Old 06-15-2018, 05:46 PM
  #4  
Super Member
 
Join Date: Jan 2008
Location: UK
Posts: 594
Thanked 3 Times in 3 Posts
E55K AMG
Originally Posted by Davednconfused View Post
Hello,

Since I have owned my car, my check engine light has been disabled through STAR. That said, I scan it frequently and it has no issues. The light just isn't turned on. This became evident to me when I had a primary o2 sensor malfunction and no light. STAR showed the CEL as on, yet there was no light on in my dash.

I know there is a way to turn it off and on using dev mode (which I have), I just don't know exactly how.

Could someone please enlighten me on how to get my CEL working again? Feel free to message me if you do not want to publicly broadcast how to deactivate the CEL.

Thanks!

  1. DRIVE
  2. MESFI2.8
  3. DEVELOPEMENT DATA
  4. CONTROL UNIT ADAPTATIONS
  5. CONTROL UNIT ADAPTATIONS (variant coding)
  6. Implitzite kodierung ME281 AMG C6-stand
  7. Go to item 0182 and change to "Diagnose"

this will turn on O2 sensors, do this with the engine off
 C43  AMG  is offline  
Reply With Quote
Old 06-16-2018, 12:21 AM
  #5  
Member
Thread Starter
 
Join Date: Jan 2017
Location: East Coast
Posts: 92
Thanked 3 Times in 3 Posts
2005 E55 AMG
Originally Posted by C43 AMG View Post
  1. DRIVE
  2. MESFI2.8
  3. DEVELOPEMENT DATA
  4. CONTROL UNIT ADAPTATIONS
  5. CONTROL UNIT ADAPTATIONS (variant coding)
  6. Implitzite kodierung ME281 AMG C6-stand
  7. Go to item 0182 and change to "Diagnose"

this will turn on O2 sensors, do this with the engine off
That is just for the rear o2 sensors though, isn't it? It wouldn't completely turn off the Check Engine Light?
Davednconfused is offline  
Reply With Quote
Old 06-17-2018, 01:01 PM
  #6  
Senior Member
 
Join Date: Nov 2010
Posts: 376
Thanked 67 Times in 43 Posts
Benz
Don't have an SDS in front of me but i know for sure on 220/215 cars it is in instrument cluster under control unit adaptations.
knowbenz is offline  
Reply With Quote
Old 06-17-2018, 09:44 PM
  #7  
Senior Member
 
Join Date: Oct 2015
Posts: 263
Thanks: 0
Thanked 18 Times in 17 Posts
E420
It's under instrument cluster somewhere
E42AMG??? is online now  
Reply With Quote
 
 
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Disabling Check Engine Light in STAR


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: