Cannot turn off ABS BAS ESP warning light off - MBWorld.org Forums



CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

Cannot turn off ABS BAS ESP warning light off

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rating: Thread Rating: 14 votes, 4.71 average.
Old 12-07-2008, 01:14 AM   #1
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
Cannot turn off ABS BAS ESP warning light off

Here is what I did so far
  1. Replaced brake switch
  2. Turned engine on
  3. Turned steering wheel from far left to far right then to the middle
  4. Turned car off and pulled key
  5. Restarted car
  6. Warning lights still there
Then I disconnected the battery and did the above again without success. Any one else have any ideas besides taking it to the dealer? It is not affecting the drivability but it sure is annoying. Any assistance is appreciated.

Albert
San Francisco CA
aarroyo87 is offline   Reply With Quote
Old 12-07-2008, 01:28 AM   #2
MBWorld Fanatic!
 
MarcusF's Avatar
 
Join Date: Apr 2005
Location: SCV SoCal
Posts: 3,707
Drives: 2002 CLK430
Thanked 35 Times in 30 Posts
Albert, I hope this isn't a stupid question (which is typically a lead in to a stupid question) - I know you changed the brake light switch, but are the brake lights actually turning on? The reason I ask is, I remember some other poster installing a brand new *broken* brake switch. cough cough (ebay saved him $5) cough
MarcusF is offline   Reply With Quote
Old 12-07-2008, 01:35 AM   #3
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
I did verify that the third brake light was lighting up when I hit the brakes. I can see it in the reflection in the rear glass. I did not check to see if the 2 side brake lights came on but I can check if it is still needed for further diagnosis.
aarroyo87 is offline   Reply With Quote
Old 12-09-2008, 01:19 AM   #4
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
I posted up a youtube video to show you exactly what I'm doing to reset the BAS ABS ESP warning lights.
http://www.youtube.com/watch?v=aDMytAeT2os
Let me know if you notice if I'm doing something wrong.

Today I also went to my friends shop and hooked up a SnapOn scanner to it. The ODB2 said it did not have any trouble codes. Anyone else have a suggestion on how to get this warning light off?
aarroyo87 is offline   Reply With Quote
Old 12-09-2008, 05:13 AM   #5
Senior Member
 
Television's Avatar
 
Join Date: Oct 2006
Location: Southcoast England
Posts: 379
Drives: CL500 216
Thanks: 0
Thanked 0 Times in 0 Posts
You have lost a speed signal somewhere, and a STAR scanner should pick it up and find the fault code. Though on some cars the brake light switch kills the speed signal via the CAN BUS. when the fault is found the BAS /ABS lamps will go out, and you turn the wheel 3 times to re set the ESP
Television is offline   Reply With Quote
Old 12-09-2008, 03:02 PM   #6
Senior Member
 
Join Date: Aug 2007
Location: london
Posts: 339
Drives: ck430 2002
Thanks: 0
Thanked 0 Times in 0 Posts
your wheel speed sensor has snapped it happend to me either the rear left or right has snapped.
tastoto is offline   Reply With Quote
Old 12-13-2008, 01:38 AM   #7
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
I had a friend from an idependant Mercedes Benz repair shop scan the codes. He said it was ESP / SPS control module that was bad. I either have to buy a new one or get it rebuilt. The problem was either the speed sensor, the wires to the speed sensor or the control module. The speed sensor and the wires tested fine so it must be the control module. Scanner was picking up a code C1000. Any recommendations on where to get one of these or a guru on the site who can rebuild it for a good price.
aarroyo87 is offline   Reply With Quote
Old 12-28-2008, 05:25 AM   #8
Newbie
 
Markizzy's Avatar
 
Join Date: Jul 2007
Location: Richmond,BC
Posts: 15
Drives: 06 ML350 Sports pack
Thanks: 0
Thanked 0 Times in 0 Posts
same problem that im having on my
w203,got stuck in the snow abs light and bas went on.havent replaced the brake light switch yet but i did try the turning the wheel procedure...any other way to reset it?
Markizzy is offline   Reply With Quote
Old 02-04-2009, 02:36 AM   #9
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
Just an FYI - i had the ESP / SPS control module rebuilt and i still have the damn light on.
Here is what I have tried so far.
1. Replace brake light switch
2. Rebuilt ESP / SPS control module
3. Turned steering wheel side to side
4. Speed sensor tested fine according to my mechanic
5. Connectivity to speed sensor tested fine also.

Any other steps i sould take to figure this out?
aarroyo87 is offline   Reply With Quote
Old 02-08-2009, 05:03 PM   #10
Member
 
Join Date: Nov 2008
Location: NorthHollywood
Posts: 139
Drives: 1999 Mercedes Benz CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
I had the same problem and a friend told me to get my cars alignment done and i got it done for like 50 bucks and resterted the car and never came back on. So worth a try because my lights would always come on as soon as i would start the car or sometime 15 mins after driving it. Good Luck
AMGMB is offline   Reply With Quote
Old 02-08-2009, 09:16 PM   #11
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
AMGMB, My alignment seems fine. The tires are wearing evenly and it does not pull left nor right. It maybe slightly off but I'm not sure it would cause the light to be on. Did you car have symtoms of a bad alignment?
aarroyo87 is offline   Reply With Quote
Old 02-09-2009, 01:10 AM   #12
Super Member
 
sfclk's Avatar
 
Join Date: Mar 2008
Posts: 576
Drives: 1999 CLK320
Thanks: 0
Thanked 0 Times in 0 Posts
Is the abs or traction control working?

Isn't there a relay for abs and esp?
sfclk is offline   Reply With Quote
Old 02-09-2009, 01:21 AM   #13
Newbie
Thread Starter
 
aarroyo87's Avatar
 
Join Date: Dec 2008
Posts: 21
Drives: 2002 CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
I did not test the ABS but the traction control is definitely not working. I’m constantly spinning the rear tires if I’m not easy on the gas pedal. Do you know where the relay would be located?
aarroyo87 is offline   Reply With Quote
Old 02-10-2009, 12:28 AM   #14
Member
 
Join Date: Nov 2008
Location: NorthHollywood
Posts: 139
Drives: 1999 Mercedes Benz CLK430
Thanks: 0
Thanked 0 Times in 0 Posts
My alignment wasnt too bad but slighty off also and after i got it done the lights never came back on. Dont no if that'll work for you though.
AMGMB is offline   Reply With Quote
Old 07-27-2010, 06:13 PM   #15
Junior Member
 
vannasinh's Avatar
 
Join Date: May 2010
Location: North Texas
Posts: 37
Drives: 2006 w203
Thanks: 0
Thanked 0 Times in 0 Posts
duuuuude my esp light is on too.

got my calipers powder coated, changed the front rotors, replaced both front and rear brake pads and bled the brakes as best as we could.

i ordered the brake light switch. should come in friday.

i have no idea what to do with the esp light though. i'm gonna try the steering wheel thing next time i see the light come on. crossing my fingers! freaking light is killing me!!! other than that the car's driving fine...
vannasinh is offline   Reply With Quote
Old 08-03-2010, 05:12 PM   #16
Junior Member
 
RickTheRuler727's Avatar
 
Join Date: Sep 2006
Location: N.Y.C.
Posts: 74
Drives: '99 CLK320, '91 BMW 325Ic
Thanks: 0
Thanked 0 Times in 0 Posts
My lights come, and go every few days. I changed the brake light switch , and did the wheel turning left right thing, and the light still comes , and goes. ABS is working when lights are on, and so does the cruise controll so I'm just learning to live with it...
RickTheRuler727 is offline   Reply With Quote
Old 08-03-2010, 11:54 PM   #17
MBWorld Fanatic!
 
Join Date: May 2007
Location: Nebraska
Posts: 1,433
Drives: 99CLK320,
Thanks: 0
Thanked 0 Times in 0 Posts
I wanted ESP in the worst way on my 99 and I am so glad I don't have it.
dlbehrns is offline   Reply With Quote
Old 09-18-2010, 03:09 PM   #18
Newbie
 
Join Date: Sep 2010
Posts: 1
Drives: c230
Thanks: 0
Thanked 0 Times in 0 Posts
BAS ABS ESP light

My wife drives a C230K

I get that BAS ABS ESP message every time I'm driving the car. When my wife drives, she never gets it. Clearly it happens when I adjust my seat down (not back, I mean sinking the seat down with the lever on the left of the seat). As soon as my wife gets back in the car, adjusts the seat back up it all goes away.

There is definitely something wrong with the harness underneath the driver's seat. So I decided to test this theory. I drove with my seat jacked up. Sure enough, I did not get the message.

I disconnected and reconnected all the harnesses under the seat one day, making sure all the connections were good. The problem went away for 2 weeks, until once again reappearing.

So I would look into that harness before attempting any more pricey fixes.
marcomassimi is offline   Reply With Quote
Old 10-08-2010, 03:53 PM   #19
Senior Member
 
Join Date: Nov 2007
Location: 954
Posts: 302
Drives: 01 CLK 55 AMG
Thanks: 0
Thanked 0 Times in 0 Posts
my ESP module and K40 went bad the other day. About to get mine rebuilt, hope i don't have the same problem after.
howie is offline   Reply With Quote
Old 03-14-2011, 10:40 PM   #20
Newbie
 
Join Date: Mar 2011
Posts: 1
Drives: um mercedes a160
Thanks: 0
Thanked 0 Times in 0 Posts
bas esp abs light

FAÇA UM TESTE PARA SABER SE O DEFEITO DAS LUZES BAS ESP E ABS ESTÁ NO SENSOR DO FREIO:
MANTENHA O PÉ NO FREIO E LIGA O MOTOR, DEPOIS TIRA O PÉ, SE A LUZ SÓ ACENDER DEPOIS, TROQUE O INTERRUPTOR (SENSOR)


TAKE A TEST TO FIND OUT IF THE DEFECT OF LIGHTS AND BAS ESP ABS BRAKE SENSOR IS IN:
KEEP ON FOOT ON BRAKE AND ENGINE, THEN TAKES THE FOOT, IF ONLY LIGHT LIGHT THEN CHANGE THE SWITCH (SENSOR)
messias40@gmail.com
messias40 is offline   Reply With Quote
Old 09-08-2011, 02:57 PM   #21
Senior Member
 
SuperChargerE55's Avatar
 
Join Date: Sep 2011
Location: Sweden
Posts: 272
Drives: E55 AMG V8 Kompressor 2004 E 55 AMG Type: 5,439 cc (5.439 L; 331.9 cu in) Supercharged V8 Powe
Thanked 1 Time in 1 Post
ABS + BAS Warning light simple reset

Howdy guys,,
I can see a lot of you guys has run into this comon problem, if you do not have an obviously problem with worn brake pads ect then is easy to reset these warning lights...
Just be sure nothing is actually wrong and need replaced..

on the CLK 320 is easy to reset!
- The car must standstill
- Gear if automatic on Park position
- Key in postion 2
- In dashboard left side you got the Up Down + R Buttons, hold the R for aprox 5 seconds then in dash will show if you want to resset if not press R again. Then you can on the stearing wheel choose your options at this point reset is done and you the language also resets to German Factory defaults.. This resets all the functions except service interval....

Had same problem after removing dash for an LED update now ran into same problem and tried drive, tried pumpin pedal and start engine but just stayed on so tried the reset in dash procedure and woila ABS+BAS Warning light gone...

Glad for this option it works if not there is a problem somewhere brake pads, worn disc ect let your mechanic inspect the computer for fault codes.
SuperChargerE55 is offline   Reply With Quote
Old 09-08-2011, 02:59 PM   #22
Senior Member
 
SuperChargerE55's Avatar
 
Join Date: Sep 2011
Location: Sweden
Posts: 272
Drives: E55 AMG V8 Kompressor 2004 E 55 AMG Type: 5,439 cc (5.439 L; 331.9 cu in) Supercharged V8 Powe
Thanked 1 Time in 1 Post
Abs Bas/esp Warning Lights reset

Howdy guys,,
I can see a lot of you guys has run into this comon problem, if you do not have an obviously problem with worn brake pads ect then is easy to reset these warning lights...
Just be sure nothing is actually wrong and need replaced..

on the CLK 320 is easy to reset!
- The car must standstill
- Gear if automatic on Park position
- Key in postion 2
- In dashboard left side you got the Up Down + R Buttons, hold the R for aprox 5 seconds then in dash will show if you want to resset if not press R again. Then you can on the stearing wheel choose your options at this point reset is done and you the language also resets to German Factory defaults.. This resets all the functions except service interval....

Had same problem after removing dash for an LED update now ran into same problem and tried drive, tried pumpin pedal and start engine but just stayed on so tried the reset in dash procedure and woila ABS+BAS Warning light gone...

Glad for this option it works if not there is a problem somewhere brake pads, worn disc ect let your mechanic inspect the computer for fault codes.
SuperChargerE55 is offline   Reply With Quote
Old 09-18-2011, 04:30 PM   #23
Newbie
 
Join Date: Nov 2010
Location: Lebanon
Posts: 5
Drives: C230 Kompressor 2005
Thanks: 0
Thanked 0 Times in 0 Posts
I did everything above and still bas error, someone told me that I shoud change the fuse fox motor side, is this right please help
alito315744 is offline   Reply With Quote
Old 09-19-2011, 02:06 AM   #24
Senior Member
 
SuperChargerE55's Avatar
 
Join Date: Sep 2011
Location: Sweden
Posts: 272
Drives: E55 AMG V8 Kompressor 2004 E 55 AMG Type: 5,439 cc (5.439 L; 331.9 cu in) Supercharged V8 Powe
Thanked 1 Time in 1 Post
BAS ERROR

Im sorry to hear that mate but firtsh things first, what did you do to trigger the BAS Warning ? Did you do something particular or did it just come out of the blue?

Please try specify what triggered it!
And trust me I understand your worries but if it can not be resset you need take it to the dealer and let him hook up the computer is just a simple resset dont be worried unless you know there is an actually issue with the brakes....
but I know the feeling to see the warning baah annoying and we dont want that in our Mercedes, right :-)
SuperChargerE55 is offline   Reply With Quote
Old 09-19-2011, 02:40 PM   #25
Newbie
 
Join Date: Nov 2010
Location: Lebanon
Posts: 5
Drives: C230 Kompressor 2005
Thanks: 0
Thanked 0 Times in 0 Posts
It came out suddenly I did reset everything in the car using the star mercedes scanner + software it disappeared but then it came on again. Some guy told me to change the sam fuse box near the motor but i don't think this is the problem so please reply and help
alito315744 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
collision assist inoperative djokodallas C Class (W205) 43 10-08-2016 07:59 PM
Bad Alternator or Voltage Regulator? MTV10 W211 AMG 20 03-07-2016 04:12 PM
2008 CLK63 AMG Black Series, rare Arctic White. 1 of 35 made Euro Mercedes Vehicles 23 12-08-2015 05:09 PM
3rd light, ABS/BAS/ESP light comes on after headlights are turned on angela12hickman E-Class (W210) 3 09-07-2015 10:55 PM
Trans won't shift into DRIVE BLKROKT C63 AMG (W204) 8 09-04-2015 11:33 AM


Tags
1999, abs, absesp, benz, clk, esp, light, mercedes, reset, sl500, testing, turn, w203, warning, youtube


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 10:12 PM.


Copyright © 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
You Rated this Thread: 5