Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W210)
Sign in using an external account
Register Forgot Password?


E-Class (W210) 1995-2002: E 200, E 220D, E 240, E 290TD, E 300TD, E 200, E 240, E 280, E 320, E 420, E 430 (Wagon, Touring, 4Matic)

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 08-20-2011, 04:01 AM   #1
Junior Member
 
Join Date: Mar 2011
Posts: 27
Drives: 01 E320
P2001 COMPONENT N15/3 & P220A THE SPEED COMPARISON OF Y3/6N2 TO Y3/6N3 IS IMPLAUSIBLE

ETC- ELECTRONIC TRANSMISSION CONTROL

P2001 : COMPONENT N15/3 (ETC [EGS] CONTROL UNIT ) IS DEFECTIVE
P220A : THE SPEED COMPARISON OF Y3/6N2 TO Y3/6N3 IS IMPLAUSIBLE.................

ANY TAKES ON THIS ??? I NEED HELP & ANY SUGGESTIONS OR ANYBODY THAT ALREADY WENT THRU THIS ..

CAR IS A : 2001 E320
To remove this ad, register today or login if you already are registered!

dwnsouf7 is offline   Reply With Quote
Old 08-20-2011, 07:49 AM   #2
MBWorld Fanatic!
 
ohlord's Avatar
 
Join Date: Apr 2007
Posts: 6,170
Drives: 300E a couple 1994 w124wagon E320 Wagon/,1971MGB Track/Rally, MG Midget Autocross ,2000 E320 wagon.
iF YOU ARE IN transmission LIMP MODE

OR SHIFTING PROBLEMS THOSE CODES NORMALLY SHOW UP AS A GENERIC CODE ON A REGULAR SCANNER as p0715 input speed sensor.
The evcu is probably not getting the proper signal from the n15/3 ETC
Inspect the electrical connector on the transmission for leakage.
Get some CRC mass air sensor cleaner and follow the r/r procedure on www.benzworld.org w210 forum and replace the connector after cleaning out the n15/3 called the ETC
The electrical connector is a known leak issue and when it leaks it passes trans fluid into the ETC electronic transmission control
and gives those codes.
I'm thinking since you show the fault P2001 : COMPONENT N15/3 (ETC [EGS] CONTROL UNIT ) IS DEFECTIVE
That the fluid leak is the issue and not the other cause of some transmission problems like the conductor plate failed.
Easy repair if you follow directions parts and a bit of fluid to replace.
You might want to do the trans fluid and filter change while down there I think it is suggested per Mercedes repair procedure and it is due anyway.
__________________




00-02 drivers side heated self dimming mirror glass
O2 sensors plug and play
17mm special spark plug boot tool
Spring loaded u joint spark plug socket
722.6 transmission dipstick
W210 W124 parts
Cryo rotors
Brake pads F.S.



Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz"

Last edited by ohlord; 08-20-2011 at 08:05 AM.
ohlord is offline   Reply With Quote
Old 08-20-2011, 07:54 AM   #3
MBWorld Fanatic!
 
ohlord's Avatar
 
Join Date: Apr 2007
Posts: 6,170
Drives: 300E a couple 1994 w124wagon E320 Wagon/,1971MGB Track/Rally, MG Midget Autocross ,2000 E320 wagon.
autohausaz.com

lists the electrical connector at 6 bucks
You can also get the trans filter and gasket from them
You need a special dipstick to measure the fluid(I have them)
and you can use mb spec 722.6 spec fluid valvoline maxlife 722.6/Nag1 spec fluid
the diy is in the stickies section at the top of the benzworld w210 forum
__________________




00-02 drivers side heated self dimming mirror glass
O2 sensors plug and play
17mm special spark plug boot tool
Spring loaded u joint spark plug socket
722.6 transmission dipstick
W210 W124 parts
Cryo rotors
Brake pads F.S.



Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz"
ohlord is offline   Reply With Quote
Old 08-20-2011, 03:05 PM   #4
Junior Member
 
Join Date: Mar 2011
Posts: 27
Drives: 01 E320
cool

cool thanks, ...thats more or less what i was thinking when all of this started, was because of a "Limp Mode" then i went to a tech to scan it with the star scanner and read me these codes..we checked the ETC or TCU which ever one it is under the hood, infront of the passenger side and we found some fluid just by passing a finger thru it , we noticed fluid was in that compartment..But the tech went ahead and suggested with out actually taking it out completely, to change out the ETC and buy a new one and also to change the conductor plate just like that...

i had read before about the the cause of limp mode to the w210 and is because of that same fluid going up the harness..i just want to be sure if i spray the contact on the bottom of the electric plug out and cleaning it &,buy a new electric plug and change it ,and clean the harness including the actual ETC i would be able to fix this...is the ETC on the E320 sealed inside good enough to salvage by cleaning it really good in combination with the other procedures?

Last edited by dwnsouf7; 08-20-2011 at 03:16 PM.
dwnsouf7 is offline   Reply With Quote
Old 08-20-2011, 05:30 PM   #5
MBWorld Fanatic!
 
ohlord's Avatar
 
Join Date: Apr 2007
Posts: 6,170
Drives: 300E a couple 1994 w124wagon E320 Wagon/,1971MGB Track/Rally, MG Midget Autocross ,2000 E320 wagon.
Sop up

the fluid and clean it out with the crc.It will remove the fluid and evaporate fully. You might also want to get the o ring and connector from the dealer since I don't know the supposed quality of the URO brand unit.
You may need to have the codes scanned on an sds after the rpair
__________________




00-02 drivers side heated self dimming mirror glass
O2 sensors plug and play
17mm special spark plug boot tool
Spring loaded u joint spark plug socket
722.6 transmission dipstick
W210 W124 parts
Cryo rotors
Brake pads F.S.



Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz"
ohlord is offline   Reply With Quote
Old 08-20-2011, 06:37 PM   #6
Junior Member
 
Join Date: Mar 2011
Posts: 27
Drives: 01 E320
k

oh ok....would the troubled codes need to be cleared by the star scanner to be fully working normal again, or is the repair just enough to do the trick almost ?
dwnsouf7 is offline   Reply With Quote
Old 08-20-2011, 07:38 PM   #7
MBWorld Fanatic!
 
ohlord's Avatar
 
Join Date: Apr 2007
Posts: 6,170
Drives: 300E a couple 1994 w124wagon E320 Wagon/,1971MGB Track/Rally, MG Midget Autocross ,2000 E320 wagon.
Sometimes

the repair does the trick sometimes the sds needs to reset the codes.
__________________




00-02 drivers side heated self dimming mirror glass
O2 sensors plug and play
17mm special spark plug boot tool
Spring loaded u joint spark plug socket
722.6 transmission dipstick
W210 W124 parts
Cryo rotors
Brake pads F.S.



Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz"
ohlord is offline   Reply With Quote
Old 08-20-2011, 09:11 PM   #8
Junior Member
 
Join Date: Mar 2011
Posts: 27
Drives: 01 E320
k

k....ima do this 2morrow or this week....hopefully that will do the trick "

how would i know for sure that im really going to be needing to replace the conductor plate as well ?
dwnsouf7 is offline   Reply With Quote
Old 08-21-2011, 05:55 PM   #9
Junior Member
 
Join Date: Mar 2011
Posts: 27
Drives: 01 E320
Will disconnecting the ETC unprogram the unit or can i disconnect to clean better ??
dwnsouf7 is offline   Reply With Quote
Old 08-21-2011, 05:55 PM
 
 
 
Reply

Tags
2007, benz, class, code, control, diy, e320, limp, mercedes, mode, p2001, p220a, transmission, unit, w210



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 07:56 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details