Aftermarket Speaker and Amplifier install pictures - Page 4 - MBWorld.org Forums

Go Back  MBWorld.org Forums > Technical & Vehicle Assistance Forums > Audio & Electronics
Aftermarket Speaker and Amplifier install pictures >

Aftermarket Speaker and Amplifier install pictures

Notices
Audio & Electronics Use this forum to discuss audio and electronic upgrades for your Mercedes-Benz.

Aftermarket Speaker and Amplifier install pictures

Old 08-24-2010, 01:21 AM
  #76  
Newbie
 
xxrickey21xx's Avatar
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
2001 ML430
no golf clubs for me. I don't even put bags back there when I go to the grocery store anymore. Last time I did, I got home and the eggs were all broken
xxrickey21xx is offline  
Old 10-14-2010, 02:45 AM
  #77  
Newbie
 
Join Date: Oct 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
350 e mb 2006
I have a 350 E 2006 sedan which its front speaker makes a noisy sound when playing a loud music. I want to know what kind and brand of speaker to use and if I would be able to do it myself. Can any body can direct me in changing it?
Robinhood is offline  
Old 10-14-2010, 09:22 PM
  #78  
MBWorld Fanatic!
Thread Starter
 
pinebaron's Avatar
 
Join Date: May 2007
Location: Blaine, WA
Posts: 1,227
Thanked 7 Times in 7 Posts
07 E320 Bluetec
Originally Posted by Robinhood View Post
I have a 350 E 2006 sedan which its front speaker makes a noisy sound when playing a loud music. I want to know what kind and brand of speaker to use and if I would be able to do it myself. Can any body can direct me in changing it?
Do you mean the front center channel speaker? If so, do a search on 'replace center channel speaker '
pinebaron is offline  
Old 10-25-2010, 12:45 PM
  #79  
Senior Member
 
Wardsweb's Avatar
 
Join Date: Mar 2003
Location: San Antonio, TX
Posts: 450
Thanked 3 Times in 3 Posts
'11 SL550 - '08 ML350
Replaced the stock subwoofer with two 12's and an amp. You can see the install pics here: C240 Subwoofer Install

Wardsweb is offline  
Old 12-02-2010, 01:06 AM
  #80  
Junior Member
 
Join Date: Aug 2010
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
03 e55 amg
E55 amg indash help

sup guys i was reading yoru tread and i see pinebaron that your very good at this!!! im needing help on installing a indash tv in my car any help it would be greatful!! anything would help thanks!!!!
7o4e55amg is offline  
Old 06-02-2011, 08:38 PM
  #81  
Member
 
Join Date: Sep 2009
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Depends on the season
Anyone ever use the MoBridge? It takes the fiber optic line and converts it to an RCA. You basically bypass the Logic 7 and can run multiple amps. Factory head unit no longer cuts bass at half volume
Cypher94 is offline  
Old 06-02-2011, 09:17 PM
  #82  
Member
 
6spdcoupe's Avatar
 
Join Date: Oct 2010
Location: Central Jersey
Posts: 238
Thanks: 0
Thanked 3 Times in 3 Posts
'14 F15 M, '06 E55, '13 CX-9
Originally Posted by Cypher94 View Post
Anyone ever use the MoBridge? It takes the fiber optic line and converts it to an RCA. You basically bypass the Logic 7 and can run multiple amps. Factory head unit no longer cuts bass at half volume

Not with RCA, Toslink only for the time being.
6spdcoupe is offline  
Old 06-02-2011, 10:06 PM
  #83  
Former Vendor of MBWorld
 
Join Date: Mar 2011
Location: Atlanta
Posts: 1,199
Thanks: 0
Thanked 3 Times in 1 Post
05 CL65 AMG, 07 Ferrari F430, 03 Range Rover HSE
It now converts to RCA
Cartronics is offline  
Old 06-10-2011, 11:38 PM
  #84  
MBWorld Fanatic!
Thread Starter
 
pinebaron's Avatar
 
Join Date: May 2007
Location: Blaine, WA
Posts: 1,227
Thanked 7 Times in 7 Posts
07 E320 Bluetec
Originally Posted by AltheaD View Post
nice forum. I'm thinking of doing the same stuff with my car but i think it would be a little bit hard for me.
Nothing is hard; right tools, a few parts and patience; don't let installers intimidate you.
pinebaron is offline  
Old 06-11-2011, 05:09 AM
  #85  
Member
 
6spdcoupe's Avatar
 
Join Date: Oct 2010
Location: Central Jersey
Posts: 238
Thanks: 0
Thanked 3 Times in 3 Posts
'14 F15 M, '06 E55, '13 CX-9
Originally Posted by Cartronics View Post
It now converts to RCA

But not shipping yet, hence why I said "for the time being". Should be ready by the end of the month though.
6spdcoupe is offline  
Old 11-16-2011, 02:00 PM
  #86  
Super Member
 
Kelvin07's Avatar
 
Join Date: Nov 2011
Location: Always Sunny & beautiful, Costa Rica
Posts: 559
Thanks: 0
Thanked 4 Times in 4 Posts
CLS55 AMG, ML63 AMG, Cayenne S
Originally Posted by xxrickey21xx View Post


Kelvin07 is offline  
Old 11-21-2012, 12:52 PM
  #87  
Newbie
 
Join Date: Nov 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
2004 Mercedes E320 4matic
very nice and clean install!! Rockford Fosgate is the way to go!! Nice car by the way! I plan on doing this very soon, just getting idea's and advice on what speaker set up to use right now!
Popester112 is offline  
Old 11-26-2012, 07:36 AM
  #88  
MBWorld Fanatic!
Thread Starter
 
pinebaron's Avatar
 
Join Date: May 2007
Location: Blaine, WA
Posts: 1,227
Thanked 7 Times in 7 Posts
07 E320 Bluetec
Thanks. Email me
pinebaron is offline  
Old 03-17-2013, 01:26 AM
  #89  
Senior Member
 
xzotik1's Avatar
 
Join Date: Aug 2012
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
C300 AMG SPORT
I was hoping to see some really nice installs.
xzotik1 is offline  
Old 03-22-2013, 04:22 PM
  #90  
Newbie
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
e500 4matic
hello.i am looking for the color coding of the fiber optic replacement cable(optical cable) for an aftermarket navigation system for an E500 2004.any help?
arp1979 is offline  
Old 03-23-2013, 05:16 PM
  #91  
MBWorld Fanatic!
 
jbondox's Avatar
 
Join Date: Apr 2007
Location: Cleveland Ohio
Posts: 2,430
Thanked 6 Times in 6 Posts
beater with a heater
Originally Posted by xzotik1 View Post
I was hoping to see some really nice installs.


Me 2
jbondox is offline  
Old 04-10-2013, 01:25 AM
  #92  
Member
 
Join Date: Dec 2012
Location: Vacaville, CA
Posts: 103
Thanks: 0
Thanked 1 Time in 1 Post
2008 CLS 63 amg
Originally Posted by jbondox View Post


Me 2
Simple Install......in my CLS63.....replaced stock speakers on doors with Focal separates in the front...and co-ax's in the rear doors. These are powered by an Alpine PDX-F4 4 channel amp.

Added a JL 500/1 and 2 10 inch Alpine Type R subs.....

Stock radio is still being utilized...except I added an Audison Bit 10 processor to control the amps....and sub control.


Og Asr is offline  
Old 04-10-2013, 05:29 PM
  #93  
MBWorld Fanatic!
Thread Starter
 
pinebaron's Avatar
 
Join Date: May 2007
Location: Blaine, WA
Posts: 1,227
Thanked 7 Times in 7 Posts
07 E320 Bluetec
Originally Posted by Og Asr View Post
Simple Install......in my CLS63.....replaced stock speakers on doors with Focal separates in the front...and co-ax's in the rear doors. These are powered by an Alpine PDX-F4 4 channel amp.

Added a JL 500/1 and 2 10 inch Alpine Type R subs.....

Stock radio is still being utilized...except I added an Audison Bit 10 processor to control the amps....and sub control.


Very neat look
pinebaron is offline  
Old 08-12-2013, 02:52 AM
  #94  
Newbie
 
jenniedsy's Avatar
 
Join Date: Aug 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
w220
Thanks for your sharing
jenniedsy is offline  
Old 08-23-2013, 03:13 AM
  #95  
Member
 
Join Date: Jul 2013
Location: NYC
Posts: 182
Thanked 2 Times in 2 Posts
X4 M40
Originally Posted by pinebaron View Post
Thanks. Email me
My C300 has Navigation+Command+DVD but no premium sound unfortunately, so looks like I'll be researching on how to do a nice system upgrade for a clean good sound.

Originally Posted by Og Asr View Post
Simple Install......in my CLS63.....replaced stock speakers on doors with Focal separates in the front...and co-ax's in the rear doors. These are powered by an Alpine PDX-F4 4 channel amp.

Added a JL 500/1 and 2 10 inch Alpine Type R subs.....

Stock radio is still being utilized...except I added an Audison Bit 10 processor to control the amps....and sub control.

How you liking your setup?
Costly?

I have a Hifonicz Brutuz 1200.1D mono amp and a Kicker L7 12" in its oem ported box that i had used in my previous very lightly maybe this is too much for my C300 ?
robnyc is offline  
Old 08-23-2013, 05:20 AM
  #96  
Newbie
 
johnwen's Avatar
 
Join Date: Jul 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
w211
how does it work ?
johnwen is offline  
Old 08-23-2013, 11:57 AM
  #97  
Member
 
Join Date: Dec 2012
Location: Vacaville, CA
Posts: 103
Thanks: 0
Thanked 1 Time in 1 Post
2008 CLS 63 amg
Originally Posted by robnyc View Post
My C300 has Navigation+Command+DVD but no premium sound unfortunately, so looks like I'll be researching on how to do a nice system upgrade for a clean good sound.



How you liking your setup?
Costly?

I have a Hifonicz Brutuz 1200.1D mono amp and a Kicker L7 12" in its oem ported box that i had used in my previous very lightly maybe this is too much for my C300 ?
Love the set up....the key is the Audison Bit 10 sound processor. That is the most costly part. Also paired up to Focal separates......

You tube the Audison Bit 10....and you will see how much better the stock system wakes up.
Og Asr is offline  
Old 09-03-2013, 04:54 PM
  #98  
Member
 
Join Date: Jul 2013
Location: NYC
Posts: 182
Thanked 2 Times in 2 Posts
X4 M40
Originally Posted by Og Asr View Post
Simple Install......in my CLS63.....replaced stock speakers on doors with Focal separates in the front...and co-ax's in the rear doors. These are powered by an Alpine PDX-F4 4 channel amp.

Added a JL 500/1 and 2 10 inch Alpine Type R subs.....

Stock radio is still being utilized...except I added an Audison Bit 10 processor to control the amps....and sub control.


Definitely trying to do this on my C300 , even though I currently have a Kicker L7 12" in its OEM ported box and a Hifonicz Brutuz Mono 1200.D amp i had in my previous car bringing into my new setup
robnyc is offline  
Old 10-02-2013, 11:57 PM
  #99  
Newbie
 
WilliamZgura's Avatar
 
Join Date: Oct 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2001 CL 600
need help please

listen to this madness, i recently purchased a 2001 CL 600, car is beautiful and runs like a rapped ape. handles great and i m just happy over all. yesterday i bought a bunch of system stuff,(i can install systems kinda) radio,amps,subs,dr n back deck spkrs, ok so a friend of mine takes everything apart then gets locked up, now i m not a fabricator n i have no idea how to mount the tv radio in were the radio goes, he cut my panel that separates the phone dial pad and radio and there is just a big hole. i got all the pieces and can put it all back but have no idea were to mount to also i have n eq that going in as well any help would b awesome sorry threads so long
WilliamZgura is offline  
Old 11-02-2013, 11:48 AM
  #100  
Junior Member
 
Join Date: Oct 2013
Location: Atlanta, Ga
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
06 E350
comand unit

I posted this problem earlier today. I installed an aftermarket amp and sub in my E350 upon connecting the power wire to the battery the car lost power and once it powered up the comand unit wouldn't put out power. I press the button the logo shows up for about 15 sec but no output. Can you help me diagnose this problem
truleyblessed is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Aftermarket Speaker and Amplifier install pictures


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: