My lowbeam bulbs [HID] flashing - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
My lowbeam bulbs [HID] flashing > My lowbeam bulbs [HID] flashing
Notices
C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

My lowbeam bulbs [HID] flashing

Reply

 
 
Old 12-16-2009, 05:26 PM
  #1
Member
Thread Starter
 
dj_rzn's Avatar
 
Join Date: May 2009
Location: Romania - Iasi
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes c220
My lowbeam bulbs [HID] flashing

I installed a HID kit and i have some strange problem which i saw it posted but i didn't find any answer.
The problem is that when i turn the headlight on my lowbeam position and the engine is stopped, they are ok, but when i start the engine, for about 5 - 10 minute they are flashing. This happens especially when it's cold outside, and now that is winter, it's really stressing. Do you have a solution please?

PS: I know it's a topic about this but i didn't have the patience to search in 100 pages and also i asked but i really didn't understand much.

PS 2: i went to my dealership, and they said that they set it on the xenon mode but it's still the same thing.

I also tried to change the ... well i really don't know how i can say it in english, but it is that small box that came at every xenon bulb.
dj_rzn is offline  
Reply With Quote
Old 12-16-2009, 05:57 PM
  #2
Member
 
Join Date: Jul 2008
Location: Bay Area
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
MBZ
You need a Error code eliminator (see link)..Same thing happened to me when I installed my 55w ddm tuning kit...
http://www.ddmtuning.com/index.php?p...=130&parent=85
BayAreaC32 is offline  
Reply With Quote
Old 12-16-2009, 06:15 PM
  #3
Senior Member
 
omg its nate's Avatar
 
Join Date: Apr 2009
Location: Minnesota
Posts: 459
Thanks: 0
Thanked 0 Times in 0 Posts
06 C230 6 Speed FTW
+1 on what Bay said.
omg its nate is offline  
Reply With Quote
Old 12-16-2009, 06:19 PM
  #4
Super Member
 
laneshift's Avatar
 
Join Date: Aug 2009
Location: Orlando, FL
Posts: 868
Thanks: 0
Thanked 0 Times in 0 Posts
C240
While we're at it, is it important for our cars to buy a relay harness?
laneshift is offline  
Reply With Quote
Old 12-16-2009, 06:26 PM
  #5
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA And RVA
Posts: 5,273
Thanks: 0
Thanked 16 Times in 16 Posts
THE C350
the ... is a ballast just so you know.
samaritrey is offline  
Reply With Quote
Old 12-16-2009, 06:39 PM
  #6
MBWorld Fanatic!
 
Join Date: Jul 2008
Posts: 6,742
Thanked 27 Times in 25 Posts
2014 C350 Sport Sedan & 2015 Kia Optima Hybrid EX
I'm not sure how one sees this EXTREMELY common problem posted and doesn't see the also extremely common answer, but I digress.

Laneshift, it's not necessary to buy a harness.
LILBENZ230 is offline  
Reply With Quote
Old 12-16-2009, 07:19 PM
  #7
Member
Thread Starter
 
dj_rzn's Avatar
 
Join Date: May 2009
Location: Romania - Iasi
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes c220
Thanks a lot for your answers guys!
Now i can go to sleep much happier! )
PS: Here is 1:20AM, and there is ... hmm 6:20PM
dj_rzn is offline  
Reply With Quote
Old 12-16-2009, 07:24 PM
  #8
Super Member
 
laneshift's Avatar
 
Join Date: Aug 2009
Location: Orlando, FL
Posts: 868
Thanks: 0
Thanked 0 Times in 0 Posts
C240
Originally Posted by LILBENZ230 View Post
I'm not sure how one sees this EXTREMELY common problem posted and doesn't see the also extremely common answer, but I digress.

Laneshift, it's not necessary to buy a harness.
Applies for Pre-Facelift vehicles, too? Just taking precaution for my 8 year old wires.
laneshift is offline  
Reply With Quote
Old 12-17-2009, 12:14 AM
  #9
Super Member
 
Join Date: Sep 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
C63
so if i got my HID's professionally installed and i bought the error code eliminator, they would know how to install it? or would i have to tell them where to put it?

also, i have the same problem as OP but haven't been to the dealer to get xenon set to present yet. if i do that, is there a chance i won't need to buy this? if i just bought them instead of going to the dealer, would that also take care of the problem without having to get xenon set to present?

thanks guys. sorry for all the questions, but i just want to see what my options are. thanks.
SheryarYO is offline  
Reply With Quote
Old 12-17-2009, 12:38 AM
  #10
MBWorld Fanatic!
 
B189s's Avatar
 
Join Date: Feb 2005
Location: Jakarta
Posts: 1,155
Thanks: 0
Thanked 0 Times in 0 Posts
1996 MB E320 & 2010 Nissan Elgrand
Originally Posted by SheryarYO View Post
so if i got my HID's professionally installed and i bought the error code eliminator, they would know how to install it? or would i have to tell them where to put it?

also, i have the same problem as OP but haven't been to the dealer to get xenon set to present yet. if i do that, is there a chance i won't need to buy this? if i just bought them instead of going to the dealer, would that also take care of the problem without having to get xenon set to present?

thanks guys. sorry for all the questions, but i just want to see what my options are. thanks.
I don't think you need to set xenon to present if you have that error eliminator installed along with your HID kit.

I never personally tried the eleminator, but I never have a problem with my car after I did the coding.
B189s is offline  
Reply With Quote
Old 12-17-2009, 08:14 PM
  #11
SPONSOR
 
Join Date: Sep 2009
Location: Los Angeles, CA
Posts: 3,957
Thanked 2 Times in 2 Posts
E70 X5M-daily Z3M Coupe-Garage queen
We are about to have a HID special.

$50 for 35w HID kit.
$15 for type 3 error code canceler.
+ shipping.

You save $5.
Gary@Suvneer is online now  
Reply With Quote
Old 12-17-2009, 09:26 PM
  #12
MBWorld Fanatic!
 
TemjinX2's Avatar
 
Join Date: Dec 2007
Location: Corona, CA
Posts: 5,034
Thanks: 0
Thanked 0 Times in 0 Posts
03 g35 coupe...........02 c32 Sold
Originally Posted by SheryarYO View Post
so if i got my HID's professionally installed and i bought the error code eliminator, they would know how to install it? or would i have to tell them where to put it?

also, i have the same problem as OP but haven't been to the dealer to get xenon set to present yet. if i do that, is there a chance i won't need to buy this? if i just bought them instead of going to the dealer, would that also take care of the problem without having to get xenon set to present?

thanks guys. sorry for all the questions, but i just want to see what my options are. thanks.
just buy 55watt ballasts. With all the $50 55watt hids kits around, you shouldn't have any problems.
TemjinX2 is offline  
Reply With Quote
Old 12-17-2009, 09:28 PM
  #13
MBWorld Fanatic!
 
TemjinX2's Avatar
 
Join Date: Dec 2007
Location: Corona, CA
Posts: 5,034
Thanks: 0
Thanked 0 Times in 0 Posts
03 g35 coupe...........02 c32 Sold
to op, i would say double check all your grounds. Make sure non of the + and - are crossed.
TemjinX2 is offline  
Reply With Quote
Old 12-18-2009, 12:45 AM
  #14
MBWorld Fanatic!
 
Join Date: Jul 2008
Posts: 6,742
Thanked 27 Times in 25 Posts
2014 C350 Sport Sedan & 2015 Kia Optima Hybrid EX
Temjin, some people have errors even with 55w kits.
LILBENZ230 is offline  
Reply With Quote
Old 12-18-2009, 03:25 PM
  #15
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
I think there are two issues being mixed up here guys. So just to set things straight, here in my opinion are the common issues with HID's:

1. Error message on screen. Headlights light up and after a second shut off (and when I say shut off I mean completely turn off...not blink):
This is caused by the MB computer which detects a lower wattage HID (as opposed to the 55W that it expects) and shuts off the lights because it thinks that the bulbs have blown. This only happens to people who install 35W bulbs. There are however a few exceptions liek the 35W VVME HID's which don't produce the error (maybe because a built in error eliminator)

2. Blinking of HID lights (Blinking: The constant instantaneous switching on and off of the HID lights):
This is caused either by bad installation of the HID's (crossing negative and positive terminals, no proper grounding etc) or by defective ballasts/bulbs. This issue can be seen in both 35W or 55W HID's.

For people in Canada, there is an additional aspect to consider. During the day, the daytime running lights (DRL's) will turn on which is basically the low-beam headlight operating on lower power, therefore causing it to be dimmer. So, even with error eliminators/the special VVME 35W kit of any 55W kit, the lower power available will cause the headlights to not turn on and produce an error during the day. This can only be fixed by setting Xenon = present in the cars computer (can be done only by your dealer). So while the yanks can get away without Xenon = present (by using error eliminators etc), us canucks cant because while the error eliminators will remove the error at night, the DRL's will still produce errors.

Hope this helps!
jcnash is offline  
Reply With Quote
Old 12-18-2009, 04:54 PM
  #16
Member
Thread Starter
 
dj_rzn's Avatar
 
Join Date: May 2009
Location: Romania - Iasi
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes c220
Well, when i open the lights, it's a error on my computer and also they start blinking (they blink, they are not turning off permanently), does a error code eliminator will work , or not? This is what i want to know, the xenon kit it's installed correctly.
dj_rzn is offline  
Reply With Quote
Old 12-18-2009, 05:47 PM
  #17
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
Originally Posted by dj_rzn View Post
Well, when i open the lights, it's a error on my computer and also they start blinking (they blink, they are not turning off permanently), does a error code eliminator will work , or not? This is what i want to know, the xenon kit it's installed correctly.
The error should turn off your lights...not make them blink.

What does your error say?
jcnash is offline  
Reply With Quote
Old 12-18-2009, 05:51 PM
  #18
Member
Thread Starter
 
dj_rzn's Avatar
 
Join Date: May 2009
Location: Romania - Iasi
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes c220
Check low beam, R
or something like that is the error. They blink sometimes, or they turn off for 5 seconds and then came back. It's random.
dj_rzn is offline  
Reply With Quote
Old 12-18-2009, 05:58 PM
  #19
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
So only your right headlight flashes?
jcnash is offline  
Reply With Quote
Old 12-18-2009, 06:19 PM
  #20
Member
Thread Starter
 
dj_rzn's Avatar
 
Join Date: May 2009
Location: Romania - Iasi
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes c220
No, both of them, and sometimes the error appears just for right, or sometime for both.. it depends.
dj_rzn is offline  
Reply With Quote
Old 12-18-2009, 08:00 PM
  #21
Junior Member
 
Join Date: Jan 2007
Location: S.F., Cali.
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
'05 C230K Sport
Originally Posted by dj_rzn View Post
Well, when i open the lights, it's a error on my computer and also they start blinking (they blink, they are not turning off permanently), does a error code eliminator will work , or not? This is what i want to know, the xenon kit it's installed correctly.
Same here with a 55w kit from DDM.

My other kit is a 35w and just flickered the right light. Not blinking just a slight flickering (no errorrs) Using the error canceler's solved the problem.
65coupei6 is offline  
Reply With Quote
Old 12-18-2009, 11:00 PM
  #22
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
Originally Posted by dj_rzn View Post
No, both of them, and sometimes the error appears just for right, or sometime for both.. it depends.
I guess the only thing you can do now is to try the error cancelers or set Xenon present. One of those should definitely fix the problem.
jcnash is offline  
Reply With Quote
Old 12-18-2009, 11:23 PM
  #23
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
Originally Posted by 65coupei6 View Post
Same here with a 55w kit from DDM.

My other kit is a 35w and just flickered the right light. Not blinking just a slight flickering (no errorrs) Using the error canceler's solved the problem.
Do you have the DDM Apexcone/Rator kit or the digital kit? Also do you have Xenon set to present?
jcnash is offline  
Reply With Quote
Old 12-19-2009, 12:45 AM
  #24
Member
 
Join Date: Jun 2009
Location: vancouver, bc
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
2005 c320 4matic
xenon = present resolves all problems

im sure your dealer did not do it correctly, if at all
aac85 is offline  
Reply With Quote
Old 12-19-2009, 12:47 AM
  #25
MBWorld Fanatic!
 
jcnash's Avatar
 
Join Date: May 2009
Location: Toronto, Canada
Posts: 1,098
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes Benz C230 Coupe
Originally Posted by aac85 View Post
xenon = present resolves all problems

im sure your dealer did not do it correctly, if at all
hey aac85,

you didnt get any error eliminators didtcha? You still using the 55W VVME's?
jcnash is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trinitony
W210 AMG
8
11-02-2015 08:19 PM
E55AMG05
W211 AMG
1
09-30-2015 10:57 AM
S2K750
C Class (W205)
6
09-30-2015 01:29 AM
cybertronicify
S-Class (W220)
5
09-26-2015 04:53 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:42 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: