No power no cranking no dashlights Car wont start help - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
No power no cranking no dashlights Car wont start help > No power no cranking no dashlights Car wont start help
Notices
C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

No power no cranking no dashlights Car wont start help

Reply

 
 
Old 04-25-2010, 04:04 PM
  #1
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
NA
No power no cranking no dashlights Car wont start help

Hey everyone,

As the title says, my car won't start. When I put the smartkey in the ignition nothing happens, no beeps like usual or the dashboard lights going up. The remote lock/unlock and trunk pop don't make a noise either anymore, the car is just plain dead. It was working 100% fine just a few weeks ago before I put it into storage.

Did a fuse pop? Is some security lock active on the car? What gives? Neither of my keys work. Car doesn't respond to anything, and I can't turn the smartkey since there doesnt seem to be power.

It's not the battery since I charged it full today. It was a new battery bought in February.
AcesHigh is offline  
Reply With Quote
Old 04-25-2010, 07:13 PM
  #2
Senior Member
 
Join Date: Feb 2007
Location: Plano, Texas
Posts: 341
Thanks: 0
Thanked 2 Times in 1 Post
2012 Gmc Canyon v8, Looking for a new MB toy
when you open the door, do the lights in the cluster (odometer) light up to say what the mileage is, or do the dome lights come on? Also, when you press the lock/unlock buttons on the key, does the small red LED light flash?

Also, what year and model is your car?
Racin_fool is offline  
Reply With Quote
Old 06-12-2010, 02:31 PM
  #3
Newbie
 
Join Date: Jun 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
e430
im having the same exact issue when the door open the dash lights up but key wont turn or nothing works can some one pelz hellllllllllllp
mzjuicey is offline  
Reply With Quote
Old 06-12-2010, 03:55 PM
  #4
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA And RVA
Posts: 5,273
Thanks: 0
Thanked 16 Times in 16 Posts
THE C350
Originally Posted by mzjuicey View Post
im having the same exact issue when the door open the dash lights up but key wont turn or nothing works can some one pelz hellllllllllllp
eis
samaritrey is offline  
Reply With Quote
Old 06-12-2010, 03:58 PM
  #5
Newbie
 
Join Date: Jun 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
e430
whats that and were is it located n e way i can fix it myself
mzjuicey is offline  
Reply With Quote
Old 06-12-2010, 04:03 PM
  #6
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA And RVA
Posts: 5,273
Thanks: 0
Thanked 16 Times in 16 Posts
THE C350
Originally Posted by mzjuicey View Post
whats that and were is it located n e way i can fix it myself
EIS is the electronic ignition system or something like that.
it is what you put the key in it does a few things powers the key reads the key and i think sends the signal to the computer to start the car but that might actually be another computer but whatever. It is right where the key goes in so just one panel usually and you can see it. the problem is that they are very expensive and have to be coded and new keys. i would do some research on eis failures but it sounds like one to me. sorry for the bad news. keep us posted.
samaritrey is offline  
Reply With Quote
Old 06-12-2010, 04:20 PM
  #7
Newbie
 
Join Date: Jun 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
e430
ok thanks
mzjuicey is offline  
Reply With Quote
Old 06-12-2010, 07:05 PM
  #8
MBWorld Fanatic!
 
Join Date: Nov 2001
Location: Huntington Beach, Ca.
Posts: 5,269
Thanks: 0
Thanked 45 Times in 42 Posts
'17 Jaguar XF
Battery died.
mleskovar is offline  
Reply With Quote
Old 06-14-2010, 10:16 PM
  #9
Newbie
 
Join Date: Apr 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2005 C240 4Matic
Update?

Is there any update on this? I'm having the same exact problem. Key won't turn the only thing happening is the tow alarm light blinks. (2005 C240 4matic)
hail7783 is offline  
Reply With Quote
Old 02-22-2011, 12:36 PM
  #10
Senior Member
 
Join Date: Jun 2008
Location: Germany
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
c200k
I found this in the search and possibly related to my problem-

2000 German W203, m111 C200k. *Battery good, confirmed good, happens with all three keys. All batteries changed in the keys.

It did this previously on occasion, getting worse when the weather is cold-

Car doesn't open with the remote. Sometimes just go back and forth and eventually, starts responding, though not 100%, meaning the second click doesn't open the rest of the doors, for instance. Eventually works. However, not this time.

When in this mode, car doesn't start. The display lights, BUT the odometer portion just reads in all dashes "--------" just like that. Put key in, nothing. Along the way, it would finally recognize the key and start, or the solenoid in the ignition switch would lock and unlock repeatedly for about 10-20 seconds, then finally the odometer starts displaying numbers again and the car starts.

Seemed to also be able to "turn on" the computer by turning the headlights on with the driver's door open to engage the alarm for the lights on. However, it's extremely cold out here now and now the car is dead...

Any ideas on diagnostics? One of the issues are mechanics here (former east Germany) are one of two things: completely incompetent or absolute ripoff artists.

Last edited by sknight; 02-22-2011 at 01:51 PM.
sknight is offline  
Reply With Quote
Old 12-08-2011, 12:57 PM
  #11
Newbie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
C-320
Hi,

My car C320 has the same problem " When I put the smartkey in the ignition nothing happens, no beeps like usual or the dashboard lights going up. The remote lock/unlock and trunk pop don't make a noise either anymore, the car is just plain dead"

Do you know what is the problem? and how to fix it?

Thanks




_____________________
Originally Posted by AcesHigh View Post
Hey everyone,

As the title says, my car won't start. When I put the smartkey in the ignition nothing happens, no beeps like usual or the dashboard lights going up. The remote lock/unlock and trunk pop don't make a noise either anymore, the car is just plain dead. It was working 100% fine just a few weeks ago before I put it into storage.

Did a fuse pop? Is some security lock active on the car? What gives? Neither of my keys work. Car doesn't respond to anything, and I can't turn the smartkey since there doesnt seem to be power.

It's not the battery since I charged it full today. It was a new battery bought in February.
Banguyen is offline  
Reply With Quote
Old 12-08-2011, 02:25 PM
  #12
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,843
Thanked 54 Times in 47 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
This Sounds like an EIS (electronic ignition switch) as Trey says, or a SAM.

First check fuses 31, 52, 57 for start enable. Fuse 52 has been uprated from 15 to 20 amps.
Good luck!
Glyn M Ruck is offline  
Reply With Quote
Old 12-08-2011, 06:00 PM
  #13
Newbie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
C-320
Thank you a lot for your help.

I found out that the battery was dead because the dome light did not turn off itself automaticly after the back door was opened. After I changed the battery the ESP light is on. How can I turn it off?

Again thanks for your help.

________________________


Originally Posted by Glyn M Ruck View Post
This Sounds like an EIS (electronic ignition switch) as Trey says, or a SAM.

First check fuses 31, 52, 57 for start enable. Fuse 52 has been uprated from 15 to 20 amps.
Good luck!
Banguyen is offline  
Reply With Quote
Old 12-08-2011, 06:24 PM
  #14
Senior Member
 
contact148's Avatar
 
Join Date: Jan 2010
Location: Canada
Posts: 434
Thanks: 0
Thanked 1 Time in 1 Post
2003 c240 4matic wagon
turn the steering wheel all the way both ways

you will also have to sync your sunroof and windows (in your manual)

Originally Posted by Banguyen View Post
Thank you a lot for your help.

I found out that the battery was dead because the dome light did not turn off itself automaticly after the back door was opened. After I changed the battery the ESP light is on. How can I turn it off?

Again thanks for your help.

________________________
contact148 is offline  
Reply With Quote
Old 12-08-2011, 07:08 PM
  #15
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,843
Thanked 54 Times in 47 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
You can try turning steering lock to lock 5 times to reset the steering angle sensor. Otherwise cancel with an OBDII scanner.
Glyn M Ruck is offline  
Reply With Quote
Old 12-09-2011, 05:19 PM
  #16
Newbie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
C-320
Thank you. I followed your instructions, the problems solved\.

_________________
Originally Posted by Glyn M Ruck View Post
You can try turning steering lock to lock 5 times to reset the steering angle sensor. Otherwise cancel with an OBDII scanner.
Banguyen is offline  
Reply With Quote
Old 12-09-2011, 05:44 PM
  #17
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,843
Thanked 54 Times in 47 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Great
Glyn M Ruck is offline  
Reply With Quote
Old 02-02-2016, 09:34 PM
  #18
Newbie
 
Join Date: Feb 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2001 e430
I have a 2001 e430 and the car stopped starting a few weeks ago, the tow truck driver, broke the eis so it turns with any key or even a screw driver, he also broke the shifter and it now shifts into any gear without any key in the eis or brake pressed. etc. i got a brand new battery also before trying anything else. the dealer says you cant use used parts so they will be of zero help for this issue.

At first I didnt know that the parts were married as they are so I got a known good key, eis, tried them and still nothing so then got the ecm still nothing. I also was investigating the brake light switch and disconnected those two connectors to it and tried to start the car seeing what would happen. the dash came up with abs, esp, and bas errors, I plugged them back in and they went away. I read you need the matched shifter as well so I got that yesterday.

long story short after replacing the key, eis, and ecm i checked the fuses (all seemed good and doubled checked that today) and now no dash lights, no blower motor fan even though the climate control lights up, you can select the temp but not fan speed as i could before even without the car starting and a non matched ecm with eis and key. what could be wrong with the car now where the dash doesnt work, the climate control doesnt work, the car still doesnt start. Its worse off than when i started ?!?!?!?!?
polygaryd is offline  
Reply With Quote
Old 08-29-2016, 10:12 PM
  #19
Newbie
 
Join Date: Feb 2014
Posts: 6
Thanked 0 Times in 0 Posts
2010 ML 350 4Matic
W164 2010 ML 350 4matic

Same problem when the car is left outside in the sun. Its 90F outside about about 110F inside the car.

no dash lights, windows don't work. Couldn't jump start either.
bevin0708 is offline  
Reply With Quote
Old 06-12-2017, 11:20 PM
  #20
Newbie
 
Join Date: Jun 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
2008 Mercedes Benz E350
Dead battery-​​​​​​​no lights, keys didn't work

Hi, I was wondering if you ever solved your problem and if so what was it? I'm having a nearly identical issue.... thx


Originally Posted by AcesHigh View Post
Hey everyone,

As the title says, my car won't start. When I put the smartkey in the ignition nothing happens, no beeps like usual or the dashboard lights going up. The remote lock/unlock and trunk pop don't make a noise either anymore, the car is just plain dead. It was working 100% fine just a few weeks ago before I put it into storage.

Did a fuse pop? Is some security lock active on the car? What gives? Neither of my keys work. Car doesn't respond to anything, and I can't turn the smartkey since there doesnt seem to be power.

It's not the battery since I charged it full today. It was a new battery bought in February.
AdDad is offline  
Reply With Quote
Old 06-12-2017, 11:36 PM
  #21
Newbie
 
Join Date: Jun 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
2008 Mercedes Benz E350
Same problem as this guy, and I'm hoping you can help

Originally Posted by Racin_fool View Post
when you open the door, do the lights in the cluster (odometer) light up to say what the mileage is, or do the dome lights come on? Also, when you press the lock/unlock buttons on the key, does the small red LED light flash?

Also, what year and model is your car?
I don't believe he ever replied, but I'd like to jump in if possible....

2008 e350 sport
1. battery drained I believe, but not 100% sure... due to door being left open (or so I assume?) Now won't recognize keys and no other power at all
2. I have interior lights and initial dash display of odometer (mileage starts as ----- and then the actual number appears)
3. Some headlight functionality
4. Exterior trunk lock release works, not interior
5. Battery was charged and reading 12.48 (I'm not positive the battery did drain, but a hunch)
6. Key FOB (both) have red lights and were working perfectly prior to this. I removed and re-inserted the battery to be sure.
7. May or may not be worth mentioning (also might be in my head).... It does seem that when I insert the key in the ignition, I hear the faintest tiny sound of power to a speaker.
8. I've pulled and checked every fuse, but currently not skilled or knowledgeable enough to test each circuit or relay

I'm really desperate for some guidance on this for a lot of single dad issues. I would sincerely appreciate any help you might be able to offer.
AdDad is offline  
Reply With Quote
Old 07-28-2017, 10:37 AM
  #22
Newbie
 
Join Date: Jul 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
MB E 350 Coupe 2010
hi

this is what jusr happened to my car ... any advice how can i solve the problem??
Originally Posted by bevin0708 View Post
Same problem when the car is left outside in the sun. Its 90F outside about about 110F inside the car.

no dash lights, windows don't work. Couldn't jump start either.
Asim Khalil is offline  
Reply With Quote
Old 07-28-2017, 11:06 AM
  #23
Newbie
 
Join Date: Jul 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
MB E 350 Coupe 2010
Originally Posted by Asim Khalil View Post
this is what jusr happened to my car ... any advice how can i solve the problem??
no power no lights windows locks even remote not working
Asim Khalil is offline  
Reply With Quote
Old 07-31-2017, 01:50 AM
  #24
Member
 
Join Date: Oct 2012
Location: Hollywood, CA
Posts: 223
Thanks: 0
Thanked 9 Times in 8 Posts
W209, W124
Dead car battery?

You're gonna have to give more than 27 words worth of details to get a good answer.
MacVidMB-V8 is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dasauto
Mercedes Vehicles
9
11-24-2015 09:45 PM
decato_P30
Mercedes Vehicles
15
10-12-2015 10:18 AM
rholmond
S-Class (W126)
3
09-07-2015 04:20 PM
Luis Flores
E-Class (W211)
5
09-03-2015 08:24 AM
vcci
W212 AMG
2
08-31-2015 02:10 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:40 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: