Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Engine light came on and dealer replaced magnets???  What are they talking about? >

Engine light came on and dealer replaced magnets??? What are they talking about?

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Engine light came on and dealer replaced magnets??? What are they talking about?

 
Old 06-04-2012, 04:57 PM
  #26  
Member
 
Join Date: Apr 2008
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
08 GL450, former 83 300D, 97 C230, 08 c300 luxury, 92 500SL, 93 400E
My car was in the shop a month ago for a CEL, and I was told the same - bad seal. Seriously? Well, I haven't touched the filter housing, and the car is CPO with 24k, but they wanted me to pay for it. I declined, and they ate it.

Now, mind you, I've had some rough running occasionally from this motor, but I chalked it up to maybe bad gas or something. Today, I tried to crank, and it didn't want to, and then it did, but started bucking and chugging, and then flat out stalled. I cranked it again, and everything's been fine since, with no CEL.

Called my SA, and he thinks the cam pos sensor is "on the way out." I suspected cam magnets from the last CEL, but I also didn't know there was an actual RECALL on them - is there? The car is OOW in 4 months, so I need to get action soon.
will_w204 is offline  
Old 06-05-2012, 10:25 AM
  #27  
Member
 
Join Date: Apr 2009
Posts: 198
Thanks: 0
Thanked 0 Times in 0 Posts
C300, ML 320, 190E
Is there a TSB number for this?
sirics is offline  
Old 06-06-2012, 02:05 PM
  #28  
MBWorld Fanatic!
 
MBRedux's Avatar
 
Join Date: Oct 2009
Posts: 2,072
Thanks: 0
Thanked 1 Time in 1 Post
Nissan GT-R BE / '12 Ducati-1199 Panigale S / '12 C300-4M Loaded/GLK350-4M Loaded
Camshaft/Crankshaft position sensors fail for all kinds of reasons, mainly the coil capacitance drops over time and it loses magnetic strength .. Very common issue.
MBRedux is offline  
Old 02-16-2018, 08:44 PM
  #29  
Newbie
 
Join Date: Feb 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes gl450
Camshaft magnet

Originally Posted by white_glass_top View Post
I just left the dealership today, had to drop mine off for the CEL, come to find out that this problem is an actual recall from Mercedes-Benz. So for those not tracking this, might wanna get yours replaced. the Cam Sensor Magnets, that is.
Hi Iím having the same problem, the engine light came on and the dealer told me that the magnets need to replaced all 4. I have a GL450 they didnít mention anything to me about a recall. I wondering is it only for the series you have or the year you had. Can you please respond back, thanks
Ashton3 is offline  
Old 02-18-2018, 03:55 PM
  #30  
MBWorld Fanatic!
 
Join Date: Jun 2011
Location: Canada
Posts: 2,112
Thanked 144 Times in 132 Posts
W204
OP what year is your car?
superangrypenguin is offline  
Old 01-08-2019, 01:23 PM
  #31  
Newbie
 
Join Date: Jan 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2013 GL550
Just got mine back

Originally Posted by Ashton3 View Post
Hi Iím having the same problem, the engine light came on and the dealer told me that the magnets need to replaced all 4. I have a GL450 they didnít mention anything to me about a recall. I wondering is it only for the series you have or the year you had. Can you please respond back, thanks
I have a 2013 GL550 and and couple months ago a check engine light came on. I took it in the next day to be told that cam magnets failed and got oil all over fuel rails, wiring harness and ECU (thank God all still under warranty). I was then told that the wiring harness has to be remade in Germany and would take 3 MONTHS to come in. After 3 months I got the truck back but am concerned that this ou s a problem that could reoccur again once out of warranty. There was no mention of "new" parts to alleviate this problem in the future l. AND I have the dealer installed Renntech upgrade! Thoughts???
Sean Daveiga is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Engine light came on and dealer replaced magnets??? What are they talking about?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: