Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
window auto up doesn't work >

window auto up doesn't work

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI
Old 06-09-2015, 12:49 PM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Exterior Guides
Print Wikipost

window auto up doesn't work

 
Old 06-22-2010, 08:35 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2008 C300
window auto up doesn't work

The auto up feature on the front passenger's door doesn't work, if you auto up it stops as soon as you let go, to get the window up you have to hold the button up, then when the window reaches the top, and you let go of the button, the window comes back down about an inch on its own, you then have to close it again. This happens with the switch on the passenger door and the main switch controls on the drivers door. It's a 2008 C300.
jhromy is offline  
Old 06-22-2010, 08:57 AM
  #2  
Member
 
Join Date: Dec 2001
Location: NY
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
C350
Try to raise the window by holding the button up on the "first setting", i.e. don't lift it all the way up. Once it's closed, then lift it all the way up and hold it there for 10 seconds. Then try again, auto down and then auto up.
Otherwise, dealer.
nickm is offline  
Old 06-22-2010, 09:11 AM
  #3  
MBWorld Fanatic!
 
snarlingchicken's Avatar
 
Join Date: Nov 2009
Location: Irvine, CA
Posts: 1,348
Likes: 0
Received 0 Likes on 0 Posts
2009 C350
I had the same problem. Go into your car. Turn your car on and pull up all 4 window tabs and hold them for about 10 seconds. That should reset the windows. No need to take it to the dealer.
snarlingchicken is offline  
Old 06-22-2010, 09:49 AM
  #4  
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2008 C300
cool thanks ill try that today when i get home from work
jhromy is offline  
Old 06-22-2010, 10:21 AM
  #5  
Senior Member
 
Join Date: Jan 2009
Location: Philippines/California, USA
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
W204 C280
I had the same problem with my car too. Took it to the dealer and they just did exactly what snarlingchicken did. Solved the problem, the system just needed to be reset apparently. They said sometimes if you get something snagged in your window, it would cause the problem. Though I don't really recall anything getting stuck in my window.
albert101 is offline  
Old 06-22-2010, 12:17 PM
  #6  
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,108
Likes: 0
Received 3 Likes on 3 Posts
2012 C250 Coupe
This has happened to me as well. In fact, about 3 times on the same window in about a month. I guess the third time was the charm, no problems with it for about 6 months now...

I fixed it by the methods suggested above.
jctevere is offline  
Old 06-22-2010, 01:09 PM
  #7  
Member
 
Join Date: Mar 2010
Location: joisey
Posts: 242
Likes: 0
Received 0 Likes on 0 Posts
08 w204
i had the same problem too. it usually happens if you hold the button after the window is down/up...found my solution in the owner's manual
kwikblkmax is offline  
Old 06-22-2010, 02:42 PM
  #8  
MBWorld Fanatic!
 
AkaSigFreak's Avatar
 
Join Date: Dec 2007
Location: Orlando, Florida
Posts: 3,058
Received 40 Likes on 36 Posts
E350 Sport/ML350RWD
This problem may also occur with the sunroof. Just a heads up.
AkaSigFreak is offline  
Old 06-23-2010, 08:09 AM
  #9  
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2008 C300
alright thanks guys it worked
jhromy is offline  
Old 06-23-2010, 08:18 AM
  #10  
MBWorld Fanatic!
 
snarlingchicken's Avatar
 
Join Date: Nov 2009
Location: Irvine, CA
Posts: 1,348
Likes: 0
Received 0 Likes on 0 Posts
2009 C350
Glad we could help
snarlingchicken is offline  
Old 08-10-2010, 06:06 PM
  #11  
Member
 
ROCK1965's Avatar
 
Join Date: Sep 2004
Posts: 125
Received 0 Likes on 0 Posts
08 C300
trying the fix and can't seem to get it to work on the driver window. Does the car need to be in Accessory mode or completely on or does it not matter?
ROCK1965 is offline  
Old 08-10-2010, 07:24 PM
  #12  
Member
 
ROCK1965's Avatar
 
Join Date: Sep 2004
Posts: 125
Received 0 Likes on 0 Posts
08 C300
OK. I tried the reset option here and after about 30 seconds, while I am holding all of the windows in the up position, the drivers windows go back down about 1 inch, while still holding them up. I didn't release anything.

I also tested the auto up with the remote and all windows go up but the driver window still goes back down an inch and wont let me use the remote to close it. It continues to go back down an inch.

Is this a dealer issue now or does anyone have any suggestions?
ROCK1965 is offline  
Old 08-10-2010, 08:17 PM
  #13  
Senior Member
 
Join Date: Jan 2009
Location: Philippines/California, USA
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
W204 C280
rock, take it to the dealer already. They'll try a reset on your software. Hopefully that should solve your problem.
albert101 is offline  
Old 08-10-2010, 08:55 PM
  #14  
Senior Member
 
Join Date: Jun 2009
Location: Inland Empire, CA
Posts: 397
Likes: 0
Received 0 Likes on 0 Posts
C300, 330i, MDX
Originally Posted by AkaSigFreak View Post
This problem may also occur with the sunroof. Just a heads up.
Sorry, not intended to hijack the thread. However, how do you reset the sunroof?
C300S 6MT is offline  
Old 08-15-2010, 01:35 PM
  #15  
Member
 
ROCK1965's Avatar
 
Join Date: Sep 2004
Posts: 125
Received 0 Likes on 0 Posts
08 C300
Originally Posted by albert101 View Post
rock, take it to the dealer already. They'll try a reset on your software. Hopefully that should solve your problem.
Amazingly it started to work!!! not sure why but it did. Had an appointment for that and the A/C smell at the dealership and by time the appointment came, it worked. Weird but good.
ROCK1965 is offline  
Old 08-15-2010, 05:21 PM
  #16  
Newbie
 
Join Date: May 2010
Location: Long Island, NY
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
2009 C300
Wink

I'm a lurker on this board. Glad because this thread solved the one problem I was having with my C300. Thanks,
wkramer is offline  
Old 08-16-2010, 02:19 PM
  #17  
Member
 
Join Date: Sep 2008
Posts: 210
Likes: 0
Received 0 Likes on 0 Posts
2009 C300 Sport 4Matic, 1999 Jeep Grand Cherokee Laredo
I had the same issue for the past few months, and haven't had time to take it in. Started with the passenger window, then a few weeks ago, drivers side started doing the same thing. I had tried the solution you guys had posted several times with no luck. Then, on the way home from work on Friday, I was stuck in traffic, and I tried again. This time, I didn't hold the buttons all the way (meaning, if you pull up on the control all the way, it clicks and you initiate the auto up), this time, I just held them up to the point right before it clicks. And now they are both fixed! Thanks for the tip, saved me a trip to the dealer.
killacam7479 is offline  
Old 07-10-2012, 08:44 PM
  #18  
Newbie
 
Join Date: Jun 2010
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
ML350
I have to dbl check the owner's manual about how this could happen. I have taken my car in for this issue. I had it calibrated (reset) by the dealer on Sat and it started doing the same thing again on Sunday afternoon. The dealer is saying that this is caused by tree sap. If German engineering is impacted so easily by tree sap, I will continue to remain disappointed in my 2008 C. I have had issues with the brakes 2months after I bought the car. The sun roof mechanism has been changed twice, and headlight switch has to be replaced (took 2 trips to the dealer for that one). And the driver seat shows signs of cracking in the MBZ Leather. All of this and I don't even have 24K on the car yet. Sorry for the rant.
mjavadi is offline  
Old 07-10-2012, 09:03 PM
  #19  
Super Member
 
Domm's Avatar
 
Join Date: Mar 2012
Location: San Francisco
Posts: 591
Likes: 0
Received 0 Likes on 0 Posts
'08 Mercedes C300
Originally Posted by mjavadi View Post
I have to dbl check the owner's manual about how this could happen. I have taken my car in for this issue. I had it calibrated (reset) by the dealer on Sat and it started doing the same thing again on Sunday afternoon. The dealer is saying that this is caused by tree sap. If German engineering is impacted so easily by tree sap, I will continue to remain disappointed in my 2008 C. I have had issues with the brakes 2months after I bought the car. The sun roof mechanism has been changed twice, and headlight switch has to be replaced (took 2 trips to the dealer for that one). And the driver seat shows signs of cracking in the MBZ Leather. All of this and I don't even have 24K on the car yet. Sorry for the rant.
How have you been maintaining your car? Have you been washing/waxing it frequently and clay barring it if it is constantly covered in tree sap? Your car must encounter a large amount of tree sap for it to cause resistance when opening your windows.

What was wrong with your headlight switch?

Have you been conditioning your leather seats? Leather is delicate and requires routine cleaning/conditioning to prevent cracking.

Last edited by Domm; 07-10-2012 at 09:05 PM.
Domm is offline  
Old 07-10-2012, 10:08 PM
  #20  
Newbie
 
Join Date: Jun 2010
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
ML350
I have been maintaining the car very well and I don't think (unlike the dealer's claim) there is any sap. I wash the car every two weeks, most often every week. It gets waxed once a month. And I put conditioner on the seats. I just think the quality is not what it could be. It does not seem to be a car that you can keep past 4-5 years.
mjavadi is offline  
Old 07-10-2012, 11:48 PM
  #21  
Member
 
JasonHu's Avatar
 
Join Date: Nov 2001
Location: Chicago, IL
Posts: 173
Likes: 0
Received 0 Likes on 0 Posts
2012 C300 4MATIC, 2014 Tesla Model S P85
Originally Posted by mjavadi View Post
I have been maintaining the car very well and I don't think (unlike the dealer's claim) there is any sap. I wash the car every two weeks, most often every week. It gets waxed once a month. And I put conditioner on the seats. I just think the quality is not what it could be. It does not seem to be a car that you can keep past 4-5 years.
It's a very common thing to happen. It happened as soon as I drove my 2012 off the lot. It miraculously fixed itself for me after a few days.
JasonHu is offline  
Old 08-19-2012, 05:38 AM
  #22  
Newbie
 
Stephen Pavlina's Avatar
 
Join Date: Aug 2012
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2008 Mercedes Benz C200
Thanks guys. Had the same problem after going to my MB dealer to replace the battery. Was about to go back to the dealership but after seeing this post tried it out and it works fine.
Stephen Pavlina is offline  
Old 08-27-2012, 11:39 PM
  #23  
Newbie
 
Join Date: Apr 2012
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Great Post

I was able to resolve this issue using this post. GREAT WORK GUYS
mtsl0020 is offline  
Old 03-31-2014, 05:38 PM
  #24  
Senior Member
 
Cillys's Avatar
 
Join Date: Apr 2013
Location: Los Angeles, CA
Posts: 274
Likes: 0
Received 0 Likes on 0 Posts
2011 C300 Sport 4MATIC
Thanks Guys! Worked for me as well.
Cillys is offline  
Old 05-24-2014, 11:33 PM
  #25  
Junior Member
 
Join Date: Mar 2014
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 4MATIC
Originally Posted by ROCK1965 View Post
OK. I tried the reset option here and after about 30 seconds, while I am holding all of the windows in the up position, the drivers windows go back down about 1 inch, while still holding them up. I didn't release anything.

I also tested the auto up with the remote and all windows go up but the driver window still goes back down an inch and wont let me use the remote to close it. It continues to go back down an inch.

Is this a dealer issue now or does anyone have any suggestions?
Did you ever resolve the issue of it going down about an inch? I am having the same problem, auto up doesnt work on driver window and once it hits the top while holding the up button I release and it goes down a bit, I have to pull it up to close it completely again...
ign92 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: window auto up doesn't work


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: