Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
iPhone 5 & answering calls via bluetooth >

iPhone 5 & answering calls via bluetooth

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

iPhone 5 & answering calls via bluetooth

 
Old 10-10-2012, 03:40 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2012
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
250 CDI C204
iPhone 5 & answering calls via bluetooth

Hi

I have just updated from an iPhone 3GS to an iPhone 5 and have noticed that there is now a delay in the microphone switching on when you answer phone calls using a blue-tooth connection. In fact when the call comes in comand sees the call and asks to accept or reject as expected. If you accept the call a small "microphone off" symbol shows on the comand screen for about 3-5 seconds and then disappears. During the period the symbol is showing the caller can not here you.

Has anyone else seen this and even better have a fix? I have spoken to my dealer and he says its either the phone or IOS6 not comand. I have a 2011 C204.

regards

john
dawsonjw is offline  
Old 10-11-2012, 12:13 AM
  #2  
Member
 
jetflyboy's Avatar
 
Join Date: Mar 2012
Location: New York & Louisiana
Posts: 152
Likes: 0
Received 0 Likes on 0 Posts
2010 C300 Sport
Hey John,

I have an iPhone 5 as well, moving up from the iPhone 4.
I have not had any of the issues you mentioned. I had no difference at all in the functions from the previous phone. I will pay special attention tomorrow, and if I see these issues I will re-post again.
jetflyboy is offline  
Old 10-11-2012, 09:40 AM
  #3  
Junior Member
 
Join Date: Jun 2012
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
C350
I've had iPhone4, 4s, and now 5 all connected and I never noticed a difference between any of them...
ElJayBird is offline  
Old 10-11-2012, 10:12 AM
  #4  
Member
 
jetflyboy's Avatar
 
Join Date: Mar 2012
Location: New York & Louisiana
Posts: 152
Likes: 0
Received 0 Likes on 0 Posts
2010 C300 Sport
I checked this morning, and I had no issues. Perhaps it will help if you delete your phone altogether, give your phone a different name and then pair it.

I don't know if that will solve the issue, but it seems worth a try.
jetflyboy is offline  
Old 10-13-2012, 08:29 PM
  #5  
Newbie
Thread Starter
 
Join Date: Apr 2012
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
250 CDI C204
Hi

thanks I have tried that. But for some reason the handsfree mic always turns off for about 3-4 seconds and back on again for all incoming calls

cheers

john
dawsonjw is offline  
Old 10-14-2012, 03:17 PM
  #6  
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,108
Likes: 0
Received 3 Likes on 3 Posts
2012 C250 Coupe
I have this same issue, very annoying! I have a 2012 C250 Coupe and I previously had a iPhone 4 (that was also running on iOS 6) and it did not have this problem.

However, with the new iPhone 5 I have this problem. So maybe its something with the iPhone 5 that has this lag/delay. I'm hoping an update comes soon to fix these bugs. Sometimes the bluetooth A2DP streaming is a little bit buggy too and the noise cuts in and out occasionally.

I do have the say that the Text Message function on comand works well - but kind of silly that the comand system won't let you send any, so reading them is kind of pointless. Interesting though that when you voice prompt "text message" the system says that function is currently unavailable, but comand is programed to recognize that function. But there is a slight work around for the iPhone 5. I am able to hold down the home button in my pocket and Siri comes over the car speakers and listens through the car microphone. You can tell Siri to send a text message.
jctevere is offline  
Old 10-22-2012, 08:21 PM
  #7  
Newbie
 
Join Date: Oct 2012
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2016 GLE400
I also have this problem

I have a 2012 ML350 BlueTEC and an iPhone 5. For incoming calls, the in-car microphone is muted. I haven't noticed whether it lasts for 3-5 seconds or not... I end up manually unmuting the microphone.
carter3d is offline  
Old 10-22-2012, 10:02 PM
  #8  
Newbie
 
Join Date: Oct 2012
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
audi
Perhaps it will help if you delete your phone altogether
williamcurti is offline  
Old 10-22-2012, 11:36 PM
  #9  
MBWorld Fanatic!
 
Join Date: Apr 2012
Location: Calgary
Posts: 1,370
Likes: 0
Received 0 Likes on 0 Posts
C63 AMG
I had many phones such as galaxy s2, htc one x, iphone 4, iphone 5 but none of them has the symptom you are having.
snowmuch is offline  
Old 10-23-2012, 01:06 PM
  #10  
Newbie
 
Join Date: Oct 2012
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2016 GLE400
Tested again today

I had some time to mess around with it again today. First, I deleted the phone from the system and re-paired it. Then, using my home phone, I called my iPhone 5. Same issue - microphone was muted. This time I waited for a bit, and as stated earlier by another user, the microphone un-muted itself after about 5 seconds.
carter3d is offline  
Old 10-30-2012, 12:59 AM
  #11  
Newbie
 
Join Date: Oct 2012
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2012 E350
Bluetooth muting problem

John -

YES! I have this exact same problem and it is very annoying!!! Is there a setting that needs to be changed or is this a bug????
Robyn C is offline  
Old 10-30-2012, 05:46 AM
  #12  
Member
 
Kaewen's Avatar
 
Join Date: Aug 2011
Location: Brunei Darussalam
Posts: 216
Likes: 0
Received 2 Likes on 2 Posts
GLC250 Coupe
I have this issue too. but its a trade off since now you can read your SMS on your command online screen.
Kaewen is offline  
Old 10-30-2012, 12:27 PM
  #13  
Member
 
Join Date: Sep 2009
Location: Vancouver, BC
Posts: 155
Received 6 Likes on 5 Posts
2015 E63S
I have the same problem. On answered calls, the system is muted for 3-4 seconds. Never had this problem on the 4s.
van_rider is offline  
Old 10-31-2012, 02:09 AM
  #14  
Newbie
 
Join Date: Aug 2012
Location: Indonesia
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
C200 Avantgarde
I have the same problem.... annoying
ptrrespaty is offline  
Old 10-31-2012, 01:49 PM
  #15  
Junior Member
 
achance's Avatar
 
Join Date: Sep 2012
Location: NYC
Posts: 24
Received 0 Likes on 0 Posts
2017 E300 Sport
I have the same problem too on my 2012 C300. I always have to hit the mute button to activate the mic.
achance is offline  
Old 11-01-2012, 04:27 PM
  #16  
MBWorld Fanatic!
 
Petje's Avatar
 
Join Date: Apr 2008
Location: The Netherlands - ROTTERDAM
Posts: 1,123
Likes: 0
Received 2 Likes on 2 Posts
W205 C400
iOS 6.0.1 is available now, May be it will solve the problems ?!
Petje is offline  
Old 11-01-2012, 11:00 PM
  #17  
Member
 
Join Date: May 2012
Location: Dallas-Ft.Worth, TX
Posts: 82
Received 0 Likes on 0 Posts
C43
Originally Posted by Kaewen View Post
I have this issue too. but its a trade off since now you can read your SMS on your command online screen.
How do you do this? I can't figure it out.
Sommy is offline  
Old 11-02-2012, 02:15 PM
  #18  
Member
 
Join Date: Sep 2009
Location: Vancouver, BC
Posts: 155
Received 6 Likes on 5 Posts
2015 E63S
Originally Posted by Sommy View Post
How do you do this? I can't figure it out.
Goto the PHONE menu, then the toolbar at the bottom should have a TEXT MESSAGES option... it will only list new text messages that come in WHILE your connected to the car, and then deletes them all on the car, once you disconnect/shut off the car.
van_rider is offline  
Old 11-02-2012, 05:47 PM
  #19  
Member
 
Join Date: Oct 2011
Location: Austin, Texas
Posts: 84
Likes: 0
Received 0 Likes on 0 Posts
C350/'08 w204
Just bought the 5....same issue on my '08. Weird. I'm not too upset about it though.
Eickecc is offline  
Old 11-03-2012, 10:31 AM
  #20  
Newbie
 
Join Date: Nov 2012
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
CLS AMG 63
Mute Problem

I have the exact same issue with my AMG 63 and new iphone 5.
MattMDK is offline  
Old 11-29-2012, 09:12 AM
  #21  
Newbie
 
Join Date: Nov 2012
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Angry Iphone 5 Answer call delay / mute

Same problem on my C220Sport, when someone gets a fix let me know it's bl**dy annoying especially when you have customers calling every 10 mins
Mark Brown is offline  
Old 11-29-2012, 10:07 AM
  #22  
Newbie
 
Join Date: Nov 2012
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
CLS AMG 63
Originally Posted by MattMDK View Post
I have the exact same issue with my AMG 63 and new iphone 5.
I spoke to Apple this week. They have heard of the issue and said it was also happening with BMW. They said the car company would need to upgrade their control system. I then spoke to Mercedes through teleaide and they claimed to never have heard of the issue and said there is not an upgrade coming in the near future. They recorded the complaint.
MattMDK is offline  
Old 11-29-2012, 10:49 AM
  #23  
Newbie
 
Join Date: Nov 2012
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Unhappy

WINNER
Mark Brown is offline  
Old 12-03-2012, 02:58 AM
  #24  
Junior Member
 
Join Date: Nov 2011
Posts: 26
Likes: 0
Received 0 Likes on 0 Posts
2012 C350
Mercedes did not get the 5 to test compatibility until it was released to the public and they (and other manufacturers) are playing catch up.

Although the 5 does work with our cars, there are some glitches. A command upgrade should be out before the end of the year. A resource to see which phones are fully compatible can be found at:

http://www.mercedes-benz-mobile.com
graphix1998 is offline  
Old 12-13-2012, 12:50 PM
  #25  
Newbie
 
Join Date: Nov 2012
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Question Any Sign of a Software Update Yet?

Has anyone heard if a software update is being actioned to fix the problem when answering the phone and the stupid delay you get?
Mark Brown is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 4.00 average.

Quick Reply: iPhone 5 & answering calls via bluetooth


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: